Problem Report - External monitor switches off when laptop lid is closed

Apologies in advance if this is not the correct place to report issues. Please kindly let me know where to do it and I’ll correct this.

I’ve just installed Manjaro on a laptop.

I normally open the lid only to power up the machine and close it afterwards. When I do that, the external monitor goes blank. It’s a bit annoying to have to keep the lid open to use the external monitor (HDMI connection). I’ve disabled the laptop screen, only the external monitor is active but I still get a blank screen when I close the lid so it’s not the same thing.

The distros I’ve used so far (Ubuntu, Mint) and Windows simply come with a “Do Nothing” option when the lid is closed but Manjaro has no such option. Modifying “/etc/systemd/logind.conf” manually doesn’t help, either.

Thanks for the support.

:+1: Welcome to Manjaro! :+1:

I’m on KDE, but xfce4-power-manager should provide this functionality if I remember correctly.


It definitely does, since on xubuntu 21.04 that function is present, but on manjaro XFCE (I tried myself, and I don’t daily drive manjaro xfce just because of this) this doesn’t work… Maybe it’s a udev rule that canonical adds to system configuration? I would really like if someone which has more experience than me could get this sorted out…

I have the same problem.

I just upgraded to xfce-21.0.7 (new install) from a xfce-20.0 install.

In the 20.0 (and previous releases), all was well.

My setup is the same as OP, one external monitor on HDMI.

The external monitor works fine, as long as the laptop lid is open.

When I close the lid, I also loose the external monitor.

And, I think the user session also crashes?

When I open the lid, the external monitor comes back on, but it’s back at the login screen - not even the ‘unlock’ screen prompt.

I’m happy to do some digging, but I don’t know what to look for.

Thanks for any suggestions.

A bit of progress - from this post:

I added the line:

IgnoreLid=true in /etc/UPower/UPower.conf

I already had the change(s) in /etc/systemd/logind.conf

So now, the external monitor does stay on when the laptop lid is closed. Both while booting (and getting to the login greeter) and once logged-in.

However, all windows are confined to the size of the laptop screen, rather than the larger (in resolution) external monitor.

When dragging a window, the mouse continues to move, and the workspace will wrap at the screen edges - but the window is blocked by the laptop screen size, and does not follow the mouse to the edge of the screen.

So I can’t place any windows towards the right or bottom of the display on the external monitor.

I do have the external monitor set as the primary monitor.

1 Like

Also - I have 2 laptops, and both had Manjaro pre-21 installed.

So I do still have 1 laptop with a fully working external monitor setup.

So, we can compare any config files for changes.

I just don’t know where to look.

I checked in /etc/UPower/UPower.conf, and the setting ‘IgnoreLid’ is false in the working/older Manjaro - so that is not the problem/fix, it’s a workaround that only half works.

I just applied the Manjaro updates from today (aug 27 2021), and it got a bit worse.

At the login screen (with the lid closed), it now uses the correct full resolution for the display (it used to be laptop screen resolution), but the mouse pointer is still at the laptop display resolution (so bigger, out of scale).

That sounds better, but I’d ‘forced’ that in the past (with a ‘display-setup-script’), and it causes problems once logged into a user session.

So when I logged in, the desktop was now the wrong scale - it was using the full resolution, but scaled at the laptop display, on the external monitor - so all way to big to fit on the screen.

AND :-

After a screen blanking, upon wakeup, the mouse pointer is the wrong size (scale) on the desktop background (it’s larger, like for the laptop screen), but in a window, it’s the correct size (for the external monitor).