Display opens but cant boot (xfce)

Hello. I am very new to linux, just loaded manjaro xfce in my laptop 5 days ago and as I tried opening it today, it seems that I cant boot and display stucks at “/dev/nvme0n1p2 clean, 358339/15032320 files, 4100422/60128751 blocks”. I read some posts and tried opening some kind of terminal using “ctrl+alt+f1-f7”, but nothing happens. I also tried rebooting and i just got a “/dev/nvme0n1p2: recovering journal” on top of the previous one. Everything was just fine 2 days ago, drivers seemed updated (not nvidia) and now no response. Any help to a linux noobie here? Thanks.

so entering to TTY on the stuck screen with ctrl + alt + f2 doesnt work? cant you type anything in it? … also did you do the recent system update… can you enter the GRUB menu - repeatidly tap shift during boot, if shift doesnt work tap esc - and switching to a different kernel?

Hey there. It doesnt seem to work no. I can open boot options/grub command line and tried boot from there to runlevel 3, but I cant find the linux line mentioned in the guide (kernel boot guide), only fwsetup and setparams are the boot options available for me.

then youll probably have to chroot.
boot into a live usb of manjaro, open terminal and run this command:
sudo manjaro-chroot -a - you can not use this command if you using btrfs file system, when in chroot run this command:
pacman-mirrors -f 5 && pacman -Syyu - if you get some dependency issues with this command run this instead:
pacman-mirrors -f 5 && pamac update
then uninstall/ reinstall kernels, run this command which kernels are installed on your system:
mhwd-kernel -li and uninstall all of them, for example linux515, linux516 with this command:
mhwd-kernel -r linux516
mhwd-kernel -r linux515
then install again the 5.15 with this command:
mhwd-kernel -i linux515
then run these command:
mkinitcpio -P
systemctl reboot

Do you mean those steps?