Discord update / official Manjaro application package situation

The official Manjaro Discord package is out of date and Discord itself is blocking runtime unless updated (https://support.discord.com/hc/en-us/community/posts/360057789311-Discord-won-t-open-on-Linux-when-an-update-is-available?page=1). This user-toxic behavior on the part of Discord makes me wonder if Manjaro should either:

  • Make an exception for Discord and release updates to the official repository immediately
    or
  • No longer support Discord in the official repository, since it doesn’t always work from there, like now

I’m in favor of either option, and really this is Discord’s fault, not Manjaro’s. However, as a Manjaro user, every other official application package I have installed works consistently, so this is a blemish on that otherwise-perfect record.

That all being said, is there a current way to enjoy having Discord installed always on Manjaro without having to resort to unsupported workarounds such as editing json data to trick Discord into thinking it’s updated, or manually installing via Discord’s tar.gz package link in the “lucky day” prompt’s dropdown? If there’s an AUR package that works around this, I’m interested.

The Discord package on the official Arch repository has the same issue, according to Arch users posting in the Discord issue thread linked. I’m interested in what options are available.

2 Likes

Well, Manjaro does do that ─ that was also the case the previous time Discord pulled that stunt. It just takes a few days. :man_shrugging:

As a Discord user myself, I agree with you that it’s absolutely toxic behavior from the Discord developers. :-1:

4 Likes

It’s possible to edit the JSON directly for version info?

Any clue where that is? I’d take a look!

I haven’t tried it myself, but the post at https://support.discord.com/hc/en-us/community/posts/360057789311/comments/360009476712 describes how to do this.

You can use instead flatpak, snap, appimage or AUR but unfortunately, none of them has not yet been updated to 0.12. I wonder who will be first :wink:

Thanks!

I’ll go look. It’s likely to be fixed in the next few days (as Tomek mentioned) but it is definitely annoying that Discord does this.

When it kept sending me to update, I had to double-take what OS I was running! I’m not used to this kind of stunt on Linux.

1 Like

Another alternative – DIY Discord :smiley:

Is the same for Arch
https://www.archlinux.org/packages/community/x86_64/discord/
Already flagged out of date.

Maybe use the PKGBUILD yourself, locally
you have to change from 11 to 12 …
then run:
makepkg -si
or maybe
makepkg -csi

https://wiki.manjaro.org/index.php?title=Makepkg

Well a temporary solution for me was downloading the tar.gz update file, extracting it and running the discord file inside the folder. I’m a newbie so this probably isn’t the best solution but just wanted to mention it for someone who is wondering how to make it work until it’s updated.

The previous related discussion, and some good ideas.

2 Likes

It looks like the same proposals were made in that thread as well: Discord support should either be dropped or Discord somehow updated extremely quickly, since having significant periods of time during which the application does not work without hacking it oneself isn’t ideal for an official package.

There’s no such thing. Arch received explicit permission from Discord to package it in their community repo. We import it from Arch like most packages. I believe last time it was fast tracked to all branches. I’m at work so I can’t check if we have an overlay package or not.

1 Like

OK, that makes sense. So, this is up to Arch maintainers for now, if I’m understanding correctly. I have applied the hack to /opt/discord/resources/build_info.json for now, and I’m hoping Arch maintainers contact Discord to ask them to fix their software. Thank you for the info!

Arch has its own permission to distribute the package. We have ours. So I pushed the update to all branches. Happy chatting.

7 Likes

I am sorry, but what does that mean? pacman -Syyu results in no new updates, and the wiki @ wiki.manjaro . org/index.php?title=Pacman_Overview does not say anything about "Box it Memo"s or what we are supposed to do now to get this new update you just pushed. The only package discorvery website I could found discover.manjaro . org/applications/discord and gitlab . manjaro.org/packages/community/discord both state version 0.0.10.2 which is clearly not correct (??)

Thanks!

I was able to see the update by navigating to the “Updates” tab in Pamac. I wonder why CLI pacman would act any differently for you.

1 Like

Not all of the mirrors are synced at the same time. :wink:

1 Like

Oops, my bad! I still had the Arch Linux package installed (same issue from last time). I ran pacman -S discord and then upgraded again – it worked this time.

1 Like

This topic was automatically closed 3 days after the last reply. New replies are no longer allowed.