CONFIG_TASK_DELAY_ACCT error in "iotop" kernel 5.14

Using kernel 5.14.7-2-MANJARO
iotop shows an error

CONFIG_TASK_DELAY_ACCT not enabled in kernel, cannot determine SWAPIN and IO %

now showing SWAPIN column unavailable.

Have you tried this?

Yes, adding “delayacct” as a kernel parameter works, but I’m trying to find the root of the problem.

I created a bug report in CONFIG_TASK_DELAY_ACCT error in “iotop” kernel 5.14 · Issue #21 · Tomas-M/iotop · GitHub

I’m trying to find what changed between 5.13 and 5.14 that made this behaviour change.

CONFIG_TASK_DELAY_ACCT is enabled by default

1 Like

I was reporting a bug in the wrong repo. That was the C version of iotop.

The python version in “community” repo is Public Git Hosting - iotop.git/summary
But I don’t know how to report a bug in that.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.