Chromium based browser glitching in latest update

{chromium , Brave} => the dont work properly with hardware acceleration enabled
***disabling it leads to bad performance thats not acceptable

***problems faced =>
icons not loding specially when playing yt videos and hovering over them again generates flickering

any solutions??

Welcome to the forum! :wave:

Please post your system info as outlined here:

Please also see:

I am using a raspberry pi 4(2 gb)

  Kernel: 6.1.16-2-MANJARO-ARM-RPI arch: aarch64 bits: 64 compiler: gcc
    v: 12.1.0 parameters: coherent_pool=1M 8250.nr_uarts=0
    snd_bcm2835.enable_headphones=0 snd_bcm2835.enable_headphones=1
    snd_bcm2835.enable_hdmi=1 snd_bcm2835.enable_hdmi=0
    video=HDMI-A-1:1920x1080M@60 smsc95xx.macaddr=DC:A6:32:CA:89:7A
    vc_mem.mem_base=0x3ec00000 vc_mem.mem_size=0x40000000
    root=PARTUUID=aa7fddd0-02 rw rootwait console=ttyS0,115200 console=tty3
    selinux=0 quiet splash plymouth.ignore-serial-consoles
    smsc95xx.turbo_mode=N dwc_otg.lpm_enable=0 usbhid.mousepoll=8 audit=0
  Desktop: KDE Plasma v: 5.27.2 tk: Qt v: 5.15.8 wm: kwin_wayland vt: 2
    dm: SDDM Distro: Manjaro ARM base: Arch Linux
  Type: ARM System: Raspberry Pi 4 Model B Rev 1.2 details: BCM2835 rev: b03112
    serial: <filter>
  Message: No system battery data found. Is one present?
  RAM: total: 1.88 GiB used: 1.11 GiB (59.0%) gpu: 76 MiB
  RAM Report: unknown-error: Unknown dmidecode error. Unable to generate
  Info: model: N/A variant: cortex-a72 bits: 64 type: MCP arch: ARMv8 family: 8
    model-id: 0 stepping: 3
  Topology: cpus: 1x cores: 4 smt: N/A cache: L1: 320 KiB
    desc: d-4x32 KiB; i-4x48 KiB L2: 1024 KiB desc: 1x1024 KiB
  Speed (MHz): avg: 600 min/max: 600/1500 scaling: driver: cpufreq-dt
    governor: schedutil cores: 1: 600 2: 600 3: 600 4: 600 bogomips: 432
  Features: asimd cpuid crc32 evtstrm fp
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed status: Not affected
  Type: spec_store_bypass status: Vulnerable
  Type: spectre_v1 mitigation: __user pointer sanitization
  Type: spectre_v2 status: Vulnerable
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: bcm2711-hdmi0 driver: vc4_hdmi v: N/A bus-ID: N/A
    chip-ID: brcm:fef00700 class-ID: hdmi
  Device-2: bcm2711-hdmi1 driver: vc4_hdmi v: N/A bus-ID: N/A
    chip-ID: brcm:fef05700 class-ID: hdmi
  Device-3: bcm2711-vc5 driver: vc4_drm v: N/A bus-ID: N/A chip-ID: brcm:gpu
    class-ID: gpu
  Display: wayland server: v: with: Xwayland v: 22.1.8
    compositor: kwin_wayland driver: X: loaded: modesetting alternate: fbdev
    dri: vc4 gpu: vc4_hdmi,vc4_hdmi,vc4_drm display-ID: 0
  Monitor-1: HDMI-A-1 res: 1920x1080 size: N/A modes: N/A
  API: OpenGL v: 2.1 Mesa 22.3.7 renderer: V3D 4.2 direct-render: Yes
  Device-1: bcm2711-hdmi0 driver: vc4_hdmi bus-ID: N/A chip-ID: brcm:fef00700
    class-ID: hdmi
  Device-2: bcm2711-hdmi1 driver: vc4_hdmi bus-ID: N/A chip-ID: brcm:fef05700
    class-ID: hdmi
  API: ALSA v: k6.1.16-2-MANJARO-ARM-RPI status: kernel-api
    tools: alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 0.3.66 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: bcm2835-mmc driver: mmc_bcm2835 v: N/A port: N/A bus-ID: N/A
    chip-ID: brcm:fe300000 class-ID: mmcnr
  IF: wlan0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: dynamic noprefixroute scope: global
  IP v6: <filter> type: noprefixroute scope: link
  Device-2: bcm2711-genet-v5 driver: bcmgenet v: N/A port: N/A bus-ID: N/A
    chip-ID: brcm:fd580000 class-ID: ethernet
  IF: end0 state: down mac: <filter>
  WAN IP: <filter>
  Device-1: pl011 driver: uart_pl011 bus-ID: N/A chip-ID: arm:fe201000
    class-ID: serial
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Device-2: pl011 driver: N/A bus-ID: N/A chip-ID: arm:serial0
    class-ID: serial
  Report: This feature requires one of these tools: hciconfig/bt-adapter
  Message: No logical block device data found.
  Message: No RAID data found.
  Local Storage: total: 59.48 GiB used: 6.61 GiB (11.1%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/mmcblk0 maj-min: 179:0 model: SL64G size: 59.48 GiB block-size:
    physical: 512 B logical: 512 B type: SSD serial: <filter> scheme: MBR
  Message: No optical or floppy data found.
  ID-1: / raw-size: 59 GiB size: 58.01 GiB (98.32%) used: 6.56 GiB (11.3%)
    fs: ext4 dev: /dev/mmcblk0p2 maj-min: 179:2 label: ROOT_MNJRO
    uuid: d0365520-aedf-4d98-a77b-350122736c3f
  ID-2: /boot raw-size: 457.8 MiB size: 457.5 MiB (99.94%)
    used: 55.7 MiB (12.2%) fs: vfat dev: /dev/mmcblk0p1 maj-min: 179:1
    label: BOOT_MNJRO uuid: 14E9-C189
  Kernel: swappiness: 60 (default) cache-pressure: 80 (default 100)
  ID-1: swap-1 type: zram size: 2.71 GiB used: 333.5 MiB (12.0%)
    priority: 100 dev: /dev/zram0
  Message: No unmounted partitions found.
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 1 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: VIA Labs Hub ports: 4 rev: 2.1 speed: 480 Mb/s
    power: 100mA chip-ID: 2109:3431 class-ID: 0900
  Device-1: 1-1.3:3 info: SINO WEALTH Gaming KB type: Keyboard,HID
    driver: hid-generic,usbhid interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 500mA
    chip-ID: 258a:002a class-ID: 0300
  Device-2: 1-1.4:4 info: Dell MS116 Optical Mouse type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 2.0 speed: 1.5 Mb/s
    power: 100mA chip-ID: 413c:301a class-ID: 0301
  Hub-3: 2-0:1 info: Super-speed hub ports: 4 rev: 3.0 speed: 5 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  System Temperatures: cpu: 43.3 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 194 Uptime: 34m Init: systemd v: 253 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 Packages: pm: pacman pkgs: 750
  libs: 189 tools: pamac Shell: Bash v: 5.1.16 running-in: konsole inxi: 3.3.26

I don’t believe hardware acceleration works on most ARM devices. @spikerguy could most likely clarify and provide more information.

few months ago i used it and it was working fine then when i tried in recent days it started doing this

Hardware acceleration in Chromium based browsers to begin with is hit and miss. The recent comments in this Arch Linux Forum post may help: chromium: hardware video acceleration with VA-API / Applications & Desktop Environments / Arch Linux Forums

I do not know of hardware acceleration working under a DE for the rpi. It will work on certain video formats (mp4/hevc) when booted into a properly installed kodi-rpi not running in a DE.

I do not use Plasma but there has been issues in the past with Plasma/Wayland that has popped up. I believe If it was me I would switch over to the testing branch and update all of the packages. Maybe a newer version of mesa/Plasma/kernel would help since things worked for you a while back with out the artifacts.


Hi, nice to read you :slight_smile:

1 Like

testing version didn’t help still the same problem