Can't start a vm inside VirtualBox

Can’t start a vm (windows 10 /11/ fedora 38) , after doing everything the right way , trying to install manually , automatically ,starting vm’s with and without EFI mode enabled , i get the same screen , which shows that vm is loaded 20%(Powering VM up 20%) , and the vm screen is just black with “starting virtual machine” box , which I can’t close , and can’t exit by any means (i can close the main program , but can’t close the vm screen , can’t restart the computer , only can turn off by pressing power button).
Can’t pin the screenshot , maybe I’ll try to show it in the comments if I can

Hi @mnwr,

I don’t know if that’s even possible. But someone else might. In any case, thought you would find this handy:

1 Like

thank you
screenshot :

1 Like

How did you install virtualbox?

Please provide the output of:

pamac list --installed | grep virt
1 Like

And you have to reboot after installing the packages to load the modules.
Or you gave it so much memory that your host is exhausted. Your error description might indicate this.
Did you set up swap?

1 Like

It came pre-installed I think , or I installed it through package manager
i gave it 4 mb ,1 cpu maybe too little ?

This might be a typo, but 4 MB is definitely not enough - 4 GB will work in almost all cases …

… and: 1 (virtual) CPU out of how many actually available?
just use all - or at least half of what is there - the allocated memory is much more important
the number of CPU’s just affect the “speed”

ok , after reinstalling oracle vm ,doing the memory tempering suggested by user Nachlese, installing extensions of my version of oracle , getting the same error as in , updating kernels , doing everything by the guide , i still have the same problem ? :rofl:
any help :woozy_face:

I’ll ask the same as previously:

There is no issues with VirtualBox as such and VirtualBox is not preinstalled on any Manjaro ISO.

I am using it on a daily base (Windows 10)

Did you ensure your host system is usable?

Did you ensure your system supports virtualization and virtualization is enabled in the firmware?

Did you ensure that the linuxXY-virtualbox-host-modules matching your installed kernel?

Did you restart your system or did you run

sudo vboxreload

Almost any system you want to run virtual will require 2-4 vcpu and 2-4 GB RAM with 32MB videoram.

Please provide some system info (provide link - same method as you image)

inxi -Fc0 | curl -F 'f:1=<-'

You don’t need the extension pack for core VirtualBox VMs (AUR) - in fact the difference between Manjaro stable and Arch - makes the extension pack a hit or miss.

Please list the vm’s configuration (provide link - same method as you image)

vboxmanage showvminfo <vmname> | curl -F 'f:1=<-'

Hey mnwr,

it seems that you have the same problem than me (here was my case: Virtualbox 7.0.8-2). I began to think that i was alone with the problem.

For me, the hint from @coolfreezer did the job. I had to do:

  1. sudo nano /etc/default/grub
  2. edit the line “GRUB_CMDLINE_LINUX_DEFAULT”
  3. and insert the entry “ibt=off”

After a reboot all my virtual machines worked, even with the extension pack installed. But be carefull! I am still searching what i turned off with this entry.

That’s no longer necessary with virtualbox 7.0.10-1, FYI.