Can't reinstall video-modesetting : Error: config 'video-modesetting' is not installed"

I’m trying to boot an manjaro live usb (gnome), but since after the grub it get stuck in a black screen, i edited the grub to ‘nomodeset’, managed to long in the TTY terminal, and tried to do :

pacman -Syyu
mhwd-kernel -r linux515
then reinstall video drivers:
mhwd -r pci video-modesetting
mhwd -r pci video-linux

…as suggested on another link from this forum. But i cannot remove the kernel (i guess because the live image have only one, while the person who made the question had more), and when i tried to remove the “video-modesetting” i got the output:
Error: config ‘video-modesetting’ is not installed"

This is the output of mhwd-kernel -li && mhwd -l && mhwd -li :

THe following kernels are installed in your system:

  • linux515
    Warning : config ‘/var/lib/mhwd/pci/network_drivers/r8168/MHWDCONFIG’ is invalid"
    Warning : config ‘/var/lib/mhwd/pci/network_drivers/rt3562sta/MHWDCONFIG’ is invalid"
    0000:00:01.0 (0300:1002:9874) Display controller ATI Technologies inc:
name                                version           freedriver             type
video-linux                      2018.05.04             true                  PCI
video-modesetting                2020.01.13             true                  PCI
video-vesa                      2017.03.12              true                   PCI

Instaled PCI configs:

name                                version           freedriver             type
video-linux                      2018.05.04             true                  PCI

you want to reinstall drivers from the live usb? well good luck with that haha …
use ventoy to to flash iso
secure boot needs to be disabled
fast boot needs to be disabled - you may not have this option
fast startup needs to be disabled from windows if you are dual booting
AHCI needs to be enabled
and boot ventoy in uefi or legacy/bios mode depending on what you are using

1 Like

Hi, thanks, i just tried that, but still couldn’t solve the black screen. I have been trying everything on google for almost 1 week:

Tried several Grub modifications, but i still can’t install Manjaro. It works on another Pc, just not in this one. So i think it might be a problem with linux instalations, since i can install windows on it … But i’m not sure.
The motherboard BIOS is the last version, and it dosen’t seems to be incompatible with linux, so i don’t know what to do next. If you have any tips to get me going, it would help a lot.

fast startup is disabled in windows?
did you try with different usb?

Yes, i installed Manjaro in 2 diferent usb from a notebook using both CSM and UEFI boot options before, using mkusb and balena etcher. All combinations booted normally on the notebook in questions, but all of them caused black screen on the Pc.
With ventoy, i only tried to boot on the Pc, not on the notebook. I only tested it with 1 pendrive, and i think the boot option used during the creation of the ventoy usb was UEFI.
And yes, the BIOS of the Pc have fast boot and secure boot disabled, and ahci on.

But just to be clear, the Pc has no windows anymore. I formated it into Ubuntu to test it, and after an sucefull instalation, it got stuck in the black screen. So i tried Manjaro, and some other linux live usbs, none worked.

I’m downloading Windows 10, just to see if it will work as before, but what i really need to install, is manjaro.

In case it helps, those links i sent before are from previous posts i made, explaining several tests and the results. But nothing really worked so far.

so when there was installed windows you were able to boot into live usb of ubuntu and after formatting/installing ubuntu it got stuck?
thats a good idea to try installing windows

1 Like

Kinda. I bought it a week ago, it had windows 10 working normally, i immediately installed Ubuntu using a live usb (from that old classical GUI instalation mode) and the black screen started.
I’ll try windows 10 now and see how it goes.

yes but you were able to boot normally into ubuntu usb, thats what im saying … and did you formatted the whole disk, when you installed ubuntu?

Oh, sorry. I was able to boot into Ubuntu Grub (as well as Manjaro and Gparted Grub), and after that i was able to successfully install Ubuntu in the whole disk, using the recommended instalation process. But besides that, no, i was never able to boot and use/experiment any linux Os. It never even showed the logo of ubuntu/manjaro. Its like it can’t load any graphical stuff.
All Gparted live, Ubuntu and Manjaro usb live, none of them ever sucefully booted into desktop in this Pc, but all of them sucefully booted on this notebook.

so you are able to boot with the usbs on a notebook but not on the desktop?
how is the windows installation looking?

Yes, exactly. Every time it didn’t worked on the Pc, i tested on the notebook and it worked.
The windows 10 instalation seems to be working just fine, so far. It’s installing.

ok, did you choose now to format the whole disk for installing windows?

Yes, i deleted the two linux partitions and windows created 3 partitions. Its installing right now. Lets see if windows will boot normally as before.

The windows 10 was installed and successfully booted. I didn’t do anything different on the installation process other then the Os itself. Same BIOS configuration. Same notebook to build the live pendrive. So the problem is Linux compatibility with my motherboard ? The problem is that i already read my motherboard manual and found only 1 mention to linux, wich didn’t helped.
I have being installing all sorts of Linux distros for years, full installations, live usb, persistent live usb. Nothing like this ever happened.
I think i will try to make a new Manjaro pendrive using Ventoy (such a great suggestion, thanks!) from windows this time, because i don’t know what to do anymore.

disable fast startup in windows first and then try booting into manjaro usb, and see if it helped

Done, but the results were the same
The BIOS fast boot option is disabled, as well as secure boot.
I tried both Manjaro and Ubuntu live this time. Both of them still ends in a black screen.
Both pendrives made trough ventoy from windows, on the problematic Pc.

Windows is working, but No linux image seems to

im talking about fast startup in windows, that needs to be disabled too:

1 Like

Oh, sorry., my bad.
So, i disabled it and tried again, but nothing changed.
I tried to boot Manjaro normaly, and then changing the grub to nomodeset. But it ended in the same black screen again.

ok, what graphics are you using? intel or amd or nvida or dual graphics?