Another Live Manjaro BIOS /black screen / Grub problem

I bought the following pc :

  • Os = Windows 10
  • CPU/GPU = amd a6-7480 radeon r5
  • Motherboard = msi a68hm-e33 v2
  • BIOS version = 7721v85 (latest)

And it was working normally, until i formatted it with the latest Ubuntu. Now it won’t boot the hard drive (Ubuntu), Live Usb (Manjaro and Gparted) and External Hd (Lubuntu).

So my plan is to use the live manjaro to make a instalation.

Bios configuration:

  • Fast Boot = Disabled
  • Windows8/10 Feature : Disabled.
  • ** * Secure boot = Disabled**
  • Existing boot modes = “UEFI” and “Legacy and UEFI”
  • Option to Enable IOMMU = Don’t exist.

How i created the live pendrives : Using Mksub and balenaetcher, on a second computer. The BIOS mode of the second computer during the creation of the live USB was CSM, and also UEFI.

Note : The external HD and the live pendrive worked on another computer.

What happens after BIOS :
Manjaro live pendrive starts the grub, and after selecting to boot it starts loading those terminal like lines and suddenly stops in a black screen.
Gparted Shows the grub, but after selecting to boot it keep outputing the error ‘error reading sector’
Ubuntu Hd shows two lines of code, and then goes black.
Lubuntu External Hd goes straigh to a black screen.

What worked a little : Replacing the Grub with nomodeset, Manjaro finished loading those lines of code now, and the following black screen now allows me to enter TTY:

The output of inxi --admin --verbosity=7 --filter --width :
cpu dual core amd a6-7480 Radeon R5 8 Compute Cores 2c+6G (-MT MCP-) speed/min/max : 1529/1400/3500 Mhz Kernel: 5.15.60-1-MANJARO x86_64 Up: 4m Rem: 1248.3/7404.5 MIB (16.9%) Storage: 0/473.26 Gib Procs: 127 Shell: Zsh 5.9 Inxi: 3.3.20