Cant mount secondary HDD

No idea what mdadm is. I just opened Dolphin, and tried to access the drive. Anyways, here the output of
the detail command:

         Container : /dev/md/ddf0, member 7
        Raid Level : raid0
        Array Size : 976223232 (931.00 GiB 999.65 GB)
      Raid Devices : 1
     Total Devices : 1

             State : clean 
    Active Devices : 1
   Working Devices : 1
    Failed Devices : 0

        Chunk Size : 64K

Consistency Policy : none

    Container GUID : 44656C6C:20202020:10000073:10281F51:4AF30405:C62ACCFB
                  (Dell     11/05/19 10:57:41)
               Seq : 00000020
     Virtual Disks : 9

    Number   Major   Minor   RaidDevice State
       0       8       16        0      active sync   /dev/sdb

It is a Raid0 with FakeRaid (BIOS Raid). Raid0 must have at least 2 drives, but there is only one drive:

Where does this disk come from? If there is no second drive, then the files are gone, since RAID0.

Is it probably an Intel Optane Cache?


Not sure, I’ll check when I get home from work in the evening. If it is Optane, I turned off UEFI and switched to legacy, (only Windows Boot Manager and network boot would show up in boot sequence) would that have an effect?

You’ll have to provide more information about your system and setup, otherwise we’ll just end up going off on unrelated tangents and wild goose chases.

You haven’t even said if this is a laptop. If this is a new purchase. If this “secondary” drive was included with the computer or installed afterwards.

Were you successfully using this drive prior to installing Manjaro? Was it gifted from a friend? Is there valuable data on it?

We’re going in blind here.

I’m using an upgraded Optiplex 3010, which I’ve had for 2 years and has ran fine. (except for windows, of course) The HDD in question was working normally before I switched to Manjaro, and there is valuable data on it. The HDD is a Hitachi HUA722010CLA330, and my boot drive is a PNY CS900 240GB SSD. Looking up the specs of the Optiplex 3010, it appears these drives were installed afterwards. It doesnt appear that I have Optane, though I’m not completely sure how to check. My general system specs are the following:

Processors: 4 × Intel® Core™ i5-3470 CPU @ 3.20GHz
Memory: 15.6 GiB of RAM
Graphics Processor: AMD Radeon RX 470 Graphics
Manufacturer: Dell Inc.
Product Name: OptiPlex 3010
System Version: 01

Here is a common list of what needs to be changed on the BIOS/UEFI Settings:

My guess is that RAID is enabled on your UEFI and you need to switch to AHCI.

As stated in the forth reply,

I tried to follow the UEFI install guide on the wiki, and if all went well, I would have had UEFI working right now. However, Gparted says on my SSD, I only have 2mb of space to resize.
I don`t know how to proceed. Could anyone kindly help?

Yes, but what about the other points in @megavolt’s post?

Such as: RAID → AHCI

Working normally under Windows? Do you remember how you initially configured it or formatted it?

You’re not using an Intel Optane drive, evident from the specs you shared (Hitatch 2.5" HDD and PNY SSD).

You’re treading into precarious grounds now. Be careful. Are you able to access the data on the Hitachi HDD from within Windows? If so, I’d backup everything for peace of mind.


No, I have not configured or formatted the drive since I first installed Windows.

The Windows installation is completely gone, I intentionally formatted the drive with the Windows installation.

But did it work normally under Windows? And does it still work normally under Windows in which you can access the data?



@winnie Edited my last reply right as you sent yours, check mine again.

I guess it is ext4 file system. Therefore you can only grow the partition when mounted. To move or shrink it, it have to be unmounted. If it is the system partition, so the root directory, it have to be done on a live session.

You still have the option to test out the other changes mentioned by @megavolt. (AHCI mode for SATA, for example.)

An “inxi dump” would really help as well:

inxi --full --admin --verbosity=7 --filter --no-host
1 Like

SATA was already set to AHCI before I installed Manjaro, and still is. Here’s the output of the dump command:

  Kernel: 5.15.71-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=206c8d41-a472-47ba-b70d-5a64b7e9c848 rw quiet
  Desktop: KDE Plasma v: 5.25.5 tk: Qt v: 5.15.6 wm: kwin_x11 vt: 1
    dm: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Desktop System: Dell product: OptiPlex 3010 v: 01
    serial: <superuser required> Chassis: type: 6 serial: <superuser required>
  Mobo: Dell model: 042P49 v: A01 serial: <superuser required> BIOS: Dell
    v: A09 date: 01/31/2013
  Message: No system battery data found. Is one present?
  RAM: total: 15.6 GiB used: 1.53 GiB (9.8%)
  RAM Report: permissions: Unable to run dmidecode. Root privileges
  Info: model: Intel Core i5-3470 bits: 64 type: MCP arch: Ivy Bridge
    gen: core 3 level: v3 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 2512 high: 3193 min/max: 1600/3200 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1597 2: 3193 3: 2067
    4: 3193 bogomips: 25554
  Flags: acpi aes aperfmperf apic arat arch_perfmon avx bts clflush cmov
    constant_tsc cpuid cpuid_fault cx16 cx8 de ds_cpl dtes64 dtherm dts epb
    ept erms est f16c flexpriority flush_l1d fpu fsgsbase fxsr ht ibpb ibrs
    lahf_lm lm mca mce md_clear mmx monitor msr mtrr nonstop_tsc nopl nx pae
    pat pbe pcid pclmulqdq pdcm pebs pge pln pni popcnt pse pse36 pti pts
    rdrand rdtscp rep_good sep smep smx ss ssbd sse sse2 sse4_1 sse4_2 ssse3
    stibp syscall tm tm2 tpr_shadow tsc tsc_deadline_timer vme vmx vnmi vpid
    x2apic xsave xsaveopt xtopology xtpr
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Ellesmere [Radeon RX 470/480/570/570X/580/580X/590] vendor: PC
    Partner / Sapphire driver: amdgpu v: kernel arch: GCN-4
    code: Arctic Islands process: GF 14nm built: 2016-20 pcie: gen: 3
    speed: 8 GT/s lanes: 16 ports: active: DP-2 empty: DP-1, DVI-D-1,
    HDMI-A-1, HDMI-A-2 bus-ID: 01:00.0 chip-ID: 1002:67df class-ID: 0300
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: amdgpu unloaded: modesetting alternate: fbdev,vesa gpu: amdgpu
    display-ID: :0 screens: 1
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.00x11.22")
    s-diag: 582mm (22.93")
  Monitor-1: DP-2 mapped: DisplayPort-1 model: Viewteck GFV24C built: 2019
    res: 1920x1080 hz: 60 dpi: 92 gamma: 1.2 size: 530x280mm (20.87x11.02")
    diag: 599mm (23.6") modes: max: 1920x1080 min: 720x400
  OpenGL: renderer: AMD Radeon RX 470 Graphics (polaris10 LLVM 14.0.6 DRM
    3.42 5.15.71-1-MANJARO) v: 4.6 Mesa 22.1.7 direct render: Yes
  Device-1: Intel 6 Series/C200 Series Family High Definition Audio
    vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 1-1.1:3
    bus-ID: 00:1b.0 chip-ID: 0d8c:0134 chip-ID: 8086:1c20 class-ID: 0300
    class-ID: 0403
  Device-2: AMD Ellesmere HDMI Audio [Radeon RX 470/480 / 570/580/590]
    vendor: PC Partner / Sapphire driver: snd_hda_intel v: kernel pcie: gen: 3
    speed: 8 GT/s lanes: 16 bus-ID: 01:00.1 chip-ID: 1002:aaf0 class-ID: 0403
  Device-3: C-Media TONOR TC-777 Audio Device type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Sound Server-1: ALSA v: k5.15.71-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 16.1 running: yes
  Sound Server-4: PipeWire v: 0.3.58 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Dell driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: d000 bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8
    bus-ID: 2-1.4:3 chip-ID: 0bda:8771 class-ID: e001 serial: <filter>
  Report: rfkill ID: hci0 rfk-id: 0 state: up address: see --recommends
  Message: No logical block device data found.
  Supported mdraid levels: raid0
  Device-1: md126 maj-min: 9:126 type: mdraid level: raid-0 status: active
    size: 931 GiB
  Info: report: N/A blocks: 976224256 chunk-size: 64k
  Components: Online:
  0: sdb maj-min: 8:16 size: 931.51 GiB
  Device-2: md127 maj-min: 9:127 type: mdraid level: N/A status: inactive
    size: N/A
  Info: report: N/A blocks: 538328 chunk-size: N/A
  Components: Online: N/A Spare:
  0: sdb maj-min: 8:16 size: 931.51 GiB state: S
  Local Storage: total: raw: 1.13 TiB usable: 223.06 GiB used: 53.22 GiB
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: PNY model: CS900 240GB SSD
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: <filter> rev: 0BB3 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Hitachi model: HUA722010CLA330
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: A3EA
  Optical-1: /dev/sr0 vendor: HL-DT-ST model: DVD+-RW GHA2N rev: A103
    dev-links: cdrom
  Features: speed: 48 multisession: yes audio: yes dvd: yes
    rw: cd-r,cd-rw,dvd-r,dvd-ram state: running
  ID-1: / raw-size: 223.57 GiB size: 219 GiB (97.96%) used: 53.22 GiB (24.3%)
    fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: N/A
    uuid: 206c8d41-a472-47ba-b70d-5a64b7e9c848
  Alert: No swap data was found.
  ID-1: /dev/md126p1 maj-min: 259:0 size: 931 GiB fs: ntfs label: New Volume
    uuid: AE0C6A050C69C8C3
  Hub-1: 1-0:1 info: Full speed or root hub ports: 2 rev: 2.0 speed: 480 Mb/s
    chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 1-1:2 info: Intel Integrated Rate Matching Hub ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 1-1.1:3 info: C-Media TONOR TC-777 Audio Device type: Audio,HID
    driver: hid-generic,snd-usb-audio,usbhid interfaces: 3 rev: 1.1
    speed: 12 Mb/s power: 100mA chip-ID: 0d8c:0134 class-ID: 0300
  Hub-3: 2-0:1 info: Full speed or root hub ports: 2 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-4: 2-1:2 info: Intel Integrated Rate Matching Hub ports: 6 rev: 2.0
    speed: 480 Mb/s chip-ID: 8087:0024 class-ID: 0900
  Device-1: 2-1.4:3 info: Realtek Bluetooth Radio type: Bluetooth
    driver: btusb interfaces: 2 rev: 1.1 speed: 12 Mb/s power: 500mA
    chip-ID: 0bda:8771 class-ID: e001 serial: <filter>
  Device-2: 2-1.5:4 info: USB OPTICAL MOUSE type: Mouse
    driver: hid-generic,usbhid interfaces: 1 rev: 1.1 speed: 1.5 Mb/s
    power: 100mA chip-ID: 0000:0538 class-ID: 0301
  Device-3: 2-1.6:5 info: China Resource Semico USB Keyboard
    type: Keyboard,Mouse driver: hid-generic,usbhid interfaces: 2 rev: 1.1
    speed: 1.5 Mb/s power: 500mA chip-ID: 1a2c:4b81 class-ID: 0301
  System Temperatures: cpu: 32.0 C mobo: N/A gpu: amdgpu temp: 26.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1679
  Processes: 220 Uptime: 2m wakeups: 0 Init: systemd v: 251
  default: graphical tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6
  Packages: pm: pacman pkgs: 1349 libs: 406 tools: pamac pm: flatpak pkgs: 0
  Shell: Zsh v: 5.9 default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.21
    ~                                                                        

The heck is going on here? There are references to TWO different RAID arrays; both apparently using /dev/sdb as an underlying device.

MDADM software RAID… NTFS… level 0… only one drive?

Were you the original owner of this computer and its components, including the drives? This is non-standard. Someone has to go out of there way to do this.

Your BIOS settings are supposedly fine: SATA mode is AHCI. No Intel Optane.

Did you use some sort of RAID feature while under Windows? Dynamic storage? Something? Since you completely removed Windows altogether, it makes it more tricky to backtrack on what you did.

No, I received it as a gift from my uncle, who made the modifications to the hardware. No modifications have been made since I began to daily-drive it. There is no way of contacting him, as he passed away 2 years ago.

No idea.

I’m sorry to hear.

The data might be lost, if it is in fact from a two-drive RAID-0 array.

However, you can try a last ditch shot. (Since “RAID-0” might mean something different in this case, such as a single drive “stripe” array.)

Try to forcefully start the array and mount it as a read-only NTFS filesystem in a temporary mount point. If it’s accessible, you can copy all the data to another drive, such as an external USB.

I tried a live session and found I have no MBR or GPT on /dev/sda1. I’d rather not completely reinstall manjaro, as I’ve already taken up 25% of the available storage. Any ideas?

It looks like it was created within a “DDF” container (Disk Data Format).

Not sure if it was done via some software under Windows.

If you want to give this a shot:

sudo mkdir /mnt/temp

sudo mount -t ntfs3 -o ro /dev/md126p1 /mnt/temp

Wow, it worked! Thanks.