Canon G7020 Printer Not Printing After Upgrade

I have a Canon G7020 printer/scanner that has been working flawlessly until I upgraded to Manjaro 24 KDE. Now, when I print, it prints blank. I tried deleting the printer, then even deleted the cnijfilter2, then tried to re-install the cnijfilter2, but it aborts before finishing the install. Without the cnijfilter2, the printer install doesn’t find the driver. The system is fully updated with the latest Kernel, Manjaro, and KDE updates. Any help would be greatly appreciated.

I presume you meant Manjaro 24 KDE.

It seems you’ve been in this predicament before and with much the same problem.

Perhaps you can find something useful in your previous thread from August 2023, which I notice you didn’t bother to mark as solved:

A decent strategy is to note any procedures used to fix an issue; perhaps in a notebook; so that you’re not forever returning to the same issue without a clue.

As cnijfilter2 is from the AUR, I’d also suggest it likely needs to be rebuilt; as AUR sourced software often needs to be after an update.

pamac build cnijfilter2

Note that the AUR is officially unsupported by Manjaro (or Arch, for that matter).


Actually, I did go back to my notes, as well as the old post, and did the same thing. That method has always worked…until now. When trying to build cnijfilter2, either through AUR, or doing it the way you suggested (thank you), it goes through the build, and aborts right at the end. Apologies for not having closed out the previous thread. I’ll remember to do that this time around when solved.

BTW, you were correct, it was 24. I have corrected the original post.

Thanks for explaining.

Your description now indicates that it’s likely a problem with the AUR build itself; which has nothing to do with Manjaro.

Your best resolve is to contact the maintainer of cnijfilter2 via the AUR, and explain your issue. That said, I notice it hasn’t been updated for a while (since 2023-07-30), so perhaps they need a gentle nudge.

There’s also a user comment (2024-06-10) mentioning a build failure resulting in an aborted process; likely the same as your experience.

I can only wish you luck.


Thank you. I just left a message on the maintainer board. So, short of them actually updating the build, is there anything else I can do to get this printer running? I don’t need every function, just printing would be fine.

As a side note, the scanner function of the G7020 works flawlessly after installing sane-airscan. Is there perhaps a generic printer driver that would work? I use this for work, so this is kind of a big deal.

Perhaps something here will help:

It briefly covers the manjaro-printer package and setting up printers using CUPS.

There is also this thread:

Despite being about a PDF Printer, it also investigates CUPS to some extent; it should still be useful.

And there’s also:

These are a good start.


the package you are looking for is the


you can find it with in the aur

pamac search canon-pixma-ts5055-complete

and install it with

pamac install canon-pixma-ts5055-complete

this package includes the support for the g7020 as you can read here

Olli, thank you so much! Worked like a charm!

I knew this seemed somehow familiar.

I noticed that even after prompting, you still hadn’t marked the solution in your year old thread; I’ve taken the liberty of doing it for you.


This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.