Can't find Driver for Canon G7020 Printer/Scanner

Just re-installed the latest Manjaro KDE, and when I go to add printer, it finds my printer, but doesn’t seem to find the driver for the Canon G7020 in the Canon list. Any ideas would be greatly appreciated

Use IPP?

I tried the IPP and IPPS route to no avail. I’ve installed this before, but can’t remember the hoops I had to jump through to make it work

When I say I tried the IPP and IPPS route, frankly, as a novice, I’m not sure I was doing it correctly.

Even when I try to load the generic driver, it comes up with "Failed to perform request: Unsupported format “application/vnd.cups-pdf-banner”.

Well you can at least say how it is connected. IPP is a network protocol. USB? There you need the driver. IPP is driver-less.

According to this: it must be cnijfilter2, so only in the AUR:

pamac install base-devel
pamac build cnijfilter2

AUR (en) - cnijfilter2
AUR (en) - scangearmp2

Thank you Megavolt! Following your instructions with cnijfilter2 did the trick for the printer. Now I need to figure how to get the scanner part going. I installed scangearmp2 which did not do the trick

For future reference on the scanner issue, installing sane-airscan did the trick and brought the scanner to life