Cannot boot Manjaro due to "ERROR: device 'UUID=<string>' not found. Skipping fsck

Recently I came across this issue while trying to boot Manjaro:

ERROR: device 'UUID=<string>' not found. Skipping fsck.
mount: /new_root: can't find UUID=<string>.
You are now being dropped into an emergency shell.
sh: can't access tty: job control turned off

I tried booting LiveUSB but my laptop doesn’t recognize it (there is no Manjaro LiveUSB in list of bootable devices) so I can’t even reinstall Manjaro.
Does being installed on nvme has anything to do with this problem? Has anybody come across the same problem? How should it have been solved?

it seems that you messed with /etc/fstab : UUID=<string> is not normal as there must be an actual UUID address there.

You shall try pressing F12 (typically) to select bootable devices at reboot. if that doesn’t work then your usb has some problems.

I put ‘string’ instead of an actual UUID just not to write the whole thing.

Did you upgraded your BIOS?

Most probably not

Did Manjaro booted before? What was the last thing you did?

I have only seen that kind of error in BIOS upgrades and hardware failure

I’ve been using Manjaro on this laptop for several months. Before coming across this issue I tried to boot Manjaro LiveUSB without success. And now I have also this issue.

Hi @soundSpectacular,

I figure you’ll have to reinstall grub. For which you’d need a live environment. I’m thinking one of two things why you can’t boot into it:

  1. The BIOS/UEFI isn’t set to check for USB devices; or
  2. a faulty USB thumb drive.

You’d have to correct whichever one it is. Afterwards:

How to chroot

  1. Ensure you’ve got a relatively new ISO or at least one with a still supported LTS kernel.

  2. Write/copy/dd the ISO to a USB thumb drive.

  3. When done, boot with the above mentioned USB thumb drive into the live environment.

  4. Once booted, open a terminal and enter the following command to enter the chroot encironment:

manjaro-chroot -a
  1. If you have more than one Linux installation, select the correct one to use from the list provided.

When done, you should now be in the chroot environment.

But, be careful, as you’re now in an actual root environment on your computer, so any changes you make will persist after a restart.

Reinstalling grub from chroot environment.

Once in the live environment, you have to reinstall GRUB. To do so, run the following:

grub-install --recheck --force --target=x86_64-efi --boot-directory=/boot --efi-directory=/boot/efi --bootloader-id=Manjaro

Followed by:


When successfully completed, exit the chroot environment:


Followed by rebooting and seeing if it worked.

If it did, feel free to heap on the praise. If, however, it didn’t, well, then is wasn’t me and I’m innocent!


If this happened out of the blue, it might be a sign of hardware failure. So in the live environment, before entering the chroot environment, do a smart test on the hard drive to make sure there’s nothing wrong with it:

  1. Install smartmontools if it’s not already installed:
pamac install smartmontools
  1. Run the check:
sudo smartctl -a <device>

Where <device> is the identifier of your harddrive. For example, /dev/sda, /dev/sdb or /dev/nvme0

If all is well, there should be something similar to:

SMART overall-health self-assessment test result: PASSED
1 Like

It doesn’t see USB stick with LiveUSB at all! No matter what I use to write a disk image (balenaEtcher or Rufus), it just doesn’t see USB stick nor in BIOS menu nor in F12 Boot menu.

How did you install manjaro ?

I installed Manjaro using LiveUSB. But now my laptop doesn’t recognize LiveUSB stick. I have no idea, why.

It would help to provide some basic info, like what brand/model of laptop you use…
It might be possible to change your UEFI-BIOS settings to recognize the USB as bootable medium, if not you have bigger problems…

My laptop is Acer Aspire A317-53-78W9 and there is no way to provide system information

Did you try all USB-slots ?
Did you try an other USB-stick ?

The only slots I have on boot priority are:

  1. HDD0:
  2. “*”

I used two USB sticks, both 32GB. Wrote disk image using Rufus or balenaEtcher
Also, does grub configuration has anything to do with this issue?

It’s too late for me to dig in the user manual of your laptop: Acer A315-53 Manuals | ManualsLib
But im sure there must be a way to allow it to use the USB…

Most likely your USB was formatted wrongly to be recognized properly using an UEFI-BIOS in SecureBoot mode…


How many USB-Slots do you have ? 3? 2? USB-3 USB-2 ?

Some sticks may not be bootable in one slot, but in an other one

A possible slot is only visible to UEFI when a stick was inserted at boot-time

Are the sticks USB2 or USB3 ?

Do you have the stick you used to install manjaro ?

Perhaps. But without Live-USB it won’t be easy.

Can you boot with the repaired grub entry?
Do you have the information you need (UUIDs and kernel name…) on paper?
Can you extract them with the grub console?
If “yes, yes, yes”, then maybe someone who knows better than me can help you.

In the meantime, I would focus on getting a live USB to work again.

Is secure boot disabled ?

Secure boot is disabled. I wrote LiveUSB image on computers, which have no UEFI (Rufus option: MBR and BIOS/UEFI).
‘uname -r’ output is ‘6.0.19-3-MANJARO’
Here are my boot manager option and ‘blkid’ output.

The system boots, when I choose ‘fallback initramfs’ option despite failing to boot with a default option.

try using ventoy to flash the iso…