Buzzing sound (probably after updates)

I have checked two posts about buzzing sound in the forum (seems could not copy link in the post) Probably the same issue, but after trying those, it is still not working. Those buzzing sounds will automatically output when opening some software with sounds, or even notifications with sounds. It will also happen when I open the audio mixer. It did not happen before, but I just found this today.

  Device-1: Intel Alder Lake PCH-P High Definition Audio
    driver: sof-audio-pci-intel-tgl
  Device-2: NVIDIA driver: N/A
  Sound Server-1: ALSA v: k5.17.9-1-MANJARO running: yes
  Sound Server-2: PipeWire v: 0.3.51 running: yes

it is also wired that I did have file for cat /sys/module/snd_hda_intel/parameters/power_save.

Could anyone provide help? Thank you so much!!!

provide output from:
inxi -Fazy

  Kernel: 5.17.9-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.17-x86_64
    root=UUID=17a57bc5-4569-4d1b-8454-2c7d491f058c rw quiet apparmor=1
    security=apparmor udev.log_priority=3 snd_hda_intel.power_save=0
  Desktop: Xfce v: 4.16.0 tk: Gtk v: 3.24.29 info: xfce4-panel, plank
    wm: xfwm v: 4.16.1 vt: 7 dm: LightDM v: 1.30.0 Distro: Manjaro Linux
    base: Arch Linux
  Type: Laptop System: Razer product: Blade 15 (2022) - RZ09-0421 v: 8.04
    serial: <superuser required> Chassis: type: 10 serial: <superuser required>
  Mobo: Razer model: CH580 v: 4 serial: <superuser required> UEFI: Razer
    v: 1.09 date: 02/22/2022
  ID-1: BAT0 charge: 83.1 Wh (100.0%) condition: 83.1/80.2 Wh (103.6%)
    volts: 17.5 min: 15.4 model: Razer Blade type: Unknown serial: <filter>
    status: full
  ID-2: hidpp_battery_0 charge: 37% condition: N/A volts: 3.8 min: N/A
    model: Logitech G903 LIGHTSPEED Wireless Gaming Mouse w/ HERO type: N/A
    serial: <filter> status: discharging
  Info: model: 12th Gen Intel Core i7-12800H bits: 64 type: MST AMCP
    arch: Alder Lake family: 6 model-id: 0x9A (154) stepping: 3 microcode: 0x41C
  Topology: cpus: 1x cores: 14 mt: 6 tpc: 2 st: 8 threads: 20 smt: enabled
    cache: L1: 1.2 MiB desc: d-8x32 KiB, 6x48 KiB; i-6x32 KiB, 8x64 KiB
    L2: 11.5 MiB desc: 6x1.2 MiB, 2x2 MiB L3: 24 MiB desc: 1x24 MiB
  Speed (MHz): avg: 831 high: 2310 min/max: 400/2400:1800 scaling:
    driver: intel_pstate governor: powersave cores: 1: 416 2: 768 3: 1448 4: 847
    5: 395 6: 872 7: 2310 8: 712 9: 519 10: 598 11: 400 12: 705 13: 470
    14: 744 15: 773 16: 1628 17: 400 18: 897 19: 800 20: 927 bogomips: 112160
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Alder Lake-P Integrated Graphics vendor: Razer USA
    driver: i915 v: kernel ports: active: eDP-1 empty: none bus-ID: 00:02.0
    chip-ID: 8086:46a6 class-ID: 0300
  Device-2: NVIDIA GA103M [GeForce RTX 3080 Ti Laptop GPU] vendor: Razer USA
    driver: nvidia v: 510.73.05 alternate: nouveau,nvidia_drm non-free: 515.xx+
    status: current (as of 2022-05) arch: Ampere pcie: gen: 1 speed: 2.5 GT/s
    lanes: 8 link-max: gen: 4 speed: 16 GT/s lanes: 16 bus-ID: 01:00.0
    chip-ID: 10de:2460 class-ID: 0300
  Device-3: IMC Networks Integrated RGB Camera type: USB driver: uvcvideo
    bus-ID: 1-2:2 chip-ID: 13d3:5279 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.3 compositor: xfwm v: 4.16.1 driver: X:
    loaded: modesetting,nvidia alternate: fbdev,nouveau,nv,vesa gpu: i915
    display-ID: :0.0 screens: 1
  Screen-1: 0 s-res: 4608x1985 s-dpi: 96 s-size: 1219x525mm (47.99x20.67")
    s-diag: 1327mm (52.25")
  Monitor-1: HDMI-1-0 pos: primary,top-right res: 2560x1440 hz: 60 dpi: 108
    size: 600x340mm (23.62x13.39") diag: 690mm (27.15") modes: N/A
  Monitor-2: eDP-1 pos: bottom-l res: 2048x1152 hz: 60 dpi: 151
    size: 344x194mm (13.54x7.64") diag: 395mm (15.55") modes: N/A
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Alder Lake PCH-P High Definition Audio vendor: Razer USA
    driver: sof-audio-pci-intel-tgl
    alternate: snd_hda_intel,snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 8086:51c8 class-ID: 0401
  Device-2: NVIDIA vendor: Razer USA driver: N/A alternate: snd_hda_intel
    pcie: gen: 1 speed: 2.5 GT/s lanes: 8 link-max: gen: 4 speed: 16 GT/s
    lanes: 16 bus-ID: 01:00.1 chip-ID: 10de:2288 class-ID: 0403
  Sound Server-1: ALSA v: k5.17.9-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.21 running: no
  Sound Server-3: PulseAudio v: 15.0 running: no
  Sound Server-4: PipeWire v: 0.3.51 running: yes
  Device-1: Intel Alder Lake-P PCH CNVi WiFi vendor: Rivet Networks
    driver: iwlwifi v: kernel bus-ID: 00:14.3 chip-ID: 8086:51f0 class-ID: 0280
  IF: wlo1 state: up mac: <filter>
  Device-1: Intel type: USB driver: btusb v: 0.8 bus-ID: 1-10:6
    chip-ID: 8087:0033 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
  Local Storage: total: 968.49 GiB used: 75.71 GiB (7.8%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 model: NVMe CA6-8D1024 size: 953.87 GiB
    block-size: physical: 512 B logical: 512 B speed: 63.2 Gb/s lanes: 4
    type: SSD serial: <filter> rev: ERA0902 temp: 36.9 C scheme: GPT
  ID-2: /dev/sda maj-min: 8:0 type: USB vendor: Lexar model: USB Flash Drive
    size: 14.62 GiB block-size: physical: 512 B logical: 512 B type: SSD
    serial: <filter> rev: 1100 scheme: MBR
  ID-1: / raw-size: 672.78 GiB size: 661.15 GiB (98.27%)
    used: 75.66 GiB (11.4%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5
  ID-2: /boot/efi raw-size: 100 MiB size: 96 MiB (96.00%)
    used: 50.7 MiB (52.8%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Alert: No swap data was found.
  System Temperatures: cpu: 52.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 456 Uptime: 44m wakeups: 7 Memory: 31.04 GiB
  used: 4.85 GiB (15.6%) Init: systemd v: 250 tool: systemctl Compilers:
  gcc: 12.1.0 clang: 13.0.1 Packages: 1388 pacman: 1371 lib: 326 flatpak: 8
  snap: 9 Shell: Bash v: 5.1.16 running-in: xfce4-terminal inxi: 3.3.16


install sof-firmware package:
sudo pacman -S sof-firmware
then reboot and test

error appeared:

error: extract: not overwriting dir with file /usr/lib/firmware/intel/sof-tplg
error: problem occurred while upgrading sof-firmware
error: could not commit transaction
error: failed to commit transaction (transaction aborted)
Errors occurred, no packages were upgraded.

seems installed before

warning: sof-firmware-2.1.1-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) sof-firmware-2.1.1-1

Total Installed Size:  14.04 MiB
Net Upgrade Size:       0.00 MiB

:: Proceed with installation? [Y/n] 
(1/1) checking keys in keyring                     [######################] 100%
(1/1) checking package integrity                   [######################] 100%
(1/1) loading package files                        [######################] 100%
(1/1) checking for file conflicts                  [######################] 100%
(1/1) checking available disk space                [######################] 100%
:: Running pre-transaction hooks...
(1/1) Creating Timeshift snapshot before upgrade...
==> skipping timeshift-autosnap due skipRsyncAutosnap in /etc/timeshift-autosnap.conf set to TRUE.
:: Processing package changes...
(1/1) reinstalling sof-firmware                    [######################] 100%
error: extract: not overwriting dir with file /usr/lib/firmware/intel/sof-tplg
error: problem occurred while upgrading sof-firmware
error: could not commit transaction
error: failed to commit transaction (transaction aborted)
Errors occurred, no packages were upgraded.

ok so its installed already… so install the 5.15 LTS and the 5.10LTS kernels from system settings/kernel, reboot, select the 5.15 in grub menu, and test with it, if it doesnt work, do the same with the 5.10

I updated from 5.15 to 5.17 before due to the wifi issues from the forum. do you mean to just test in 5.15 live boot?

no just install the 5.15 and 5.10 and reboot and select them in the grub menu and test if the audio wokrs with the LTS kernels

try with

sudo pacman -S sof-firmware --overwrite="/usr/lib/firmware/intel/sof-tplg"
sudo pacman -S sof-firmware --overwrite="*"

I tried 5.15, same problem. And I can’t boot into 5.10. maybe because of the new hardware and drivers?

tried both, still same output and error

all right so install the latest kernel 5.18 and try with it, if it doesnt work, we try pulse/pipewire install/uninstall

btw I could not find the password of this account before, so I registered new one. Now I recovered this…

you cant boot on older kernel 5.10 , remove
keep 5.15 LTS and 5.17 , may be add 5.18 coming ( in state this is RC , Release Candidate , coming in stable )

good damn, i just realized that youre not OP …

a quick question before moving forward, if I had to switch 5.17 back later, will I just need to

sudo pacman -S linux517-headers linux517-nvidia
sudo mkinitcpio -P

and reboot?

why do you want to install headers and nvidia?
post output from:
mhwd-kernel -li

5.18 has the same problem . And I install those before based on my another question here. And I found while installing new kernels, old nvidia and headers will be removed and instead install those with corresponding kernel version

Currently running: 5.18.0-1-MANJARO (linux518)
The following kernels are installed in your system:
   * linux517
   * linux518

you have already installed the 517 kernel, so you dont need to install again headers, just reboot and switch to it in grub menu