Brother Wifi Network Printer - Detected But Not Printing

Hello Everyone,

I recently purchased an HL-L2360DW Printer:

It looks like it’s detected properly inside printer settings inside my Manjaro Gnome Installation:

When I try to print any type of test page, the print job hangs and nothing happens. The Brother printer works fine on my Windows and Apple devices, but I am having issues trying to get it working in Linux. It looks like Linux ‘detects’ the printer properly, it just cannot send a print job to it. I previously ran Ubuntu and had a similar issue where I had to update the ‘address’ to use the IPP protocol to get the printer to work properly. However, I do not see an ‘address’ field that I can modify under Manjaro.

Any help would be greatly appreciated. Thanks!

Have you updated cups from an update or two ago?

This is a clean install (formatted drive, reinstalled Manjaro Gnome from a USB). Are these steps still needed on a ‘fresh’ install?

you should type/insert in your inet-browser following address: http://localhost:631/admin or just click on it to open while reading this.

The driver is installed but you have to enable network printing and administration to can use it.

Hi A4orce84,

Note: this is my experience with setting up a printer…

although I am on KDE Manjaro, and someone can direct you to how setting up a printer in Manjaro is done on Gnome I had the same issue as you when I tried installing my Brother printer in Manjaro. I got it working doing the following (may differ in Gnome):

first make sure you have cups and manjaro-printer packages installed already, if not install them. The packages should be already installed, but check just in case. You can check using the Application Launcher —> Add/Remove software and then search for cups and for manjaro-printer. In Gnome the search for the packages might be a little different.

second do what Hipster suggested: you want to make sure that the cups service is up to date but also that it will be enabled and started before you do the next step.

After you update your system, update your systemd services like this: (post that Hipster gave you a link to):

sudo systemctl disable --now org.cups.cupsd.socket
sudo systemctl disable --now org.cups.cupsd.service
sudo systemctl disable --now org.cups.cupsd.path
sudo systemctl enable --now cups.service
sudo systemctl enable --now cups.socket
sudo systemctl enable --now cups.path

after following Hipster’s advice, you are ready for the next step. In my case I added the driver for my Brother’s model.

I looked and your printer driver is in the AUR. Since I don’t use Gnome, I am not sure if you have the AUR, if you do, then you can build it also through the Add/remove software program or through your package manager.

After that I followed the Manjaro Wiki instructions dealing with the CUPS service. I first tried adding a printer through the GUI using the Application Launcher -----> System Settings -----> Printers but the signal to print would get to my printer and nothing would happen. So I went the CUPS route. (I am sure it was user error :sweat_smile:)

In the Manjaro wiki for printing using the CUPS method I looked for the CUPS install method, looking down the page I saw Cups Webpage Interface and started there and followed the instructions. Before doing the CUPS method I removed from the GUI the printer that did not work and then used the CUPS method to install my printer. Then I printed a test page to make sure.

There are two methods for the CUPS printer installation: I tried the automatic method, and that did not seem to work for me, so I tried the manual method. Good luck with your install!. I hope this helps…

1 Like

Thank you everyone, I finally got my printer added and working properly! I appreciate the help!


1 Like

Hi Guys. I have the exact same problem with a Brother_DCP-L3510CDW_series running Manjaro stable, Kernel 5.4, KDE Edition.
None of the above mentioned methods worked for me.
Additionally, I installed brother-dcpl3510cdw-drv-bin via yaourt and provided the included driver (/opt/brother/Printers/dcpl3510cdw/cupswrapper/brother_dcpl3510cdw_printer_en.ppd) as ppd file for the printer.
Didn’t work either.
I also took care of the symbolic link in the comment at the archlinux page of the yaourt package
(ln -s /opt/brother/Printers/dcpl3510cdw/cupswrapper/brother_lpdwrapper_dcpl3510cdw /usr/lib/cups/filter/brother_lpdwrapper_dcpl3510cdw)
Unfortunately nothings works.
What am I missing here? Please help.

Moreover selecting one of the automatically idiscovered drivers does not seem to work. If i select the discovered “IPP Everywhere” driver, CUPS notifies a success, but the driver hasn’t changed at all.