`org.cups.cupsd.{service,socket,path}` not found

I’m having an issue with the cups intervention posted above. Executing systemctl disable results in the following message:

Failed to disable unit: Unit file org.cups.cupsd.service does not exist.

I reinstalled cups and executed systemctl disable again but I get the same message. Advice on how to proceed would be appreciated.

Please show us the output of

$ sudo systemctl -a list-units | grep -i cups
     cups.path                     loaded    active   running   CUPS Scheduler                                                                     
● org.cups.cupsd.path              not-found inactive dead      org.cups.cupsd.path                                                                
  cups.service                     loaded    active   running   CUPS Scheduler                                                                     
  cups.socket                      loaded    active   running   CUPS Scheduler
  1. If you don’t have a printer,
  • ignore the advice on CUPS ( Common UNIX Printing System)
  • uninstall CUPS
  1. Otherwise, this is not good:

    So please reinstall that bit. (or all of CUPS)

cc @verminator

I reinstalled and restarted CUPS and org.cups.cupsd.path is still listed as not-found inactive dead. I’m not sure what’s going on as I used the printer with this machine yesterday before installing the update.

After updating, that service will indeed no longer exist, because the name of the service has been changed upstream by the systemd developers.

Assuming this is ‘stable’. Just did the latest update? Always check the stable update forum page.

From that page.

CUPS update need manual intervention

After you update your system, update your systemd services like this:

sudo systemctl disable --now org.cups.cupsd.socket
sudo systemctl disable --now org.cups.cupsd.service
sudo systemctl disable --now org.cups.cupsd.path
sudo systemctl enable --now cups.service
sudo systemctl enable --now cups.socket
sudo systemctl enable --now cups.path


Thanks, it worked this time.

Good to hear you got it solved.

I vote for an automated solution as posted here. It can’t be that Linux remains something for Linux-experts. Linux needs to open up and be more accessible to PC-users.

It would not be a very good idea if linux starts services without asking.
There was a message when the package got updated.
But only Arch user doing it by terminal had the chance so read this message.
Manjaro has to bring such information better to there users.

1 Like

The little arrow at the bottom right of the Add and Remove Programs (pamac gui) application has an arrow in the bottom right to see terminal output. I recommend people click that to see any update warnings and such. :+1:


I needed to perform this CUPS update also with KDE/5.9.11 kernel. A using a wireless Canon MG6821 Printer.

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.