Rpm or dpkg required for installing Brother DCP-T220 printer drivers

git clone GitHub - ishaanbhimwal/brother-dcpt220
Cloning into ‘brother-dcpt220’…
remote: Enumerating objects: 5, done.
remote: Counting objects: 100% (5/5), done.
remote: Compressing objects: 100% (5/5), done.
remote: Total 5 (delta 0), reused 0 (delta 0), pack-reused 0
Receiving objects: 100% (5/5), done.

But I was able to create my own PKGBUILD. Thank you anyways for the help.


Are you sure you need a driver to make your printer work ? Did you try this first ?

Great! I have added the package to the AUR incase anyone needs it:

pamac build brother-dcpt220

autofill running updpkgsums in the same folder of the pkgbuild

Some things need or could be changed in your pkgbuild, I’ll send you a patch when I have time

1 Like

I did install the package successfully and it has been added in the printer section but the printer is still not working. It just shows active jobs but nothing happens.

None of the command is working - test page, cleaning heads, etc.

This is not a wifi printer, I have connected it via USB. It has been added through administrator settings

Can you try to download the driver here: Downloads | DCP-T220 | Others | Brother ?

Those are .deb and .rpm packages. Those can’t be installed on Arch that is why I am getting the original error of rpm or dpkg required.

What is the status in localhost:631/printers/ when you try to print a test page from gnome-settings?

Yourself or the AUR one cause I recently updated it?

In the gnome-settings when I print a test page the status remains idle on localhost:631/printers/.

yay brother-dcpt220

I removed my printer and then installed from aur.

It doesn’t on my end. As your last resort you can try to re-install the driver to see if that help.

Anybody got the printer working?

I installed debian 11 in a VB and it detects the printer without trouble and actually prints.

I would obviously rather not start virtualbox to print.
If anybody has an idea I would even try to create/test a PKGBUILD if someone helped.

I tried installing HPLIP and it worked. I guess that some needed packages were installed as dependencies
Sorry for my bad England, I am Russian suka blyat

1 Like

Hi @Shmelvsvitere, and welcome!

It’s been 2 years since that last post:


No offense meant, but I don’t think your answer is relevant anymore.

I think this will benefit you:


Old Threads/“Necro-Bumping”