/boot/initramfs-linux.img not found after update

Hi, I was updating my manjaro Installation with sudo pacman -Syyu, after the update i restarted my laptop and i was struck with /boot/initramfs-linux.img not found. i am currently tring to fixed the issue by mounting the partition and the efi partition, whenever i mount my /dev/sda on /mnt/boot it will show that the efi partition is in write protected. here is my /etc/fstab

# <file system>             <mount point>  <type>  <options>  <dump>  <pass>
UUID=F81A-BE4F                            /boot/efi      vfat    umask=0077 0 2
UUID=4674ea84-5d7f-4f36-a66d-98b959ecbc54 /              ext4    defaults,noatime 0 1
tmpfs                                     /tmp           tmpfs   defaults,noatime,mode=1777 0 0

after runing mkinitcpio -p linux515 it shows this error

==> Building image from preset: /etc/mkinitcpio.d/linux515.preset: 'default'
==> Using configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-5.15-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.15-x86_64.img
==> ERROR: specified kernel image does not exist: '/boot/vmlinuz-5.15-x86_64'
==> Building image from preset: /etc/mkinitcpio.d/linux515.preset: 'fallback'
==> Using configuration file: '/etc/mkinitcpio.conf'
  -> -k /boot/vmlinuz-5.15-x86_64 -c /etc/mkinitcpio.conf -g /boot/initramfs-5.15-x86_64-fallback.img -S autodetect
==> ERROR: specified kernel image does not exist: '/boot/vmlinuz-5.15-x86_64'

can not run pacman -S linux because the /boot is write protected

Use the tool manjaro-chroot which is on the live medium.

If you want to put your system together properly, you’ll have to mount / first
mount /dev/sdaX /mnt
and then
mount /boot/efi to the correct place

Why the efi partition appears to be write protected - I don’t know.
It probably won’t be with manjaro-chroot or when the system is properly put together by hand.

1 Like

Auto detection works with ext4:

sudo manjaro-chroot -a

Hi @k1llm0ng3r and welcome to the Manjaro community.

I do not have a solution to your issue, but I do have a few tips:

  • Always use sudo pacman -Syu when updating (notice only one ‘y’).

There is also no wonder that no initramfs-linux.img file was not found, as it does not exist; as @anon51566685 notes below. There is also no need to mount /boot as it is not a partition - / (root) is already mounted.

Why do you think you need to mount the ESP? - initramfs-{version}.img is not on the ESP and the EFI directory is not within /boot.

To explain: /boot/efi is actually a mount point (in this case a symlink) - not a directory: it mounts the $esp/EFI directory (on the ESP) under the /boot directory (on root), which translates to an accessible path of /boot/efi/EFI.

If you’ve followed that so far, this means you can access the EFI folder with a command such as this:

sudo ls /boot/efi/EFI

…although some tools may not work as expected… the ESP should already be mounted.

Unlike pamac, pacman always requires sudo. For example:

sudo pacman -S vivaldi

Additionally, it looks like you wanted to update your kernel… pacman -S linux is the wrong way to do that. Please see Manjaro Kernels for the right way.

As a new user, please take some time to familiarise yourself with Forum requirements; in particular, the many ways to use the forum to your benefit. To that end, some or all these links will be invaluable:

And last, but not least, the Stable Update Announcements, which you should check frequently for important update related information. Occasionally an issue might be directly related to a particular update; it’s always best to check those announcements.

Cheers.

1 Like

can you report

sudo mhwd-kernel -li
sudo ls /etc/mkinitcpio.d/*.preset

Also there is no package named linux or file named initramfs-linux.img in Manjaro.

i currently use linux515 kernel and linux54 kernel,

here is my sudo mhwd-kernel -li:

currently running: 6.6.25-1-MANJARO (linux66)
The following kernels are installed in your system:
   * linux515
   * linux54

and here is the output of

sudo ls /etc/mkinitcpio.d/*.preset

/etc/mkinitcpio.d/linux515.preset  /etc/mkinitcpio.d/linux54.preset

This shows that you’re running linux66:

Well… Lets make sure of the things.

sudo pacman-mirrors -f
sudo pacman -Syu linux54 linux515
sudo mkinitcpio -P
sudo grub-mkconfig -o /boot/grub/grub.cfg

We could also check the boot directory before proceeding;

ls -a /boot/

PS.

None of the quoted commands required sudo.
And in fact using it at the wrong times can create problems.

Thanks for helping me figure out the problem i was trying to manually mount my
/dev/sda to /mount/boot which was making the whole /boot folder write-protected. i tried runing pacman -S linux without mounting /dev/sda to /boot, which run perfectly fine and then i run mkinicpio -P, which fixed my issue. thanks again for helping me figure out the problem.

Sorry, but what you describe seems like a totally senseless resolution to anything.
I imagine you did ‘something’ in the process that just happened to help.
But, as long as you’re happy, all is well in the Universe.

Cheers.

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.