Bluetooth mouse stops working after a while

Hey,
I am new manjaro and so far everything works fine, except for one thing. My Bluetooth Mouse just stops working after a while. I normally use KDEBluetooth but I also tried it with blueman and bluetoothctl with the same result. When it stops working it is still shown as connected device and it is not possible to disconnect it. When it stops working I also can’t deactivate bluetooth, the only way to get it work again is to restart the system.

Here some outputs:

[olli@olli-ideapad ~]$ sudo systemctl status bluetooth.service
* bluetooth.service - Bluetooth service
     Loaded: loaded (/usr/lib/systemd/system/bluetooth.service; enabled; vendor preset: disabled)
     Active: active (running) since Sun 2021-08-29 10:06:28 CEST; 1 day 7h ago
       Docs: man:bluetoothd(8)
   Main PID: 921 (bluetoothd)
     Status: "Running"
      Tasks: 1 (limit: 18400)
     Memory: 3.0M
        CPU: 17.818s
     CGroup: /system.slice/bluetooth.service
             `-921 /usr/lib/bluetooth/bluetoothd

Aug 30 17:11:32 olli-ideapad bluetoothd[921]: Endpoint unregistered: sender=:1.42 path=/MediaEndpoint/A2DPSink/sbc_xq_552
Aug 30 17:11:32 olli-ideapad bluetoothd[921]: Endpoint unregistered: sender=:1.42 path=/MediaEndpoint/A2DPSource/sbc_xq_552
Aug 30 17:11:33 olli-ideapad bluetoothd[921]: Endpoint registered: sender=:1.42 path=/MediaEndpoint/A2DPSink/sbc
Aug 30 17:11:33 olli-ideapad bluetoothd[921]: Endpoint registered: sender=:1.42 path=/MediaEndpoint/A2DPSource/sbc
Aug 30 17:11:33 olli-ideapad bluetoothd[921]: Endpoint registered: sender=:1.42 path=/MediaEndpoint/A2DPSink/sbc_xq_453
Aug 30 17:11:33 olli-ideapad bluetoothd[921]: Endpoint registered: sender=:1.42 path=/MediaEndpoint/A2DPSource/sbc_xq_453
Aug 30 17:11:33 olli-ideapad bluetoothd[921]: Endpoint registered: sender=:1.42 path=/MediaEndpoint/A2DPSink/sbc_xq_512
Aug 30 17:11:33 olli-ideapad bluetoothd[921]: Endpoint registered: sender=:1.42 path=/MediaEndpoint/A2DPSource/sbc_xq_512
Aug 30 17:11:33 olli-ideapad bluetoothd[921]: Endpoint registered: sender=:1.42 path=/MediaEndpoint/A2DPSink/sbc_xq_552
Aug 30 17:11:33 olli-ideapad bluetoothd[921]: Endpoint registered: sender=:1.42 path=/MediaEndpoint/A2DPSource/sbc_xq_552
[olli@olli-ideapad ~]$ inxi --admin --verbosity=7 --filter --no-host --width
System:
  Kernel: 5.13.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=0bef2ef0-ffa0-46be-8761-26920982d8fe rw quiet apparmor=1 
  security=apparmor resume=UUID=17d68ab8-e748-41bc-8f81-1c0912101501 
  udev.log_priority=3 
  Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 
  dm: SDDM Distro: Manjaro Linux base: Arch Linux 
Machine:
  Type: Laptop System: LENOVO product: 82LM v: IdeaPad 5 14ALC05 
  serial: <filter> Chassis: type: 10 v: IdeaPad 5 14ALC05 serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: No DPK serial: <filter> UEFI: LENOVO 
  v: G5CN17WW(V1.05) date: 04/22/2021 
Battery:
  ID-1: BAT1 charge: 52.7 Wh (90.5%) condition: 58.2/56.5 Wh (102.9%) 
  volts: 12.5 min: 11.5 
  model: 0x53 0x4D 0x50 0x00 0x32 0x30 0x 0x4C 0x31 0x39 0x4D 0x33 0x50 0x5650 
  type: Li-ion serial: <filter> status: Discharging cycles: 9 
Memory:
  RAM: total: 14.99 GiB used: 6.77 GiB (45.2%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Info: 8-Core model: AMD Ryzen 7 5700U with Radeon Graphics bits: 64 
  type: MT MCP arch: Zen 2 family: 17 (23) model-id: 68 (104) stepping: 1 
  microcode: 8608103 cache: L2: 4 MiB bogomips: 57518 
  Speed: 1897 MHz min/max: 1400/1800 MHz boost: enabled Core speeds (MHz): 
  1: 1897 2: 1749 3: 1397 4: 1397 5: 1397 6: 1396 7: 1397 8: 1397 9: 1508 
  10: 1761 11: 1450 12: 1609 13: 1460 14: 1514 15: 1397 16: 1397 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy 
  constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs irperf lahf_lm 
  lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx 
  nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter 
  pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni 
  popcnt pse pse36 rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sha_ni 
  skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor 
  svm svm_lock syscall tce topoext tsc tsc_scale umip v_spec_ctrl 
  v_vmsave_vmload vgif vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave 
  xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: conditional, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Lucienne vendor: Lenovo driver: amdgpu v: kernel 
  bus-ID: 04:00.0 chip-ID: 1002:164c class-ID: 0300 
  Device-2: Chicony Integrated Camera type: USB driver: uvcvideo bus-ID: 1-3:2 
  chip-ID: 04f2:b725 class-ID: fe01 serial: <filter> 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa 
  display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: eDP res: 1920x1080 hz: 60 dpi: 158 size: 309x173mm (12.2x6.8") 
  diag: 354mm (13.9") 
  OpenGL: renderer: AMD RENOIR (DRM 3.41.0 5.13.12-1-MANJARO LLVM 12.0.1) 
  v: 4.6 Mesa 21.2.1 direct render: Yes 
Audio:
  Device-1: AMD vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 04:00.1 
  chip-ID: 1002:1637 class-ID: 0403 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo 
  driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x bus-ID: 04:00.5 
  chip-ID: 1022:15e2 class-ID: 0480 
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus-ID: 04:00.6 chip-ID: 1022:15e3 class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.12-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: no 
Network:
  Device-1: Realtek vendor: Lenovo driver: rtw89_pci v: N/A modules: rtw89pci 
  port: 2000 bus-ID: 03:00.0 chip-ID: 10ec:8852 class-ID: 0280 
  IF: wlo1 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 
  bus-ID: 3-4:3 chip-ID: 0bda:4852 class-ID: e001 serial: <filter> 
  Report: hciconfig ID: hci0 rfk-id: 5 state: up address: <filter> 
  Info: acl-mtu: 1021:6 sco-mtu: 255:12 link-policy: rswitch hold sniff park 
  link-mode: slave accept 
Logical:
  Message: No logical block device data found. 
RAID:
  Message: No RAID data found. 
Drives:
  Local Storage: total: 476.94 GiB used: 63.27 GiB (13.3%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Western Digital 
  model: PC SN730 SDBPNTY-512G-1101 size: 476.94 GiB block-size: 
  physical: 512 B logical: 512 B speed: 31.6 Gb/s lanes: 4 type: SSD 
  serial: <filter> rev: 11170001 temp: 43.9 C scheme: GPT 
  Message: No optical or floppy data found. 
Partition:
  ID-1: / raw-size: 460.08 GiB size: 451.79 GiB (98.20%) 
  used: 63.27 GiB (14.0%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2 
  label: N/A uuid: 0bef2ef0-ffa0-46be-8761-26920982d8fe 
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%) 
  used: 288 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 
  label: NO_LABEL uuid: FF70-3EB2 
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: partition size: 16.56 GiB used: 0 KiB (0.0%) priority: -2 
  dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A 
  uuid: 17d68ab8-e748-41bc-8f81-1c0912101501 
Unmounted:
  Message: No unmounted partitions found. 
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-3:2 info: Chicony Integrated Camera type: Video driver: uvcvideo 
  interfaces: 3 rev: 2.0 speed: 480 Mb/s power: 500mA chip-ID: 04f2:b725 
  class-ID: fe01 serial: <filter> 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 3-3:2 info: Elan Micro ELAN:Fingerprint type: <vendor specific> 
  driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 04f3:0c4d class-ID: 0000 
  Device-2: 3-4:3 info: Realtek Bluetooth Radio type: Bluetooth driver: btusb 
  interfaces: 2 rev: 1.0 speed: 12 Mb/s power: 500mA chip-ID: 0bda:4852 
  class-ID: e001 serial: <filter> 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
Sensors:
  System Temperatures: cpu: 55.0 C mobo: N/A gpu: amdgpu temp: 48.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 355 Uptime: 1d 7h 30m wakeups: 3161 Init: systemd v: 248 
  tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1315 lib: 381 
  flatpak: 0 Shell: Bash v: 5.1.8 running-in: yakuake inxi: 3.3.06 
[olli@olli-ideapad ~]$ bluetoothctl show
Controller 74:4C:A1:CB:A6:DA (public)
        Name: olli-ideapad
        Alias: olli-ideapad
        Class: 0x007c010c
        Powered: yes
        Discoverable: no
        DiscoverableTimeout: 0x000000b4
        Pairable: yes
        UUID: Message Notification Se.. (00001133-0000-1000-8000-00805f9b34fb)
        UUID: A/V Remote Control        (0000110e-0000-1000-8000-00805f9b34fb)
        UUID: OBEX Object Push          (00001105-0000-1000-8000-00805f9b34fb)
        UUID: Message Access Server     (00001132-0000-1000-8000-00805f9b34fb)
        UUID: PnP Information           (00001200-0000-1000-8000-00805f9b34fb)
        UUID: IrMC Sync                 (00001104-0000-1000-8000-00805f9b34fb)
        UUID: Vendor specific           (00005005-0000-1000-8000-0002ee000001)
        UUID: Headset                   (00001108-0000-1000-8000-00805f9b34fb)
        UUID: A/V Remote Control Target (0000110c-0000-1000-8000-00805f9b34fb)
        UUID: Generic Attribute Profile (00001801-0000-1000-8000-00805f9b34fb)
        UUID: Phonebook Access Server   (0000112f-0000-1000-8000-00805f9b34fb)
        UUID: Device Information        (0000180a-0000-1000-8000-00805f9b34fb)
        UUID: Audio Sink                (0000110b-0000-1000-8000-00805f9b34fb)
        UUID: Generic Access Profile    (00001800-0000-1000-8000-00805f9b34fb)
        UUID: Handsfree Audio Gateway   (0000111f-0000-1000-8000-00805f9b34fb)
        UUID: Audio Source              (0000110a-0000-1000-8000-00805f9b34fb)
        UUID: OBEX File Transfer        (00001106-0000-1000-8000-00805f9b34fb)
        Modalias: usb:v1D6Bp0246d053C
        Discovering: no
        Roles: central
        Roles: peripheral
        Roles: central-peripheral
Advertising Features:
        ActiveInstances: 0x00 (0)
        SupportedInstances: 0x0a (10)
        SupportedIncludes: tx-power
        SupportedIncludes: appearance
        SupportedIncludes: local-name
        SupportedSecondaryChannels: 1M
        SupportedSecondaryChannels: 2M
        SupportedSecondaryChannels: Coded
[olli@olli-ideapad ~]$ rfkill list
0: ideapad_wlan: Wireless LAN
        Soft blocked: no
        Hard blocked: no
1: ideapad_bluetooth: Bluetooth
        Soft blocked: no
        Hard blocked: no
2: phy0: Wireless LAN
        Soft blocked: no
        Hard blocked: no
5: hci0: Bluetooth
        Soft blocked: no
        Hard blocked: no

Does this problem also arise:

  1. on Kernel 5.10 LTS?
  2. in a newly created user? (E.G. ollix4)

:thinking:

Thanks for the answer.

  1. On 5.10 Bluetooth doesn’t work at all.
  2. I tried it and so far it seems to work but it’s hard to say because it stopps working after random duration.

I have the same issue as @ollix3, also with Lenovo laptop, realtek bt.
I could not get BT working on 5.10 so i updated to 5.13 & then BT worked fine. I have been using BT mouse without an issue for about a week, no disconnects.
However last night some more updates dropped in & since then BT mouse stops working at random interval. Cannot be re-connected until restart.
I tried turning BT off/on in settings - it turns OFF but wont turn back on, however systemctl says its running.

edit: oh, & now I just had the trackpad randomly stop working instead, but the bt mouse was ok. after reboot both seem fine … for now. Seems oddly coincidental pointer related issue.

1 Like

I had the same problem several months ago.
Link to thread
But I could not find out, what to do.
It happened - and still happens - with every kernel version I have tried since.
I have two mice with the same problem on this manjaro machine.
When I boot to windows or use the mouse elsewhere, there is no problem.

In the end I got a wired mouse and I still love the machine with manjaro :wink:

Viele Grüße
Axel

1 Like

4 days. Problem gone?

:thinking:

It just happened & I was able to isolate the event in my log. I launched terminal seconds after.
Before 8:53 some rtkit processing msgs, then 4 mins later (8:57) Bluetooth stops working.

 9月 08 08:57:57 Sulaco systemd[683]: Started Application launched by gnome-shell.
 9月 08 08:57:46 Sulaco upowerd[846]: treating change event as add on /sys/devices/pci0000:00/0000:00:08.1/0000:05:00.4/usb3/3-4
 9月 08 08:57:46 Sulaco upowerd[846]: treating change event as add on /sys/devices/pci0000:00/0000:00:08.1/0000:05:00.4/usb3/3-3
 9月 08 08:57:46 Sulaco upowerd[846]: treating change event as add on /sys/devices/pci0000:00/0000:00:08.1/0000:05:00.4/usb3/3-4
 9月 08 08:57:46 Sulaco upowerd[846]: treating change event as add on /sys/devices/pci0000:00/0000:00:08.1/0000:05:00.4/usb3/3-3
 9月 08 08:57:46 Sulaco kernel: usb 3-4: reset full-speed USB device number 3 using xhci_hcd
 9月 08 08:57:45 Sulaco kernel: usb 3-3: reset full-speed USB device number 2 using xhci_hcd
 9月 08 08:53:54 Sulaco rtkit-daemon[858]: Supervising 8 threads of 4 processes of 1 users.
9月 08 08:53:54 Sulaco rtkit-daemon[858]: Supervising 8 threads of 4 processes of 1 users.
 9月 08 08:50:34 Sulaco rtkit-daemon[858]: Supervising 8 threads of 4 processes of 1 users.
 9月 08 08:50:34 Sulaco rtkit-daemon[858]: Supervising 8 threads of 4 processes of 1 users.
 9月 08 08:48:54 Sulaco rtkit-daemon[858]: Supervising 8 threads of 4 processes of 1 users.
 9月 08 08:48:54 Sulaco rtkit-daemon[858]: Supervising 8 threads of 4 processes of 1 users.
 9月 08 08:45:22 Sulaco rtkit-daemon[858]: Supervising 8 threads of 4 processes of 1 users.
 9月 08 08:45:22 Sulaco rtkit-daemon[858]: Supervising 8 threads of 4 processes of 1 users.
 9月 08 08:44:34 Sulaco rtkit-daemon[858]: Supervising 8 threads of 4 processes of 1 users.
 9月 08 08:44:34 Sulaco rtkit-daemon[858]: Supervising 8 threads of 4 processes of 1 users.
 9月 08 08:43:54 Sulaco rtkit-daemon[858]: Supervising 8 threads of 4 processes of 1 users.
 9月 08 08:43:54 Sulaco rtkit-daemon[858]: Supervising 8 threads of 4 processes of 1 users.
 9月 08 08:43:34 Sulaco org.fcitx.Fcitx5.desktop[1090]: I2021-09-08 08:43:34.981578 instance.cpp:1235] End au>
 9月 08 08:43:34 Sulaco org.fcitx.Fcitx5.desktop[1090]: I2021-09-08 08:43:34.976048 instance.cpp:1233] Runnin>
 9月 08 08:42:40 Sulaco rtkit-daemon[858]: Supervising 8 threads of 4 processes of 1 users.
 9月 08 08:42:40 Sulaco rtkit-daemon[858]: Supervising 8 threads of 4 processes of 1 users.
 9月 08 08:41:13 Sulaco wpa_supplicant[635]: wlp4s0: WPA: Group rekeying completed with 34:97:f6:61:20:80 [GT>
 9月 08 08:38:54 Sulaco rtkit-daemon[858]: Supervising 8 threads of 4 processes of 1 users.

Other than BT mouse I do not have any other devices connected to laptop.
I had 2 day without the issue, so it seems there maybe days without, or it may happen several times a day.

That looks like your Bluetooth adapter was kicked off the Universal Serial Bus.

  • Was the system overheating at the time?
  • Do you run an overclocked system?
  • Which exact command did you run to get that output?

:face_with_monocle:

I do live on a pacific island, its pretty hot & humid, but air-con is on. It shouldnt be too hot, but its possible. I have not noticed the laptop getting hot at all since owning it.

I don’t run overclocked, its a recently new Lenovo Thinkbook unmodified.
Ive used the bluetooth with Ubuntu on another partition & did not have this issue, (but didnt test extensively, only a couple days use)

The output is from terminal journalctl -r which i ran about 15 seconds after the mouse stopped working.

1 Like

If I get this sorted, I’m flying in with a bunch of :eu: food and I’m staying at your place until said food runs out…

Would you be prepared to remove the current Bluetooth adapter hardware and change it to an Intel one?

:scream:

If not, can you provide an inxi --admin --verbosity=7 --filter --no-host --width so I can look for other options?

:thinking:

Perfect! We are desperate for good bread & wine. My wife is the only cheesemaker on island, so we got that part sorted.

Probably not at the moment. I’ll just make do with trackpad.
The model is specced as “Intel® Wi-Fi 6 AX200” but in reality the wifi & bt are both realtek, it seems to be luck of the draw from what other owners report.

of course!

inxi --admin --verbosity=7 --filter --no-host --width 
System:
  Kernel: 5.13.13-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=0b90181d-1eb7-44d7-bc37-80c878000293 rw quiet splash apparmor=1 
  security=apparmor udev.log_priority=3 iommu=soft 
  Desktop: GNOME 40.4 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 40.1 
  Distro: Manjaro Linux base: Arch Linux 
Machine:
  Type: Laptop System: LENOVO product: 20VF v: ThinkBook 14 G2 ARE 
  serial: <filter> Chassis: type: 10 v: ThinkBook 14 G2 ARE serial: <filter> 
  Mobo: LENOVO model: LNVNB161216 v: SDK0J40700 WIN serial: <filter> 
  UEFI: LENOVO v: FACN28WW(V1.11) date: 05/18/2021 
Battery:
  ID-1: BAT1 charge: 41.1 Wh (94.3%) condition: 43.6/45.0 Wh (96.8%) 
  volts: 12.7 min: 11.5 
  model: 0x43 0x65 0x6C 0x78 0x70 0x65 0x 0x4C 0x31 0x39 0x43 0x33 0x50 0x4500 
  type: Li-ion serial: <filter> status: Discharging cycles: 43 
Memory:
  RAM: total: 19.41 GiB used: 2.1 GiB (10.8%) 
  RAM Report: permissions: Unable to run dmidecode. Root privileges required. 
CPU:
  Info: 6-Core model: AMD Ryzen 5 4500U with Radeon Graphics bits: 64 
  type: MCP arch: Zen 2 family: 17 (23) model-id: 60 (96) stepping: 1 
  microcode: 8600106 cache: L2: 3 MiB bogomips: 28453 
  Speed: 1397 MHz min/max: 1400/2375 MHz boost: enabled Core speeds (MHz): 
  1: 1397 2: 1397 3: 1397 4: 1397 5: 1397 6: 1397 
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1 
  bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy 
  constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total cqm_occup_llc 
  cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid f16c flushbyasid 
  fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs irperf lahf_lm 
  lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe msr mtrr mwaitx 
  nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae pat pausefilter 
  pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb pfthreshold pge pni 
  popcnt pse pse36 rdpid rdpru rdrand rdseed rdt_a rdtscp rep_good sep sha_ni 
  skinit smap smca smep ssbd sse sse2 sse4_1 sse4_2 sse4a ssse3 stibp succor 
  svm svm_lock syscall tce topoext tsc tsc_scale umip v_spec_ctrl 
  v_vmsave_vmload vgif vmcb_clean vme vmmcall wbnoinvd wdt xgetbv1 xsave 
  xsavec xsaveerptr xsaveopt xsaves 
  Vulnerabilities: Type: itlb_multihit status: Not affected 
  Type: l1tf status: Not affected 
  Type: mds status: Not affected 
  Type: meltdown status: Not affected 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, IBRS_FW, 
  STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
Graphics:
  Device-1: AMD Renoir vendor: Lenovo driver: amdgpu v: kernel bus-ID: 05:00.0 
  chip-ID: 1002:1636 class-ID: 0300 
  Device-2: IMC Networks Integrated Camera type: USB driver: uvcvideo 
  bus-ID: 1-3:2 chip-ID: 13d3:56ff class-ID: 0e02 
  Display: wayland server: X.org 1.20.13 compositor: gnome-shell driver: 
  loaded: amdgpu,ati unloaded: modesetting alternate: fbdev,vesa display-ID: 0 
  resolution: <missing: xdpyinfo> 
  OpenGL: renderer: AMD RENOIR (DRM 3.41.0 5.13.13-1-MANJARO LLVM 12.0.1) 
  v: 4.6 Mesa 21.2.1 direct render: Yes 
Audio:
  Device-1: AMD vendor: Lenovo driver: snd_hda_intel v: kernel bus-ID: 05:00.1 
  chip-ID: 1002:1637 class-ID: 0403 
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Lenovo 
  driver: N/A alternate: snd_pci_acp3x, snd_rn_pci_acp3x bus-ID: 05:00.5 
  chip-ID: 1022:15e2 class-ID: 0480 
  Device-3: AMD Family 17h HD Audio vendor: Lenovo driver: snd_hda_intel 
  v: kernel bus-ID: 05:00.6 chip-ID: 1022:15e3 class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.13-1-MANJARO running: yes 
  Sound Server-2: sndio v: N/A running: no 
  Sound Server-3: JACK v: 1.9.19 running: no 
  Sound Server-4: PulseAudio v: 15.0 running: yes 
  Sound Server-5: PipeWire v: 0.3.34 running: yes 
Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet 
  vendor: Lenovo driver: r8169 v: kernel port: 3000 bus-ID: 03:00.0 
  chip-ID: 10ec:8168 class-ID: 0200 
  IF: eno1 state: down mac: <filter> 
  Device-2: Realtek vendor: Lenovo driver: rtw89_pci v: N/A modules: rtw89pci 
  port: 2000 bus-ID: 04:00.0 chip-ID: 10ec:8852 class-ID: 0280 
  IF: wlp4s0 state: up mac: <filter> 
  IP v4: <filter> type: dynamic noprefixroute scope: global 
  broadcast: <filter> 
  IP v6: <filter> type: noprefixroute scope: link 
  WAN IP: <filter> 
Bluetooth:
  Device-1: Realtek Bluetooth Radio type: USB driver: btusb v: 0.8 
  bus-ID: 3-4:3 chip-ID: 0bda:4852 class-ID: e001 serial: <filter> 
  Report: rfkill ID: hci0 rfk-id: 3 state: up address: see --recommends 
Logical:
  Message: No logical block device data found. 
RAID:
  Message: No RAID data found. 
Drives:
  Local Storage: total: 704.24 GiB used: 253.27 GiB (36.0%) 
  SMART Message: Required tool smartctl not installed. Check --recommends 
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: MZALQ256HAJD-000L2 
  size: 238.47 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s 
  lanes: 4 type: SSD serial: <filter> rev: BL2QFXV7 temp: 28.9 C scheme: GPT 
  ID-2: /dev/sda maj-min: 8:0 vendor: Crucial model: CT500MX500SSD1 
  size: 465.76 GiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s 
  type: SSD serial: <filter> rev: 032 scheme: MBR 
  Message: No optical or floppy data found. 
Partition:
  ID-1: / raw-size: 118.99 GiB size: 116.56 GiB (97.96%) 
  used: 41.56 GiB (35.7%) fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3 
  label: N/A uuid: 0b90181d-1eb7-44d7-bc37-80c878000293 
  ID-2: /boot/efi raw-size: 512 MiB size: 511 MiB (99.80%) 
  used: 4.6 MiB (0.9%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A 
  uuid: EB07-8818 
  ID-3: /mnt/SSD500 raw-size: 465.76 GiB size: 457.45 GiB (98.22%) 
  used: 211.7 GiB (46.3%) fs: ext4 dev: /dev/sda1 maj-min: 8:1 label: SSD500 
  uuid: a1936d96-6ea6-4cb5-b62d-618a8ec8a2a8 
Swap:
  Alert: No swap data was found. 
Unmounted:
  ID-1: /dev/nvme0n1p2 maj-min: 259:2 size: 118.99 GiB fs: ext4 label: N/A 
  uuid: 0f80e24b-1488-4fd7-b5a4-c563182bf4f7 
USB:
  Hub-1: 1-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 1-3:2 info: IMC Networks Integrated Camera type: Video 
  driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA 
  chip-ID: 13d3:56ff class-ID: 0e02 
  Hub-2: 2-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
  Hub-3: 3-0:1 info: Full speed (or root) Hub ports: 4 rev: 2.0 
  speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900 
  Device-1: 3-3:2 info: Elan Micro ELAN:Fingerprint type: <vendor specific> 
  driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA 
  chip-ID: 04f3:0c4b class-ID: 0000 
  Device-2: 3-4:3 info: Realtek Bluetooth Radio type: Bluetooth driver: btusb 
  interfaces: 2 rev: 1.0 speed: 12 Mb/s power: 500mA chip-ID: 0bda:4852 
  class-ID: e001 serial: <filter> 
  Hub-4: 4-0:1 info: Full speed (or root) Hub ports: 2 rev: 3.1 speed: 10 Gb/s 
  chip-ID: 1d6b:0003 class-ID: 0900 
Sensors:
  System Temperatures: cpu: 37.5 C mobo: N/A gpu: amdgpu temp: 36.0 C 
  Fan Speeds (RPM): N/A 
Info:
  Processes: 253 Uptime: 21m wakeups: 211 Init: systemd v: 248 tool: systemctl 
  Compilers: gcc: 11.1.0 Packages: pacman: 1535 lib: 468 flatpak: 0 Shell: Zsh 
  v: 5.8 running-in: gnome-terminal inxi: 3.3.06 

And as you’re on Gnome and not KDE, I have no further ideas, except reclassifying your question to the Gnome category and adding a few tags…

:frowning:

It appears this issue only occurs when on battery power.
When the charging cable is connected I also see those reset full-speed USB device errors, but the mouse is not disconnected & BT still works. Only when the power cable is unplugged, BT will fail after some interval.

Yes I am on Gnome, but the OP is KDE describing the same/similar issue. I didnt mean to hijack it, I was hoping he would reply.

1 Like

Yes, this was one thing we also found out in the thread that I liked to above…
Still don’t know if this is helpful, though…

1 Like

Execute:

pamac install tlpgui
tlpgui

Turn off power saving for Bluetooth and the USB bus.

:crossed_fingers:

1 Like

This is what I get:

~ >>> pamac install tlpgui
Fehler: Ziel nicht gefunden: tlpgui

My machine is still running Gnome. Is that something to consider?
Viele Grüße
Axel

:man_facepalming:

I’m an idiot!

pamac install tlpui
tlpui

Entschuldigung!!! :scream:

1 Like

Und? So? Did that help?

:thinking:

No, sadly it didn’t :frowning_face:
So I’m switching back to my wired mouse now…
Would be nice to have, but really doesen’t bother me much.
Thanks you!
Viele Grüße
Axel

1 Like

For me it worked so far, i don’t use the laptop a lot so I’m not entirely sure if it’s fixed for good, but since I applied your fix the problem didn’t happen again.

I’ll try it a little more and mark your answer as the solution when I’m sure the problem is gone.

Either way thanks a lot for helping @Fabby :smiley:

1 Like