Blank Screen after suspend, brightness key not working, bluetooth auto start at boot

Hi All,
I bought New Dell 15 Inspiron 5505 AMD Ryzen 7. I am facing some problems like blank screen after suspend, brightness not working now, was working at the beginning, can’t stop Bluetooth auto start at booting - did try tlp to stop loading bluetooth at boot.

Here is the inxi output

System:
  Kernel: 5.15.7-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=a84e491f-4210-4c6f-8d5e-4993677b668a rw quiet
    resume=UUID=dc1c95cc-ca12-43da-9805-b311b2f8db7e udev.log_priority=3
  Desktop: GNOME 41.2 tk: GTK 3.24.30 wm: gnome-shell dm: GDM 41.0
    Distro: Manjaro Linux base: Arch Linux
Machine:
  Type: Laptop System: Dell product: Inspiron 5505 v: 1.5.4
    serial: <superuser required> Chassis: type: 10 v: 1.5.4
    serial: <superuser required>
  Mobo: Dell model: 0GFPRC v: A01 serial: <superuser required> UEFI: Dell
    v: 1.5.4 date: 06/10/2021
Battery:
  ID-1: BAT0 charge: 32.4 Wh (81.4%) condition: 39.8/39.8 Wh (100.0%)
    volts: 12.2 min: 11.2 model: SMP-ATL3.56 DELL C5KG613 type: Li-poly
    serial: <filter> status: Discharging
Memory:
  RAM: total: 15.06 GiB used: 3.3 GiB (21.9%)
  RAM Report:
    permissions: Unable to run dmidecode. Root privileges required.
CPU:
  Info: model: AMD Ryzen 7 4700U with Radeon Graphics bits: 64 type: MCP
    arch: Zen 2 family: 0x17 (23) model-id: 0x60 (96) stepping: 1
    microcode: 0x8600104
  Topology: cpus: 1x cores: 8 smt: <unsupported> cache: L1: 512 KiB
    desc: d-8x32 KiB; i-8x32 KiB L2: 4 MiB desc: 8x512 KiB L3: 8 MiB
    desc: 2x4 MiB
  Speed (MHz): avg: 1396 high: 1397 min/max: 1400/2000 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1397 2: 1397
    3: 1397 4: 1396 5: 1397 6: 1397 7: 1397 8: 1397 bogomips: 31959
  Flags: 3dnowprefetch abm adx aes aperfmperf apic arat avic avx avx2 bmi1
    bmi2 bpext cat_l3 cdp_l3 clflush clflushopt clwb clzero cmov cmp_legacy
    constant_tsc cpb cpuid cqm cqm_llc cqm_mbm_local cqm_mbm_total
    cqm_occup_llc cr8_legacy cx16 cx8 de decodeassists extapic extd_apicid
    f16c flushbyasid fma fpu fsgsbase fxsr fxsr_opt ht hw_pstate ibpb ibrs ibs
    irperf lahf_lm lbrv lm mba mca mce misalignsse mmx mmxext monitor movbe
    msr mtrr mwaitx nonstop_tsc nopl npt nrip_save nx osvw overflow_recov pae
    pat pausefilter pclmulqdq pdpe1gb perfctr_core perfctr_llc perfctr_nb
    pfthreshold pge pni popcnt pse pse36 rapl rdpid rdpru rdrand rdseed rdt_a
    rdtscp rep_good sep sha_ni skinit smap smca sme smep ssbd sse sse2 sse4_1
    sse4_2 sse4a ssse3 stibp succor svm svm_lock syscall tce topoext tsc
    tsc_scale umip v_spec_ctrl v_vmsave_vmload vgif vmcb_clean vme vmmcall
    wbnoinvd wdt xgetbv1 xsave xsavec xsaveerptr xsaveopt xsaves
  Vulnerabilities:
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional,
    IBRS_FW, STIBP: disabled, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
Graphics:
  Device-1: AMD Renoir vendor: Dell driver: amdgpu v: kernel bus-ID: 03:00.0
    chip-ID: 1002:1636 class-ID: 0300
  Device-2: Realtek Integrated_Webcam_HD type: USB driver: uvcvideo
    bus-ID: 3-2:2 chip-ID: 0bda:5538 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.org 1.21.1.2 compositor: gnome-shell driver:
    loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
    resolution: <missing: xdpyinfo>
  OpenGL: renderer: AMD RENOIR (DRM 3.42.0 5.15.7-1-MANJARO LLVM 13.0.0)
    v: 4.6 Mesa 21.2.5 direct render: Yes
Audio:
  Device-1: AMD vendor: Dell driver: snd_hda_intel v: kernel bus-ID: 03:00.1
    chip-ID: 1002:1637 class-ID: 0403
  Device-2: AMD Raven/Raven2/FireFlight/Renoir Audio Processor vendor: Dell
    driver: snd_rn_pci_acp3x v: kernel alternate: snd_pci_acp3x,snd_pci_acp5x
    bus-ID: 03:00.5 chip-ID: 1022:15e2 class-ID: 0480
  Device-3: AMD Family 17h HD Audio vendor: Dell driver: snd_hda_intel
    v: kernel bus-ID: 03:00.6 chip-ID: 1022:15e3 class-ID: 0403
  Sound Server-1: ALSA v: k5.15.7-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
Network:
  Device-1: Qualcomm Atheros QCA6174 802.11ac Wireless Network Adapter
    vendor: Dell driver: ath10k_pci v: kernel bus-ID: 02:00.0 chip-ID: 168c:003e
    class-ID: 0280
  IF: wlp2s0 state: up mac: <filter>
  IP v4: <filter> type: dynamic noprefixroute scope: global
    broadcast: <filter>
  IP v6: <filter> type: noprefixroute scope: link
  WAN IP: <filter>
Bluetooth:
  Device-1: Qualcomm Atheros type: USB driver: btusb v: 0.8 bus-ID: 3-3:3
    chip-ID: 0cf3:e007 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: down bt-service: enabled,running
    rfk-block: hardware: no software: yes address: see --recommends
Logical:
  Message: No logical block device data found.
RAID:
  Message: No RAID data found.
Drives:
  Local Storage: total: 476.94 GiB used: 35.96 GiB (7.5%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: SK Hynix model: BC511 NVMe 512GB
    size: 476.94 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 11004101 temp: 34.9 C scheme: GPT
  Message: No optical or floppy data found.
Partition:
  ID-1: / raw-size: 78.64 GiB size: 76.85 GiB (97.72%) used: 14.92 GiB (19.4%)
    fs: ext4 dev: /dev/nvme0n1p3 maj-min: 259:3 label: N/A
    uuid: a84e491f-4210-4c6f-8d5e-4993677b668a
  ID-2: /boot/efi raw-size: 500 MiB size: 499 MiB (99.80%)
    used: 300 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1 label: N/A
    uuid: CAFA-74E3
  ID-3: /data raw-size: 320.31 GiB size: 314.22 GiB (98.10%)
    used: 13.1 GiB (4.2%) fs: ext4 dev: /dev/nvme0n1p5 maj-min: 259:5 label: N/A
    uuid: 5bb42ef9-971c-4c02-8c2f-e79026247a2c
  ID-4: /home raw-size: 69.18 GiB size: 67.54 GiB (97.63%)
    used: 7.95 GiB (11.8%) fs: ext4 dev: /dev/nvme0n1p4 maj-min: 259:4
    label: N/A uuid: f63832be-6ed0-45f9-a51d-b9506202adad
Swap:
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: partition size: 8.32 GiB used: 0 KiB (0.0%)
    priority: -2 dev: /dev/nvme0n1p2 maj-min: 259:2 label: N/A
    uuid: dc1c95cc-ca12-43da-9805-b311b2f8db7e
Unmounted:
  Message: No unmounted partitions found.
USB:
  Hub-1: 1-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Hub-2: 2-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
  Hub-3: 3-0:1 info: Hi-speed hub with single TT ports: 4 rev: 2.0
    speed: 480 Mb/s chip-ID: 1d6b:0002 class-ID: 0900
  Device-1: 3-1:5 info: A4Tech A4tech 2.4G Wireless Device
    type: Keyboard,Mouse driver: hid-generic,usbhid interfaces: 2 rev: 2.0
    speed: 12 Mb/s power: 100mA chip-ID: 09da:0024 class-ID: 0301
  Device-2: 3-2:2 info: Realtek Integrated_Webcam_HD type: Video
    driver: uvcvideo interfaces: 2 rev: 2.0 speed: 480 Mb/s power: 500mA
    chip-ID: 0bda:5538 class-ID: 0e02 serial: <filter>
  Device-3: 3-3:3 info: Qualcomm Atheros type: Bluetooth driver: btusb
    interfaces: 2 rev: 2.0 speed: 12 Mb/s power: 100mA chip-ID: 0cf3:e007
    class-ID: e001
  Device-4: 3-4:4 info: Shenzhen Goodix FingerPrint type: <vendor specific>
    driver: N/A interfaces: 1 rev: 2.0 speed: 12 Mb/s power: 100mA
    chip-ID: 27c6:538d class-ID: ff00
  Hub-4: 4-0:1 info: Super-speed hub ports: 2 rev: 3.1 speed: 10 Gb/s
    chip-ID: 1d6b:0003 class-ID: 0900
Sensors:
  System Temperatures: cpu: 36.0 C mobo: 33.0 C gpu: amdgpu temp: 40.0 C
  Fan Speeds (RPM): cpu: 0
Info:
  Processes: 294 Uptime: 1h 35m wakeups: 6717 Init: systemd v: 249
  tool: systemctl Compilers: gcc: 11.1.0 Packages: pacman: 1297 lib: 363
  Shell: Zsh v: 5.8 running-in: gnome-terminal inxi: 3.3.11

Here is journalctl -xe result link.
Manjaro helper log

Any help is really appriciated.
Thanks in advance

add i915.enable_dpcd_backlight=0 as boot parameter to fix backlight problem

edit the file /etc/default/grub as root and add i915.enable_dpcd_backlight=0 to GRUB_CMDLINE_LINUX parameter which is usually at the top. don’t remove the existing parameters. run sudo update-grub and reboot and check if you can change brightness now.

i don’t think tlp has anything to do with bluetooth. use sudo systemctl disable bluetooth.service

1 Like

@ishaanbhimwal Thank you for your suggestion.
I was searching for the solution and find that Dell 15 Inspiron 5505 AMD Ryzen 7 with AMD RENOIR graphics has S3 sleep issue. Dell disable the S3 support. Laptop screen stays blank after suspend. Brightness key also not working.

Here is the links that helps me understand what to do for my case.

Link 1
Link 2

My solution was to install the experimental kernel 5.16.0-1-MANJARO.

Now my laptop can show the login screen when the lid is open from sleep, before it was blank screen and I had to hard reset.

For Bluetooth I have to install tlp-rdw and set the proper setting there.

Brightness key is now working as it suppose to be.

Only one problem left, when it woke up from sleep it can’t remember the WiFi mouse was plugged in rather I have to re plug in to work. I hope in future this problem also will solved by the kernel upgrade or may be I need to change some settings. You are more welcome to suggest any solution to WiFi mouse problem.

:grinning:

nice that 2 of your issues are solved but try switching to lts kernel. it is more reliable and will probably solve the wifi issue

1 Like

Blank screen problem seems to be appearing again after sleep. It did work few times. Ahh, I have to wait for the upstream kernel release to fix it or have to apply the patch. To be honest never did patching by myself. :frowning_face:

not tried but might work →
Edit the grub file by editing it with sudo access.

sudo vim /etc/default/grub 

Add nouveau.modeset=0 to the line that says GRUB_CMDLINE_LINUX="" so that it finally looks like this GRUB_CMDLINE_LINUX="nouveau.modeset=0". Don’t remove the existing parameters.

Then run

sudo update-grub

Reboot after successfully updating grub.

1 Like

Okay I tried GRUB_CMDLINE_LINUX="nouveau.modeset=0" and the system boot up correctly. Last time I also did try the modeset but without the value and the login screen was blank.

I also tried 5 minutes lid down and when the lid was open the login screen load successfully. Lets hope it stays persistent. Will also test with more time close lid in a day and will post the update here.

Thanks @ishaanbhimwal .

I pray that the upstream developers understand the issue and able to fix it by kernel release. The device works fine with Windows sleep function. I hope in future it will also work fine with Linux. :slightly_smiling_face:

Edit:
I found some instruction in this link about another dell model, I may need to follow the instruction of patching.

cat /sys/power/mem_sleep                                         
[s2idle]

sudo dmesg | grep -i acpi | grep supports                       
[sudo] password for shahi: 
[    0.412652] ACPI: PM: (supports S0 S4 S5)
[    0.428489] acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI EDR HPX-Type3]

Indeed my laptop don’t have the S3 sleep mode.

1 Like

Did you try this: Fix suspend issues on Dell 7405 2-in-1 - DEV Community? It didn’t work on my 5500U HP, but maybe it will for your Dell 5505.

@TheRoark yes it did solve my issue for now. I still have the USB device connected issue. After wake up from sleep it can’t remember my WiFi mouse. I have to re plugged it.

try disabling tlp :point_down:

I tried with disabling TLP and it didn’t work.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.