Bluetooth and usb not working with tlp on battery

I recently installed Manjaro and randomly, when using my laptop on battery, both Bluetooth and USB ports stop working. I tried to disable USB autosuspend without any results. I disable TLP entirely and everything works without issue, but I don’t know if that can have a bad impact on my battery life. There is another (less drastic) solution? Thanks in advance.

Some data from my laptop:
OS: Manjaro Linux x86_64
Host: TUF Gaming FX505DT_FX505DT 1.0
Kernel: 5.15.7-1-MANJARO
Shell: zsh 5.8
Resolution: 1920x1080
DE: GNOME 41.2
CPU: AMD Ryzen 7 3750H with Radeon Vega Mobile G
GPU: NVIDIA GeForce GTX 1650 Mobile / Max-Q
GPU: AMD ATI 05:00.0 Picasso

You can disable tlp and try any other power management software

See this thread:

Run the following:

lspci | grep -iE 'blu|usb'

You should get output like this:

02:00.3 USB controller: Advanced Micro Devices, Inc. [AMD] Raven USB 3.1
02:00.4 USB controller: Advanced Micro Devices, Inc. [AMD] Raven USB 3.1

So then we uncomment and add the USB controllers to the RUNTIME_PM_DENYLIST line of /etc/tlp.conf or better yet a drop-in file like /etc/tlp.conf.d/99-denied.conf. Example:

RUNTIME_PM_DENYLIST="02:00.3 02:00.4"

Its ‘safe’ to run without TLP, yes.
But it is the eminent power management daemon.
And from what I can tell, it offers more (antenna and sata controls) than alternatives like cpufreq.

1 Like

I tried everything you say. I disabled USB autosuspend entirely and doesn’t work. The only way if to disable TLP on the config file

Thanks, I will check it :ok_hand:

1 Like

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.