Fail to restart after suspend

This is a problem I had on Mint so I decided to try Manjaro with newer Kernels etc.

I can set the machine to sleep and it does switching off monitors.

However the machine will not resume, no matter what.

My only option is to switch the machine off using the power button and restarting.

Have been using Linux happily for a while but right now back to Windows so I do not have to keep forcing the machine off every time I want to use it. Sadly this is the machine I need to work properly.

Any ideas would be greatly appreciated. It is an AMD machine.

  Host: wayne-desktop Kernel: 5.15.7-1-MANJARO x86_64 bits: 64 compiler: gcc
    v: 11.1.0 parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=fa7aeda9-1f81-4825-8bcc-03eee27a7f85 rw quiet apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: KDE Plasma 5.23.4 tk: Qt 5.15.2 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux
  Type: Desktop Mobo: ASUSTeK model: PRIME X570-P v: Rev X.0x
    serial: <superuser required> UEFI: American Megatrends v: 4021
    date: 08/09/2021
  Info: model: AMD Ryzen 5 3600X bits: 64 type: MT MCP arch: Zen 2
    family: 0x17 (23) model-id: 0x71 (113) stepping: 0 microcode: 0x8701021
  Topology: cpus: 1x cores: 6 tpc: 2 threads: 12 smt: enabled cache:
    L1: 384 KiB desc: d-6x32 KiB; i-6x32 KiB L2: 3 MiB desc: 6x512 KiB
    L3: 32 MiB desc: 2x16 MiB
  Speed (MHz): avg: 2831 high: 3678 min/max: 2200/4409 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 2933 2: 3493
    3: 3540 4: 2050 5: 2714 6: 3625 7: 3678 8: 2385 9: 2169 10: 2052 11: 3058
    12: 2283 bogomips: 91061
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Full AMD retpoline, IBPB: conditional, STIBP:
    conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: AMD Navi 10 [Radeon RX 5600 OEM/5600 XT / 5700/5700 XT]
    driver: amdgpu v: kernel bus-ID: 09:00.0 chip-ID: 1002:731f class-ID: 0300
  Display: x11 server: compositor: kwin_x11 driver:
    loaded: amdgpu,ati unloaded: modesetting,radeon alternate: fbdev,vesa
    resolution: <missing: xdpyinfo>
  Message: Unable to show advanced data. Required tool glxinfo missing.
  Device-1: AMD Navi 10 HDMI Audio driver: snd_hda_intel v: kernel
    bus-ID: 09:00.1 chip-ID: 1002:ab38 class-ID: 0403
  Device-2: AMD Starship/Matisse HD Audio vendor: ASUSTeK
    driver: snd_hda_intel v: kernel bus-ID: 0b:00.4 chip-ID: 1022:1487
    class-ID: 0403
  Sound Server-1: ALSA v: k5.15.7-1-MANJARO running: yes
  Sound Server-2: JACK v: 1.9.19 running: no
  Sound Server-3: PulseAudio v: 15.0 running: yes
  Sound Server-4: PipeWire v: 0.3.40 running: yes
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASUSTeK PRIME B450M-A driver: r8169 v: kernel port: f000
    bus-ID: 03:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp3s0 state: up speed: 1000 Mbps duplex: full mac: 04:d9:f5:80:08:d4
  Local Storage: total: 4.55 TiB used: 10.89 GiB (0.2%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST4000DM004-2CV104
    size: 3.64 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 5425 serial: ZFN2SJJ6 rev: 0001 scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Samsung model: SSD 860 EVO 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: S4FMNE0MB02205N rev: 3B6Q scheme: GPT
  ID-1: / raw-size: 233.43 GiB size: 228.71 GiB (97.98%)
    used: 10.86 GiB (4.7%) fs: ext4 dev: /dev/sdb5 maj-min: 8:21
  ID-2: /boot/efi raw-size: 99 MiB size: 95 MiB (95.96%)
    used: 31.6 MiB (33.3%) fs: vfat dev: /dev/sdb2 maj-min: 8:18
  Alert: No swap data was found.
  System Temperatures: cpu: N/A mobo: N/A gpu: amdgpu temp: 45.0 C mem: 44.0 C
  Fan Speeds (RPM): N/A gpu: amdgpu fan: 1215
  Processes: 308 Uptime: 25m wakeups: 0 Memory: 62.78 GiB
  used: 3.03 GiB (4.8%) Init: systemd v: 249 tool: systemctl Compilers:
  gcc: 11.1.0 Packages: 1223 pacman: 1217 lib: 333 flatpak: 0 snap: 6
  Shell: Zsh v: 5.8 default: Bash v: 5.1.12 running-in: konsole inxi: 3.3.11

I hope someone can help.

1 Like

try switching to lts kernel >
1.) Go to manjaro settings.
2.) Navigate to kernels and install lts one
3.) boot from preferred kernel through grub advanced options

1 Like

5.15 is the latest to be LTS. I Use it myself. See:

Nevertheless, trying a different kernel is a good idea. From the terminal, run:

mhwd-kernel --install linux54


mhwd-kernel --install linux510

Both of which are also LTS. Reboot and press shift to bring uup the GRUB screen. On it, scroll and select Advanced… option, then select the kernel to use, boot into it, and test it.

Hope this helps!

1 Like

I tried the LTS kernels. 5.10 and 5.4 makes no difference at all.

I will add that using Linux the monitors will not switch off, ie blank when not in use

I Have been having this issue for months. Not just with Manjaro. I have 2 Desktop systems. One is a fairly new system Intel alder lake based. The other is an AMD system with a 3700x. The only thing in common between the systems is an AMD GPU 6700xt.

I have tried every distro you can think of. Always the same, the system will either not let the display come out of suspend or the fans speed up and the system can’t even be reset resulting in the need to pull the plug.

I never had this issue while I was using an Nvidia GPUs.

See in the bios if you can switch between new style sleep mode (S2idle) and legacy sleep mode (S3). It may come under a variety of labels. Linux on AMD doesn’t support S2idle well (and that’s a euphemism) but some motherboards allow you to revert to legacy mode ; note that those modes are incompatible (it’s either one or the other) and Microsoft mandates S2idle to be the one enabled by default.
Sadly, some OEMs won’t provide a bios switch (HP, for instance - ask me how I know), in that case you’re stuck until a stable S2idle support makes its way into the kernel.

here is a similar thread - Blank Screen after suspend, brightness key not working, bluetooth auto start at boot
you may want to try out 5.16.0-1-MANJARO kernel

1 Like

Tried the 5.16. rc4 no difference. Is there any major change between it and 5.16…0-1?

If not then not sure it will make a difference.

Not an option on my board

Hi @waynus

Follow this link and you will get the idea what is going on with AMD and what you have to do.
At least I am able to solve the sleep and woke up problem.

If your laptop bios has sleep option to change than problem will solve easily if not than you have to patch the DSDT.

Due to the new Windows “modern/connected standby” (S0ix) the good old sleep to RAM (S3) is disabled in some laptops. We need to patch our DSDT to make S3 available again.

Asus calls it “deep sleep”, I believe, or something to that effect. But you may not have the option either.

According to my motherboard s3 is enabled.

The following sleep states are available on this system:
    Standby (S3)
    Hybrid Sleep

The following sleep states are not available on this system:
    Standby (S1)
        The system firmware does not support this standby state.

    Standby (S2)
        The system firmware does not support this standby state.

    Standby (S0 Low Power Idle)
        The system firmware does not support this standby state.

    Fast Startup
        This action is disabled in the current system policy.

My machine is also not a laptop. does that make a difference?

What is the output of this

sudo dmesg | grep -i acpi | grep supports


cat /sys/power/mem_sleep

May be, I am not sure. I am just a fellow user of Linux, not an expert.

[    0.407563] ACPI: PM: (supports S0 S3 S4 S5)
[    0.413930] acpi PNP0A08:00: _OSC: OS supports [ExtendedConfig ASPM ClockPM Segments MSI EDR HPX-Type3]

s2idle [deep]

I am puzzled by the second output it seems to support a mode that the motherboard does not.

I think my solution came with switching IOMMU to disabled on the motherboard.

It had 3 settings enabled, disabled and auto. It was set to auto.

Not sure why?

I was able to upgrade back to the latest kernel after updating to [Stable Update] 2022-01-02 - Kernels, Systemd, KDE Frameworks, Mesa, Xorg-Server, Wine, Python 3.10 (See the changelog about X-server)

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.