Blackscreen on boot after Plasma 6 update

Hi everyone, as the title says, after downloading the update and rebooting yesterday my computer stays on a black screen.

So far I have luckily been able to log into TTY and do the following steps:

  • decompress all zstd-compressed firmwares in /lib/firmware/
  • update the linux-firmware (yes afterwards since i only got that update this morning as opposed to the big changes happening yesterday)
  • download versions 6.1, 6.6 and 6.9 with downloading separately the Nvidia drivers (the packages named “linux00-nvidia”)
  • cleaned up now flagged out of date/not in AUR packages such as Pyside and Shiboken.
  • search in both journalctl and startX logs

Sadly none of this was enough yet, I am usually able to Google-fu my way out of Linux/Manjaro focused problems, but here I feel beaten. So here I am making this comment to humbly request some help on the matter.

1 Like

I have the same issue and believe it has to do with the nvidia drivers. When I boot the system I do get the first majaro screen with the three dots, bit afterwards it’s just a black screen.


Alright I got it working again. Not sure if this fixes it for you but it had installed kernel 6.7 for me and I got into grub and launched with kernel 6.6.30-2. Then it booted just fine. Then went into Manjaro settings manager and uninstalled kernel 6.7. Afterwards it booted just fine using kernel 6.6.30-2

Kernel 6.7 is EOL.
Of course if you have EOL kernels you should remove them (+ replace with working ones).

Also it was posted in super bold on the announcement.

Yeah and I already tried 6.6 because I was on 5.15 before that update and I’m now trying whatever I can.
With a friend of mine we tried to tinker with Xorg to see if we could get some insights in the logs but nothing does it yet.


  • I found out that I was able to launch Wayland, so I manually boot it every time until I can find the answer to my problem.
  • Xorg logs aren’t helping either, the only error I can find concerns the touchpad:

[ 10.013] (EE) libinput: SynPS/2 Synaptics TouchPad: Failed to create a device for /dev/input/mouse0
[ 10.013] (EE) PreInit returned 2 for “SynPS/2 Synaptics TouchPad”

There was another user yesterday/today with touchpad issues, which might be related. I don’t know whether the issue was resolved, but if you search the forum for the user jackdinn’s recent posts, you might find something useful.

As you will see there are many threads with similar black screen issues. The following article should help to troubleshoot your issue.

That’s all I can offer. I’ll chime in again if I think of anything useful.


Thank you, I did see most black screen issues and frankly I don’t know anymore if the amount of things I did is improving or if i have created more issues somehow.
edit: I didn’t see the link was just the tutorial so to clarify, I already went through all the steps in it.

I’ll see for the touchpad too, as I vaguely remember once a few years back having a black screen problem and the same-ish touchpad error, why and were they related I don’t remember but anything is worth trying ig.

1 Like

The Plymouth boot screen (the three dots) could also be contributing to the issue. Plymouth is known to cause boot problems for some users, in varying circumstances.

Many people (myself included) remove it completely, however, it is not as simple as uninstalling it; it requires a few more steps due to it’s close ties with boot processes.

See: [HowTo] Disable or Remove Plymouth (boot splash) for more information.


For some reason it looks like I am the only user not having Plymouth, I tried searching for the packages but nothing comes up.

on the other hand, I got here some Xorg logs, I don’t know if they are useful, but there seems to be more than just the touchpad going on:

I used the command:

sudo cat /var/log/Xorg.2.log | grep -e EE -e WW

My guess is you uninstalled it at some point or you installed Manjaro using the minimal ISO instead of the full ISO. Otherwise :man_shrugging:

Check whether it’s installed using:

pacman -Qi plymouth

yeah I tested and it just says “error: package ‘plymouth’ was not found”.
I honestly don’t remember what were the specifics when I installed Manjaro it has been more than 3 years now haha

It might be time to do some spring cleaning.

You could download the latest full ISO and start over; it might ultimately solve many issues. Three years is plenty of time for a rolling release to get messed up. :wink:

Aye, I was already fearing to have to do that, but maybe that’s a good solution. I’ll probably soon see to do just that :sweat_smile:

If you do, I suggest using the manual partitioning method and creating a separate /home - that’s sure to be more convenient if you ever need to reinstall in the future.

1 Like