Failed to start Simple Desktop Display Manager

Hi, I’m newbie.
I’ve just start a fresh install and updating the system, but upon restart, I cannot go pass through “[Failed] Failed to start Simple Desktop Display Manager”. Is there any way around?

Hello and welcome,

Sounds like a partial update to me. From TTY please run this commands as your user:

sudo pacman-mirrors -f && sudo pacman -Syyu plasma-desktop sddm qt5-base
then reboot the system by
systemctl reboot

If the issue still persists, from TTY once again you run:
systemctl stop sddm

Try to start your session with:

1 Like

I don’t know how to run TTY as user. I try to change some parameter in BIOS and end up having ‘there is no bootable media’.

Now, I’m doing a clean install right from the start.

Hi, I am having a similar issue and following your advice, when I try to run


I get $DISPLAY is not set or cannot connect to the X server.

Any suggestions on how I might rectify that?

But the sddm is not running?
systemctl status sddm

Try to enable it manually
systemctl enable sddm

Sorry for the photo, can’t copy paste. :blush:

1 Like

The sddm.service start request repeated too quickly is a tricky one, at least for me.
Do this from that TTY
systemctl stop sddm
systemctl disable sddm
systemctl enable sddm
systemctl reboot

1 Like

Unfortunately the same thing. Is there a clean way to uninstall/reinstall xorg and led plasma without affecting the rest of the system?

Do not unistall packages, just reinstall them the way i mentioned above about sddm and plasma-desktop.
sudo pacman -Syu xorg-xerver xorg-xerver-comon xorg-xerver-wayland

This is just an example.
Is the display failing to start too if you create a test user and try to log in?

Appreciate the help, but I just ended up reinstalling as the time my computer was down, is longer than the time it would take to set it back up (maybe lol)

Did anyone find a fix? This is the second time it’s happened to me and I’m not installing Manjaro again. The only thing it says for me is “[Failed] Failed to start Simple Desktop Display Manager” and I can’t type anything…

I am facing the same issue.
Did you find any solution to this?

I have just encountered this issue as well after the 2020-08-22 update.
@bogdancovaciu I booted off a Live USB and use chroot too run the reinstall you suggested but it did not rectify the issue.

@lallmon: thanks for the photo! exactly what happened to my system today…

@el1x: feel you here, don’t know which update exactly bombed my system that way but encountered it today. :frowning:

Solution in my case was, what bogdancovaciu posted with stopping, disabling and enabling sddm. After reboot my system could start up again. :slight_smile:

Don’t know what happened really, strange issue right here.

A post was split to a new topic: Could not resolve host

I also had the same problem.
It was a driver(graphics) problem.
I did the following to solve it …
Ctrl + Alt + F2
Input username and password.
Then hit Enter.
Now type mhwd -l -d
Here you will see a list of installed and available drivers.
In the list of available drivers you might find some with PRIORITY: 0 .
Sometimes they are the ones causing problem.
As for me it is was video-vesa .
So, all I had to do was remove it.
To remove it you may use the following command.
sudo mhwd -r pci [name of driver]
Note: pci because it showed ATTACHED: PCI in mhwd. If it shows ATTACHED: USB you need to type usb instead of pci
For me I typed sudo mhwd -r pci video-vesa and removed the driver.
Then I rebooted my pc. sudo reboot.
Finally, I’ve solved the problem and also know what caused the problem.


Yesss, this did the trick for me. I had recently installed video-vesa without knowing what it was. Stupid me. Thank You!!

I am using optimus-switch-sddm for graphics because it was the only way for me to get my Linux laptop to work with external monitors properly. GitHub - dglt1/optimus-switch-sddm: easy installer for optimus-switch for SDDM, sets up nvidia PRIME and also allows for easy switching between intel/nvidia (prime mode) and intel only mode where nvidia gpu is powered down and no longer visible. modes are switched with "sudo" or "sudo" .

What solved the issue for me, was to run the following, where XXX is the updated kernel (with which the sddm started to fail).

sudo pacman -S linuxXXX-headers acpi_call-dkms xorg-xrandr xf86-video-intel git

In addition, I also ran the below (not sure if it mattered) and rebooted.

sudo pacman-mirrors -f && sudo pacman -Syyu plasma-desktop sddm qt5-base

1 Like

My problem was exactly the same and your solution resolved the issue.

This worked for me too.