Black login screen

I am running RC 21.1 with kernel 5.13 (Gnome). Since today the log in screen is black. To log in I have to enter text mode with Ctrl + Alt + F2, log in, then run startx. That then works.

I should add it worked yesterday when I installed the system. I had to use the RC with kernel 5.13 because I have a relatively new graphics card that was not supported properly in earlier versions.

I did run sudo pacman -Syyu to update everything and everything seems up to date.

Many thanks for great support and community!

Hello iulian7, welcome to this amazing community!

That problem seems awfully similar to the problem that I have every time I clean install Manjaro (I also run gnome). I’ve documented a solution here in a thread Fixing Black Screen by editing mkinitcpio.conf – What am I doing?

Basiclly, I followed what goes bellow Early KMS start in here Kernel mode setting at Arch wiki. In essence, I loaded the drivers to my integrated gpu before the boot process and it solved the problem.

Let me know if that helps.

I do not have integrated graphics. I only have one graphics card. The Graphics section looks like this:

  Device-1: ASPEED Graphics Family driver: ast v: kernel 
  Device-2: AMD Navi 22 [Radeon RX 6700/6700 XT / 6800M] driver: amdgpu 
  v: kernel 
  Display: server: 1.20.11 driver: loaded: amdgpu,ati,modesetting 
  unloaded: radeon resolution: <missing: xdpyinfo> 
  OpenGL: renderer: AMD Radeon RX 6700 XT (NAVY_FLOUNDER DRM 3.41.0 
  5.13.5-1-MANJARO LLVM 12.0.1) 
  v: 4.6 Mesa 21.1.5

I changed the mkinitcpio.conf file so that MODULES=(amdgpu). It did not help. The ast driver is probably the VGA connector.

:+1: Welcome to Manjaro! :+1:

  1. Please read this:
    How to provide good information
    and post some more information so we can see what’s really going on. Now we know the symptom of the disease, but we need some more probing to know where the origin lies… :grin:
  2. An inxi --admin --verbosity=7 --filter --no-host --width would be the minimum required information for us to be able to help you. (Personally Identifiable Information like serial numbers and MAC addresses will be filtered out by the above command)
    Also, please copy-paste that output in-between 3 backticks ``` at the beginning and end of the code/text.


P.S. If you enter a bit more details in your profile, we can also see which Desktop Environment you’re using, which exact CPU/GPU or Kernel, … you have without typing it every time

1 Like

I have the exact same issue. During boot it says “Started Window Manager” and then it shows the rapidly blinking/flickering cursor on a black screen.
On this screen, when I spam CTRL+Alt+Fx sufficiently, I eventually am able to show a console. (it keeps switching back to the cursor screen until it doesn’t and shows me the console)

My machine is a Ryzen 7 3800 XT with an MSI Radeon 6700 XT.

When I boot with proprietary drivers from the USB install drive, inxi tells me (I manually typed this over, because copy/paste obviously won’t work):

  Device-1: AMD Navi 22 vendor: Micro-Star MSI driver: N/A bus-ID: 2d:00.0
  chip-ID: 1002:73df class-ID: 0300
  Display: server: 1.20.11 driver: loaded: ati, radeon
  unloaded: modesetting alternate: fbdev,vesa tty: 128x48
  Message: Advanced graphics data unavailable in console for root.

It looks like a driver problem, just like the one above and the topic over at AMD Navi 22 / 6700XT gives black screen at first install using Manjaro 21.0

  • I also edited the boot options and changed radeon.modeset=1 to amdgpu.modeset=1, to no avail. (both with the proprietary drivers and open source option)
inxi --admin --verbosity=7 --filter --no-host > /tmp/my-inxi.txt

Then copy /tmp/my-inxi.txt over to a USB stick and upload it here.


P.S. I can’t help any further with this, as I’m on KDE and nVidia, but have added #amdgpu to the question to attract the right experts! :innocent:


Thanks Fabby!

I found this:

forum dot manjaro dot org/t/radeon-rx-6700-xt-cannot-start-display-manager-black-screen/65820

The recommended driver for the newer cards right now is the video-linux driver aka amdgpu. Are you perhaps on an older kernel? Complete support for the newer cards has just arrived in 5.12, so that might be worth a try. Alternatively the 5.10 version had decent support for my 6800XT. You might als…

The ISO seems to be based on kernel 5.10, so that’s possibly the issue.

I’m going to try a newer kernel from github dot com/manjaro/release-review/releases
I’ll report back. If that doesn’t work, I’ll get an advanced inxi paste here! Cheers!

1 Like

Maybe superfluous info, bit try 5.14 as OP already tried 5.13.


I tried 5.13 with open source driver boot option: IT WORKS!

1 Like