Awful performance since install

I’ve installed Manjaro recently and chose proprietary drivers in the boot menu before installing it, but it seems like it’s using open driver sources, the performance is awful, but I don’t know if it’s related or not.
It randomly freezes even when doing basic tasks e.g I open up discord or maybe too many tabs on my browser (five or so) and sometimes it’s enough to freeze everything up. Playing games on steam like crusader kings, especially ones that uses proton, will freeze up the computer and force me to restart it.

My CPU is AMD Ryzen 5 5500U with Radeon Graphics (12).

I took the inxi from your other thread …


Now starting there.

You have an AMD video card … the best driver is the open source AMDGPU.
Theres nothing proprietary to want.
(theres some slight caveat to that with 3D rendering … but then you just want those proprietary components… and its besides the point here)


Kernel 6.5 is EOL (end of life).
See kernel.org
Please install a supported LTS and remove 6.5.
ex:

sudo mhwd-kernel -i linux66

Then reboot and select 6.6 from the menu.
You can double check the running kernel using uname -a.
Once not booted into 6.5 you may remove it.

sudo mhwd-kernel -r linux65

Your BIOS is out of date


You also have a small amount of memory and no swap. When you use those 6GB of RAM then your system will lock up.

It appears you are using the majority of it already. So I expect it probably runs out pretty easily.


Theres a number of other things that might be worth checking … but I would say handle those things first.

Recap;

  • Install LTS kernel and remove 6.5. See above.

  • To update the BIOS please refer to the manufacturers documentation. You will either be able to update using the UEFI/BIOS itself (load the update from a file using the administration screens), or you can use a windoze (either from Dual-Boot, or from a live system such as Hirens Boot CD).

  • Enable SWAP. You can choose any flavor, such as a swapfile, and so on.
    My suggestion is zram. See below.

Click for zram instructions
sudo pacman -Syu zram-generator

Then edit the configuration file. (use your preferred editor)

sudo micro /etc/systemd/zram-generator.conf

You want it to look like:

[zram0]
zram-size = ram / 1
compression-algorithm = zstd
swap-priority = 100
fs-type = swap

You may want to ensure zswap is disabled as well. One way is to add to the boot options, at /etc/default/grub the option zswap.enabled=0.
That is to add it to one of the CMD lines so that (Assuming no other options) it would look like:

GRUB_CMDLINE_LINUX="zswap.enabled=0"

Then run

sudo update-grub

And reboot.
You can check the configured swap/zram using

swapon
zramctl



Ultimately the main cause of

is your memory/swap situation. With about 99% certainty.
But the other points should be handled as soon as possible as well.

1 Like

I’ve updated the kernel now and set up SWAP. I’ll find out how to update my BIOS.
image
I’ll report back if it actually has changes to the performance.

Let us know how it goes.
Lenovo doesnt appear to offer easy-to-access changelogs of the BIOS updates, so I couldnt quickly see what it includes. But its usually a good idea to keep it updated.

Now that you have SWAP the hope is you should not experience freezes any longer.
(if you do … we may want to increase the SWAP size and/or begin looking at other possible culprits)

Note.
I forgot to mention that zram does not support Hibernation. (sleep/suspend is unaffected)
So please do not enable it, or if you end up doing so then replace zram with an alternative like a swapfile.

It completely fixed my performance problems, now I have no reasons to drop linux.

2 Likes

Happy days. Happy penguins.
Cheers. :slight_smile:

This topic was automatically closed 3 hours after the last reply. New replies are no longer allowed.