Extremely weird issue involving RTX 3060

Hi, I am making this request on behalf of someone else, so I can’t really get every single detailed log, but I have a lot of relevant information that I can manually re-type.

First, he cannot boot into Manjaro, or any other distro for that matter (we’ve tried Pop!, Endeavor and Manjaro) if we use the proprietary nvidia drivers. The installer just black screens, and if we install the drivers after the open-source drivers version is installed, it will just black screen on reboot.

Again, I am sorry for the crappiness of the log information I’m providing but he’s very far away and it’s hard to get this information from him.

System information

AMD Ryzen 7 1700 Eight-Core Processor

I don't really know what else is necessary.

We have also tried installing nvidia-470, same deal.

So, going into tty2 and doing startx results in this image. (The kernel was downgraded to 6.1 because someone mentioned it, it does the same thing on the most recent LTS kernel.)

The first page that has errors in the xorg log is something like this

We ran

sudo journalctl -b0 -g nvidia

and we got this

here is the rest of the information to the right of the error that’s cut off

Again I apologize for using images, but I am unable to efficiently obtain these logs and we’re both exhausted trying to troubleshoot this.

It works fine with video-linux, but it’s not very good with nvidia. I never personally had any problems getting Manjaro to boot with nvidia, so I am completely lost. I hope someone has some patience to help me out, I can get more information if needed. Though this is a completely fresh install of Manjaro KDE Minimal x86 64

Thank you.

Once you have installed and all what does an inxi look like?

inxi -Fazy

It seems you referenced mhwd profiles, so what does it say?

mhwd -li -l

You can also use paste services. ex:

inxi -Fazy | curl -F 'file=@-' https://0x0.st

It was not clear if you were able to recover from the ‘bad’ nvidia install.
Assuming you had used mhwd for the install, you can remove it again from the tty, ex:

sudo mhwd -r pci video-nvidia
1 Like

Hi, thanks for responding. I’ve gotten the information you’ve asked for.
inxi results

  Host: aterraformer Kernel: 6.1.69-1-MANJARO arch: x86_64 bits: 64
    compiler: gcc v: 13.2.1 clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.1-x86_64
    root=UUID=66e97a48-9601-4a43-b37c-e25942609860 rw quiet splash
  Console: tty 3 DM: SDDM Distro: Manjaro Linux base: Arch Linux
  Type: Laptop Mobo: Micro-Star model: B350 TOMAHAWK (MS-7A34) v: 1.0
    serial: <superuser required> UEFI: American Megatrends v: 1.20
    date: 03/16/2017
  Info: model: AMD Ryzen 7 1700 bits: 64 type: MT MCP arch: Zen level: v3
    note: check built: 2017-19 process: GF 14nm family: 0x17 (23) model-id: 1
    stepping: 1 microcode: 0x8001105
  Topology: cpus: 1x cores: 8 tpc: 2 threads: 16 smt: enabled cache:
    L1: 768 KiB desc: d-8x32 KiB; i-8x64 KiB L2: 4 MiB desc: 8x512 KiB L3: 16 MiB
    desc: 2x8 MiB
  Speed (MHz): avg: 1546 high: 1550 min/max: 1550/3000 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1550 2: 1550
    3: 1550 4: 1550 5: 1550 6: 1550 7: 1550 8: 1550 9: 1550 10: 1550 11: 1550
    12: 1550 13: 1495 14: 1550 15: 1550 16: 1550 bogomips: 95855
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 sse4a ssse3 svm
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: mmio_stale_data status: Not affected
  Type: retbleed mitigation: untrained return thunk; SMT vulnerable
  Type: spec_rstack_overflow mitigation: safe RET, no microcode
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, STIBP: disabled, RSB filling,
    PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: NVIDIA GA106 [GeForce RTX 3060] vendor: eVga.com. driver: nvidia
    v: 470.223.02 alternate: nouveau,nvidia_drm non-free: 545.xx+ status: current
    (as of 2023-11; EOL~2026-12-xx) arch: Ampere code: GAxxx
    process: TSMC n7 (7nm) built: 2020-2023 pcie: gen: 1 speed: 2.5 GT/s
    lanes: 16 link-max: gen: 4 speed: 16 GT/s bus-ID: 23:00.0
    chip-ID: 10de:2503 class-ID: 0300
  Display: server: X.org v: driver: X: loaded: N/A unloaded: nvidia
    gpu: nvidia tty: 128x48
  API: EGL v: 1.5 platforms: device: 1 drv: swrast gbm: drv: kms_swrast
    surfaceless: drv: swrast inactive: wayland,x11,device-0
  API: OpenGL v: 4.5 vendor: mesa v: 23.1.9-manjaro1.1
    note: console (EGL sourced) renderer: llvmpipe (LLVM 16.0.6 256 bits)
  API: Vulkan Message: No Vulkan data available.
  Device-1: NVIDIA GA106 High Definition Audio vendor: eVga.com.
    driver: snd_hda_intel v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 4 speed: 16 GT/s bus-ID: 23:00.1 chip-ID: 10de:228e
    class-ID: 0403
  Device-2: AMD Family 17h HD Audio vendor: Micro-Star MSI
    driver: snd_hda_intel v: kernel pcie: gen: 3 speed: 8 GT/s lanes: 16
    bus-ID: 25:00.3 chip-ID: 1022:1457 class-ID: 0403
  Device-3: C-Media USB Advanced Audio Device
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-8:3 chip-ID: 0d8c:016c class-ID: 0300
  API: ALSA v: k6.1.69-1-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: off with: 1: pipewire-pulse status: off
    2: wireplumber status: off 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: Micro-Star MSI driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s
    lanes: 1 port: f000 bus-ID: 21:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp33s0 state: up speed: 1000 Mbps duplex: full mac: 4c:cc:6a:ff:c2:db
  Local Storage: total: 3.18 TiB used: 8.87 GiB (0.3%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: SanDisk model: SDSSDA240G
    size: 223.57 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: 172189465205 fw-rev: 30RL scheme: GPT
  ID-2: /dev/sdb maj-min: 8:16 vendor: Western Digital
    model: WD10EZEX-08WN4A0 size: 931.51 GiB block-size: physical: 4096 B
    logical: 512 B speed: 6.0 Gb/s tech: HDD rpm: 7200 serial: WD-WCC6Y5RH3SRZ
    fw-rev: 1A01 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Crucial model: CT2000MX500SSD1
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    tech: SSD serial: 2327E6EB8C0A fw-rev: 046 scheme: GPT
  ID-4: /dev/sdd maj-min: 8:48 vendor: Generic model: SD MMC size: 238.75 GiB
    block-size: physical: 512 B logical: 512 B type: USB rev: 2.0 spd: 480 Mb/s
    lanes: 1 mode: 2.0 tech: SSD serial: 058F63626476 fw-rev: 1.00 scheme: MBR
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure?
  ID-1: / raw-size: 1.82 TiB size: 1.79 TiB (98.37%) used: 8.87 GiB (0.5%)
    fs: ext4 dev: /dev/sdc2 maj-min: 8:34
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 300 KiB (0.1%) fs: vfat dev: /dev/sdc1 maj-min: 8:33
  Alert: No swap data was found.
  System Temperatures: cpu: 28.1 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 254 Uptime: 4m wakeups: 0 Memory: total: 16 GiB
  available: 15.57 GiB used: 571.9 MiB (3.6%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: pm: pacman pkgs: 1041 libs: 300 tools: pamac Shell: Bash (login)
  v: 5.2.21 running-in: tty 3 inxi: 3.3.31

mhwd results

e[1me[31m> e[mInstalled PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
    video-nvidia-470xx            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI

e[1me[31mWarning: e[mNo installed USB configs!
e[1me[31m> e[m0000:23:00.0 (0300:10de:2503) Display controller nVidia Corporation:
                  NAME               VERSION          FREEDRIVER           TYPE
          video-nvidia            2023.03.23               false            PCI
    video-nvidia-470xx            2023.03.23               false            PCI
           video-linux            2018.05.04                true            PCI
     video-modesetting            2020.01.13                true            PCI
            video-vesa            2017.03.12                true            PCI

e[1me[31m> e[m0000:21:00.0 (0200:10ec:8168) Network controller Realtek Semiconductor Co., Ltd.:
                  NAME               VERSION          FREEDRIVER           TYPE
         network-r8168            2023.09.12                true            PCI

Thank you for the paste services trick, I didn’t know you could do that. Appreciate the lesson.

sudo mhwd -r pci video-nvidia

We’ve tried reverting back to video-linux that exact way, and it works, but applications don’t work correctly using the open source drivers. Any distro we try to use proprietary nvidia drivers, just a black screen (plymouth), or it freezes around CUPS service or something like that, I know it’s not CUPS related. It’s looking like xorg is the cause.

Edit: The driver being 470 was an attempt at making it work by using an older driver, the errors are exactly the same as the 540 driver.

In this case then

sudo mhwd -r pci video-nvidia-470xx

Though of course we want to eventually be able to install the proper current one
(ex: sudo mhwd -i pci video-nvidia)

Wow, for one thing you have an extremely old BIOS
(with newer hardware)

You should definitely update that.
If my search-foo is correct

Note: It appears the MSI updates support what they call “m-flash” which means you can boot it from a USB and update that way. See the documentation at the support page (also with links to videos).

PS. This is not related to your problem, but I notice the system has no SWAP.
That means when the physical RAM as all used the system will lock up.
You have lots of options for SWAP, including a partition, swapfile, etc… but I generally suggest zram these days. ex (continuing the discussion from Awful performance since install):

1 Like

Oh wow, it was fixed entirely with a BIOS update. I feel so stupid now. Thank you so much for you help, and I’ve passed along the information about SWAP. I really appreciate it.

Dont feel that way.

Its not like we all do BIOS updates every other day.

Glad it all worked out. :slight_smile:

1 Like

This topic was automatically closed 36 hours after the last reply. New replies are no longer allowed.