StarCraft 2 on Lutris

Hello, how are you? I have tried to install StarCraft 2 on lutris since it didn’t work on Steam. Lutis says that vulkan isn’t installed or that it isn’t supported and dkxv doesn’t work. The game starts and I can hear the sound and see the cursor but there’s no video.

My laptop is an Acer, with an i5 intel processor. When I go to the terminal and write vulkaninfo the terminal says that there isn’t anything installed or that it cannot run the command, but, I installed all vulkan dependencies on the same terminal and I can see them on the software manager.

Maybe start with some system info

inxi -Fazy

A general guide on how to find information, format code, etc

Hello cscs, thank you. Here you have, this is what I got.

    ~  inxi -Fazy                                                       ✔ 
  Kernel: 6.6.8-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 13.2.1
    clocksource: tsc available: hpet,acpi_pm
    parameters: BOOT_IMAGE=/boot/vmlinuz-6.6-x86_64
    root=UUID=d5e6545e-a4b6-44c7-a2fb-a85b21d48287 rw quiet splash apparmor=1
    security=apparmor udev.log_priority=3
  Desktop: GNOME v: 45.2 tk: GTK v: 3.24.39 wm: gnome-shell dm: GDM v: 45.0.1
    Distro: Manjaro Linux base: Arch Linux
  Type: Laptop System: Acer product: Aspire 5742 v: V1.15
    serial: <superuser required>
  Mobo: Acer model: Aspire 5742 v: V1.15 serial: <superuser required>
    BIOS: Acer v: 1.15 date: 01/21/2011
  ID-1: BAT0 charge: 19.3 Wh (100.0%) condition: 19.3/47.5 Wh (40.7%)
    volts: 12.3 min: 10.8 model: SANYO Li_Ion_4000mA type: Li-ion
    serial: <filter> status: full
  Info: model: Intel Core i5 M 480 bits: 64 type: MT MCP arch: Westmere
    gen: core 1 level: v2 built: 2010-11 process: Intel 32nm family: 6
    model-id: 0x25 (37) stepping: 5 microcode: 0x7
  Topology: cpus: 1x cores: 2 tpc: 2 threads: 4 smt: enabled cache:
    L1: 128 KiB desc: d-2x32 KiB; i-2x32 KiB L2: 512 KiB desc: 2x256 KiB
    L3: 3 MiB desc: 1x3 MiB
  Speed (MHz): avg: 1325 high: 1460 min/max: 1199/2667 boost: enabled
    scaling: driver: acpi-cpufreq governor: schedutil cores: 1: 1232 2: 1279
    3: 1460 4: 1331 bogomips: 21285
  Flags: ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: gather_data_sampling status: Not affected
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
  Type: mds status: Vulnerable: Clear CPU buffers attempted, no microcode;
    SMT vulnerable
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_rstack_overflow status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: conditional, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel Core Processor Integrated Graphics
    vendor: Acer Incorporated ALI driver: i915 v: kernel arch: Gen-5.75
    process: Intel 45nm built: 2010 ports: active: HDMI-A-1,LVDS-1
    empty: DP-1,VGA-1 bus-ID: 00:02.0 chip-ID: 8086:0046 class-ID: 0300
  Device-2: Logitech Webcam C110 driver: snd-usb-audio,uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1.2:4
    chip-ID: 046d:0829 class-ID: 0102
  Device-3: Chicony 1.3M Webcam driver: uvcvideo type: USB rev: 2.0
    speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 2-1.1:3 chip-ID: 04f2:b1d8
    class-ID: 0e02
  Display: wayland server: v: with: Xwayland v: 23.2.3
    compositor: gnome-shell driver: gpu: i915 display-ID: 0
  Monitor-1: HDMI-A-1 model: Toshiba serial: <filter> built: 2020
    res: 3840x2160 dpi: 85 gamma: 1.2 size: 698x392mm (27.48x15.43")
    diag: 1321mm (52") ratio: 16:9 modes: max: 1920x1080 min: 640x480
  Monitor-2: LVDS-1 model: LG Display 0x0250 built: 2010 res: 1366x768
    dpi: 101 gamma: 1.2 size: 345x194mm (13.58x7.64") diag: 396mm (15.6")
    ratio: 16:9 modes: 1366x768
  API: EGL v: 1.5 hw: drv: intel crocus platforms: device: 0 drv: crocus
    device: 1 drv: swrast surfaceless: drv: crocus wayland: drv: crocus x11:
    drv: crocus inactive: gbm
  API: OpenGL v: 4.5 compat-v: 2.1 vendor: intel mesa v: 23.1.9-manjaro1.1
    glx-v: 1.4 direct-render: yes renderer: Mesa Intel HD Graphics (ILK)
    device-ID: 8086:0046 memory: 1.46 GiB unified: yes display-ID: :0.0
  API: Vulkan Message: No Vulkan data available.
  Device-1: Intel 5 Series/3400 Series High Definition Audio
    vendor: Acer Incorporated ALI 5 driver: snd_hda_intel v: kernel
    bus-ID: 00:1b.0 chip-ID: 8086:3b56 class-ID: 0403
  Device-2: Generalplus USB Audio Device
    driver: hid-generic,snd-usb-audio,usbhid type: USB rev: 1.1 speed: 12 Mb/s
    lanes: 1 mode: 1.1 bus-ID: 1-1.1:3 chip-ID: 1b3f:2008 class-ID: 0300
  Device-3: Logitech Webcam C110 driver: snd-usb-audio,uvcvideo type: USB
    rev: 2.0 speed: 480 Mb/s lanes: 1 mode: 2.0 bus-ID: 1-1.2:4
    chip-ID: 046d:0829 class-ID: 0102
  API: ALSA v: k6.6.8-2-MANJARO status: kernel-api with: aoss
    type: oss-emulator tools: alsactl,alsamixer,amixer
  Server-1: JACK v: 1.9.22 status: off tools: N/A
  Server-2: PipeWire v: 1.0.0 status: active with: 1: pipewire-pulse
    status: active 2: wireplumber status: active 3: pipewire-alsa type: plugin
    tools: pactl,pw-cat,pw-cli,wpctl
  Device-1: Broadcom NetLink BCM57780 Gigabit Ethernet PCIe
    vendor: Acer Incorporated ALI driver: tg3 v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 port: N/A bus-ID: 01:00.0 chip-ID: 14e4:1692
    class-ID: 0200
  IF: enp1s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Qualcomm Atheros AR9287 Wireless Network Adapter
    vendor: Foxconn T77H167.00 driver: ath9k v: kernel pcie: gen: 1
    speed: 2.5 GT/s lanes: 1 bus-ID: 02:00.0 chip-ID: 168c:002e class-ID: 0280
  IF: wlp2s0 state: down mac: <filter>
  Local Storage: total: 465.76 GiB used: 59.74 GiB (12.8%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/sda maj-min: 8:0 vendor: Western Digital
    model: WD5000BPVT-11HXZT1 size: 465.76 GiB block-size: physical: 4096 B
    logical: 512 B speed: 3.0 Gb/s tech: HDD rpm: 5400 serial: <filter>
    fw-rev: 1A01 scheme: MBR
  ID-1: / raw-size: 231.81 GiB size: 227.11 GiB (97.97%)
    used: 59.74 GiB (26.3%) fs: ext4 dev: /dev/sda5 maj-min: 8:5
  Alert: No swap data was found.
  System Temperatures: cpu: 51.0 C mobo: N/A
  Fan Speeds (rpm): N/A
  Processes: 278 Uptime: 2h 21m wakeups: 3 Memory: total: 6 GiB note: est.
  available: 5.47 GiB used: 2.56 GiB (46.8%) Init: systemd v: 254
  default: graphical tool: systemctl Compilers: gcc: 13.2.1 clang: 16.0.6
  Packages: 1586 pm: pacman pkgs: 1570 libs: 477 tools: gnome-software,pamac
  pm: rpm pkgs: 0 pm: flatpak pkgs: 16 Shell: Zsh v: 5.9
  running-in: gnome-terminal inxi: 3.3.31

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

Thank you, so we know its a somewhat old intel GPU.

Which is sorta generic, but we can tie it to the cpu

What packages for vulkan do you have?

pacman -Qs vulkan

Some asides ..

Wow, thats pretty old. I dont know if there are any available … but maybe check for a BIOS update?

You have no swap, and a somewhat small amount of memory.
I would suggest adding some form of swap, as when you hit that 6GB you will lock up.
My suggestion these days is usually zram, and I recently guided someone else with that;
Continuing the discussion from Awful performance since install:

Thank you again. This is what I got when I ran -Qs vulkan in the terminal:

local/dxvk-gplasync-bin 2.3-1
    A Vulkan-based compatibility layer for Direct3D 9/10/11 (with gplasync patches)
local/lib32-vkd3d 1.9-1
    Direct3D 12 to Vulkan translation library By WineHQ
local/lib32-vulkan-icd-loader 1.3.274-1
    Vulkan Installable Client Driver (ICD) Loader (32-bit)
local/lib32-vulkan-intel 1:23.1.9-1
    Intel's Vulkan mesa driver (32-bit)
local/lib32-vulkan-radeon 1:23.1.9-1
    Radeon's Vulkan mesa driver (32-bit)
local/spirv-tools 2023.5-1 (vulkan-devel)
    API and commands for processing SPIR-V modules
local/vulkan-extra-layers (vulkan-devel)
    Extra layers for Vulkan development
local/vulkan-headers 1:1.3.274-1 (vulkan-devel)
    Vulkan header files
local/vulkan-icd-loader 1.3.274-1
    Vulkan Installable Client Driver (ICD) Loader
local/vulkan-intel 1:23.1.9-1
    Intel's Vulkan mesa driver
local/vulkan-mesa-layers 1:23.1.9-1
    Mesa's Vulkan layers
local/vulkan-radeon 1:23.1.9-1
    Radeon's Vulkan mesa driver
local/vulkan-tools 1.3.269-1 (vulkan-devel)
    Vulkan Utilities and Tools
local/vulkan-validation-layers (vulkan-devel)
    Vulkan Validation Layers

As for the other aspects you mention, I will follow the instruction tomorrow and will get back to you.

I tried to comment a file inside the terminal but when I finished I couldn’t save it, and I feel pretty dumb. There are some commands below like this one: ^0, or ^M-E, but, nothing happened when I tried. I will just go over it again to see if I manage to do something.

Moderator edit: In the future, please use proper formatting: [HowTo] Post command output and file content as formatted text

I forgot to mention, my Bios is legacy Bios, not UEFI. I have absolute no idea on how to update the BIOS, I don’t want to brake my machine T.T. But any advice is highly appreciated.

This GPU has no support for Vulkan, only OpenGL and DirectX. And even OpenGL only version 2.1. No chance to run any modern Game on it with Linux. On Windows it supports up to DirectX 10.1.

Must be this one since Gen5.75:

Thank you very much megavolt.