Audio stops working after one application uses it

This is pretty much identical to this post, # Playback and video not working, But the posted solution doesn’t work; I already had manjaro-pipewire installed to begin with. Removing and reinstalling it didn’t do anything either.

Specifically, after restarting my computer, the first application I launch generally is able to play audio ok. The second I open anything else, no audio is output and YouTube reports the “If playback doesn’t begin shortly, try restarting your device” and Spotify gives back the “Can’t Play this Song Right Now”. Restarting the pipewire-pulse service via systemctl restart --user pipewire-pulse.service will fix it for a few minutes, but then it fails again.

The one thing I have noticed is that the inxi -Fayz output has PulseAudio not running:

❯ inxi -Fayz                                     
  Kernel: 5.14.21-2-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 11.1.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.14-x86_64
    root=UUID=cec2d4e0-d852-4f58-a084-9d86bcb73abe rw apparmor=1
    security=apparmor udev.log_priority=3 apparmor=1 security=apparmor
    resume_offset=40210432 mem_sleep_default=deep
  Desktop: Qtile v: 0.21.0 vt: 7 dm: LightDM v: 1.30.0 Distro: Manjaro Linux
    base: Arch Linux
  Type: Laptop System: Framework product: Laptop v: A3
    serial: <superuser required>
  Mobo: Framework model: FRANBMCP03 v: A3 serial: <superuser required>
    UEFI: INSYDE v: 03.02 date: 07/01/2021
  ID-1: BAT1 charge: 54.0 Wh (100.0%) condition: 54.0/55.0 Wh (98.2%)
    volts: 17.6 min: 15.4 model: NVT Framewo type: Li-ion serial: <filter>
    status: discharging
  Info: model: 11th Gen Intel Core i5-1135G7 bits: 64 type: MT MCP
    arch: Tiger Lake built: 2020 process: Intel 10nm family: 6
    model-id: 0x8C (140) stepping: 1 microcode: 0x86
  Topology: cpus: 1x cores: 4 tpc: 2 threads: 8 smt: enabled cache:
    L1: 320 KiB desc: d-4x48 KiB; i-4x32 KiB L2: 5 MiB desc: 4x1.2 MiB L3: 8 MiB
    desc: 1x8 MiB
  Speed (MHz): avg: 2211 high: 3774 min/max: 400/4200 scaling:
    driver: intel_pstate governor: powersave cores: 1: 733 2: 449 3: 3774
    4: 1117 5: 1676 6: 3499 7: 2773 8: 3669 bogomips: 38720
  Flags: avx avx2 ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Type: itlb_multihit status: Not affected
  Type: l1tf status: Not affected
  Type: mds status: Not affected
  Type: meltdown status: Not affected
  Type: spec_store_bypass
    mitigation: Speculative Store Bypass disabled via prctl and seccomp
  Type: spectre_v1
    mitigation: usercopy/swapgs barriers and __user pointer sanitization
  Type: spectre_v2 mitigation: Enhanced IBRS, IBPB: conditional, RSB filling
  Type: srbds status: Not affected
  Type: tsx_async_abort status: Not affected
  Device-1: Intel TigerLake-LP GT2 [Iris Xe Graphics] driver: i915 v: kernel
    arch: Gen12.1 process: Intel 10nm built: 2020-21 ports: active: DP-5,eDP-1
    empty: DP-1, DP-2, DP-3, DP-4, DP-6, DP-7 bus-ID: 00:02.0
    chip-ID: 8086:9a49 class-ID: 0300
  Device-2: Realtek Laptop Camera type: USB driver: uvcvideo bus-ID: 3-7:4
    chip-ID: 0bda:5634 class-ID: 0e02 serial: <filter>
  Display: x11 server: X.Org v: 21.1.4 with: Xwayland v: 22.1.3 compositors:
    1: Qtile v: 0.21.0 2: Picom v: git-7e568 driver: X: loaded: modesetting
    alternate: fbdev,vesa gpu: i915 display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1280 s-dpi: 97 s-size: 1010x337mm (39.76x13.27")
    s-diag: 1065mm (41.92")
  Monitor-1: DP-5 mapped: DP-4-1 pos: primary,bottom-l
    model: Samsung S24E310 serial: <filter> built: 2016 res: 1920x1080 hz: 60
    dpi: 94 gamma: 1.2 size: 521x293mm (20.51x11.54") diag: 598mm (23.5")
    ratio: 16:9 modes: max: 1920x1080 min: 720x400
  Monitor-2: eDP-1 pos: top-right model: BOE Display 0x095f built: 2019
    res: 1920x1280 hz: 60 dpi: 171 gamma: 1.2 size: 285x190mm (11.22x7.48")
    diag: 343mm (13.5") ratio: 3:2 modes: 2256x1504
  Message: Unable to show GL data. Required tool glxinfo missing.
  Device-1: Intel Tiger Lake-LP Smart Sound Audio driver: snd_hda_intel
    v: kernel bus-ID: 3-6.2.3:9 alternate: snd_sof_pci_intel_tgl bus-ID: 00:1f.3
    chip-ID: 08bb:2902 class-ID: 0300 chip-ID: 8086:a0c8 class-ID: 0403
  Device-2: Texas Instruments PCM2902 Audio Codec type: USB
    driver: hid-generic,snd-usb-audio,usbhid
  Device-3: Lenovo ThinkPad USB-C Dock Gen2 USB Audio type: USB
    driver: hid-generic,snd-usb-audio,usbhid bus-ID: 3-
    chip-ID: 17ef:a396 class-ID: 0300 serial: <filter>
  Sound Server-1: ALSA v: k5.14.21-2-MANJARO running: yes
  Sound Server-2: PulseAudio v: 16.1 running: no
  Sound Server-3: PipeWire v: 0.3.56 running: yes
  Device-1: Intel Wi-Fi 6 AX210/AX211/AX411 160MHz driver: iwlwifi v: kernel
    pcie: gen: 2 speed: 5 GT/s lanes: 1 bus-ID: aa:00.0 chip-ID: 8086:2725
    class-ID: 0280
  IF: wlp170s0 state: up mac: <filter>
  Device-2: Lenovo USB-C Dock Ethernet type: USB driver: r8152
    bus-ID: 2-4.1:9 chip-ID: 17ef:a387 class-ID: 0000 serial: <filter>
  IF: enp0s13f0u4u1 state: down mac: <filter>
  Device-1: Intel AX210 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 3-10:7 chip-ID: 8087:0032 class-ID: e001
  Report: hciconfig ID: hci0 rfk-id: 1 state: down
    bt-service: enabled,running rfk-block: hardware: no software: no
    address: <filter>
  Info: acl-mtu: 0:0 sco-mtu: 0:0
  Local Storage: total: 931.51 GiB used: 212.92 GiB (22.9%)
  SMART Message: Required tool smartctl not installed. Check --recommends
  ID-1: /dev/nvme0n1 maj-min: 259:0 vendor: Samsung model: SSD 980 1TB
    size: 931.51 GiB block-size: physical: 512 B logical: 512 B speed: 31.6 Gb/s
    lanes: 4 type: SSD serial: <filter> rev: 1B4QFXO7 temp: 39.9 C scheme: GPT
  ID-1: / raw-size: 931.22 GiB size: 915.53 GiB (98.32%)
    used: 212.91 GiB (23.3%) fs: ext4 dev: /dev/nvme0n1p2 maj-min: 259:2
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 304 KiB (0.1%) fs: vfat dev: /dev/nvme0n1p1 maj-min: 259:1
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default)
  ID-1: swap-1 type: file size: 32 GiB used: 0 KiB (0.0%) priority: -2
    file: /swapfile
  System Temperatures: cpu: 42.0 C mobo: N/A
  Fan Speeds (RPM): N/A
  Processes: 255 Uptime: 12m wakeups: 1 Memory: 31.15 GiB
  used: 4.5 GiB (14.5%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.1.0 clang: 14.0.6 Packages: 1700
  pacman: 1691 lib: 397 flatpak: 9 Shell: Zsh v: 5.9
  running-in: xfce4-terminal inxi: 3.3.19

I don’t have a way to start it that I know of, as the pulseaudio command isn’t available. I naively attempted to yay -S pulseaudio, but it’s saying that pipewire-pulse is in conflict with that.

That kernel is long since EOL …

That looks fine, but i3wm configuration you have might forgotten about this part:

exec --no-startup-id volumeicon
bindsym $mod+Ctrl+m exec terminal -e 'alsamixer'
exec --no-startup-id pulseaudio
exec --no-startup-id pa-applet

In principle, i3wm will go directly via alsa, but if you want to use pulse or pipewire you just have to have it enabled
systemctl --user enable pipewire-pulse.servic
And you do have that already. When you restart it, works for a bit but then fails because elsewhere you have conflicting config.

So you would comment the pulse part, or delete those lines

exec --no-startup-id volumeicon
bindsym $mod+Ctrl+m exec terminal -e 'alsamixer'
#exec --no-startup-id pulseaudio
#exec --no-startup-id pa-applet

You can also install manjaro-pipewire to make sure …

1 Like

Yeah, I know. I tried moving to the latest recommended kernel awhile back and my wifi card stopped working. I went on a deep dive and concluded that moving to the older version was the best option. Unfortunately I don’t remember what exactly got me to that conclusion though (I should take notes…). I’ll give it another shot though; maybe it’ll be fine??

So I’m actually using qtile as my WM; I tagged i3 as that is the base-Manjaro installation I started with. But I did copy over most of the exec --no-startup-ids to my script for qtile, so your recommendations still help. I actually had start-pulseaudio-x11 as my startup command rather than pulseaudio.

I also copied out pa-applet, but that shouldn’t be an issue, right? It’s just an applet after all… Is there a different one I should be using instead?

Commenting out those startup commands, so far it seems to be working fine, but I’ll check back in a few days to verify. Thanks!

Re: Old Kernel

Sure enough, I switched over to 5.15.55-1 and my wifi card isn’t detected. I’ve got a couple of important things to do today, so that’ll unfortunately have to be a problem for another time. I might make a new post about when/if I get back around to it.

According to Framework (maker of my laptop), there were a bunch reported issues with the linux driver for the AX210 WiFi module that are fixed in the 5.17 kernel. But that’s not supported. Also pretty sure I previous tried more updated kernels and ran into different networking issues… but we’re relying on human memory, so who knows if that’s actually correct.

Just an update, I still run into this issue, but it happens less often at least.

Re: Re: Old Kernel

Found the thread I created to document the previous issue: Intel WiFi6 AX210 fails to load on kernel 5.15, but fine on 5.14

Adding here for posterity’s sake (and mine for finding it again in the future).