[ARM Stable Update] 2022-07-10 - QT5, Pulseaudio, Plasma 5.25, Plasma Mobile Gear and Kernels

Hello ARM community.

First update after our 22.06 release!

Plasma 5.25 is here!

Some highlights:

  • Most of our kernels got updated
  • Firefox updated to 102.0.1
  • Thunderbird updated to 91.11.0
  • QT5 updated to 5.15.5
  • KDE Plasma updated to 5.25.2
  • Plasma Mobile Gear updated to 22.06
  • Gnome updated to 42.3
  • Megapixels updated to 1.5.2
  • Element Desktop updated to 1.11.0
  • Added Mattermost Desktopo to repository
  • Lots of updated packages for our Mobile offerings
  • The regular Python updates
  • And regular updates from upstream

How to get Waydroid working

If you follow these steps, you should have Waydroid working fine.

Remember, Waydroid only works on wayland!

  • Install waydroid-image and all it’s dependencies.
  • Run pkexec setup-waydroid.
  • You should now be able to launch Waydroid. The first launch takes a while.
How to use Kodi RPI on Manjaro ARM

If anyone wants to test kodi on the rpi, install these packages:

sudo pacman -S kodi-rpi kodi-rpi-dev kodi-rpi-eventclients kodi-rpi-tools-texturepacker libcec-rpi linux-rpi4 xf86-video-fbdev

Have it set up is to boot straight in to kodi

This means the kodi.service file need to replace whatever login manager you have installed. In my case I would:

sudo systemctl disable lightdm.service
sudo systemctl enable kodi.service

They recommend removing custom configs in config.txt. We ran into an issue if a value was set with gpu_mem=.

My config.txt with a bit of overclocking:

#gpu_mem=64     #disable this
initramfs initramfs-linux.img followkernel

#enable sound

#enable vc4
#max_framebuffers=2    #disable cause kodi uses more

Some notes:

The default user will be kodi
kodi home directory will be /var/lib/kodi
So put test video in /var/lib/kodi/Videos so you can get to it
after setting up the video directory in kodi.

Upstream Notifications:

Older notifications

If you used the Manjaro ARM Installer or is using PinePhone or PineTab, you need to redo your passwords, because of an update to libxcrypt:
Arch Linux - News: Sorting out old password hashes

Chromium will loose sync support in early March:
Arch Linux - News: Chromium losing Sync support in early March

ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention:
Arch Linux - News: ghostpcl>=9.53.2-2 and ghostxps>=9.53.2-2 updates require manual intervention

The nss and zn_poly packages requires manual intervention:
Arch Linux - News: nss>=3.51.1-1 and lib32-nss>=3.51.1-1 updates require manual intervention
Arch Linux - News: zn_poly 0.9.2-2 update requires manual intervention

The packages hplip and firewalld requires manual intervention:
Arch Linux - News: hplip 3.20.3-2 update requires manual intervention
Arch Linux - News: firewalld>=0.8.1-2 update requires manual intervention

Package changes:

(Sun Jul 10 18:57:09 CEST 2022)

  • arm-stable community aarch64: 788 new and 760 removed package(s)
  • arm-stable core aarch64: 60 new and 60 removed package(s)
  • arm-stable extra aarch64: 577 new and 670 removed package(s)
  • arm-stable kde-unstable aarch64: 394 new and 393 removed package(s)

See the full package list here

Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #manjaro-arm:arm-testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!


Please consider supporting Manjaro ARM directly via Patreon, Ko-Fi or Open Collective.
You can also donate to our upstream, which is Arch Linux ARM.


  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself. (Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

1 Like

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

Mouse cursor is slow on Raspberry Pi

Due to a change in the Raspberry Pi kernels upstream, they no longer support FKMS. This can result in slow performance when using the FKMS drivers with the newer Raspberry Pi kernels.
Solution: Open /boot/config.txt, change fkms to kms in the dtoverlay line. Save the file and reboot.

Waydroid container cannot access internet

Cause: new default waydroid configuration issue, tracked here.

Short-term Solution:

  1. create /etc/nftables.d/waydroid.nft with the following contents:
#!/usr/sbin/nft -f
table inet filter {
    chain input {
        iifname "waydroid0" accept comment "Allow incoming network traffic from WayDroid"
    chain forward {
        iifname "waydroid0" accept comment "Allow outgoing network traffic from WayDroid"
        ct state {established, related} counter accept comment "accept established connections"
  1. any time you launch waydroid, run the following after it has started:
echo "ip route add default via" |sudo waydroid shell
Old Issues
Plasma Dialer cannot answer calls

Sadly Plasma Dialer 22.02 has a serious regression with no known workaround. It’s not possible to accept incoming calls. Very sorry about this. Follow the upstream bug report. We will patch the package as soon as a solution is found.

Plasma Mobile - Black screen after update

We are seeing some reports about Plasma Mobile on the PinePhone only showing a black screen after entering the PIN after this update.
Workaround: Downgrade qt5-es2-wayland to 5.15.2+kde+r41 which is now back in Stable and Testing branch repositories.

New Breath theme not applying correctly

With the update to the new Breath theme, a migration package tries to apply the new theme correctly.
However this is not getting done for Plasma’s Lockscreen and the SDDM theme.
So please go through your settings after updating to make sure the themes are correctly applied.
Fix: manjaro-system should take care of this for you.

Plasma Mobile switch to ModemManager

With the PlaMo Gear 21.12 release, Plasma Mobile is now using ModemManager as the telephony stack. So in order to use SIM capabilities, you need to switch from using oFono to ModemManager.
Fix: Run sudo systemctl disable --now ofono ofonoctl && sudo systemctl enable --now ModemManager. You might have to reboot your phone for Plasma Mobile to pick up this change.

Plasma Mobile has does not launch after update
This was caused by an error in kwin 5.23.2 which only affects installs based on openGLES (qt5-es2).
Fix: Update to kwin 5.23.2-1.2 or above.

No ethernet on rk3399 boards
A recent kernel regression has resulted in built in ethernet on rk3399 based boards, such as RockPro64 and Rock Pi 4’s, no longer works on kernel 5.14. This is an upstream issue that has not been fixed yet.
Fix: Update to linux-5.14.1-2 or newer.

Vivaldi no longer working
The issue is present in all chrome based browser (except Chromium that got a patch for it).
It’s an issue with systemd-resolved and has been reported in the Arch Linux Bug Tracker.
Needs to be fixed by Vivaldi updates in the future.
Fix: Vivaldi 4.1.2369.21 fixed this issue.

Modemmanager-pp dependency issue
modemmanager-pp 1.16.10 depends on libqmi-pp and libmbim-pp, but they are no longer found in the repo.
Fixed by updated to modemmanager-pp 1.18rc1+2+ga20f2c05-2.

systemd-hook unsuccesful after pacman 6 update
After the pacman 6 update, updates will create this message in the post-transation hooks part:

Running the command manually works and there has been no issues reported as the result of this. This will either get fixed at some point in Pacman or SystemD.
Should be fixed with pacman-6.0.0-4

Keyring issues
If you have some gpg keyring issues, you can run sudo systemctl start pacman-init.service which will regenerate your keyring. Will take a few minutes to complete.
Should be fixed with manjaro-system-20210716-1

Plasma Mobile no longer boots
The current update to qt5-es2-base results in Plasma Mobile no longer booting, showing a screen that says to run a loginctl command to login.
Fixed by updating to qt5-es2-base-5.15.2+kde+r199-3.1 and qt5-es2-declarative-5.15.2+kde+r28-3.1.

Kwin crashes on startup on Pinebook Pro
This seems to be related to Mesa 20.3 and the Pinebook Pro support in kernel 5.10, as this does not seem to happen on other devices.
It does not impact 3d performance as far as I can tell. Just the OpenGL compositing in Kwin.
Fixed with mesa 20.3.2-2.

My VPN no longer connects
OpenVPN 2.5.0 changed how VPN routes work.
Workaround is to downgrade to previous version (2.4.9):

sudo pacman -U /var/cache/pacman/pkg/openvpn-2.4.9*

DP Alt Mode no longer works on Pinebook Pro
This is a known issue, the hacky patch we had to enable this has broken in recent kernels.
@tsys and Ayufan are looking into it.
As a workaround you can install linux-pinebookpro again.
FIXED with linux-5.9.12-4 and linux-rc-5.10-rc7-2 and above.

brcm-patchram-plus and pi-blueooth are in conflict
See this post for workaround:
[ARM Testing Update] 2020-11-16 - Bitwarden, Mesa-Git, Pacman and kernels - #10 by Darksky

Plasma Mobile Keyboard
The plasma mobile onscreen keyboard does not work with QT 5.15.0.
This is fixed by updating to kwin 5.19.3-1.1.

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

Chosen mirror on the list says it’s updated (United States), but Add/Remove Software states that the system is up to date with no updates. Refreshing manually doesn’t change anything.

I’m running on an RPI4 with the MATE desktop. The system was fully up-to-date till this morning.

I started the update, but got the following warning message:

unable to lock database
failed to synchronize dadabases

I cancelled the update. How can I resolve thiis issue?

I run Manjaro-ARM XFCE on a Raspberry Pi 400 from an SSD when I started to run the current update the following popped up on the screen:

The download and installation went just fine, even got the restart popup, and it restarted just fine. What does this mean and am I going to have any issues because of this?

Question 2: Ever since I did the mouse fix, I have lost the Manjaro loading splash screen. Is there any way to get that back and keep the fix?

I found the solution here:
Deleted db.lck in /var/tmp/pamac/dbs/
Everything ran as expected, without the warining, and no problems with the updated system.

Thank you for the fix. Glad to hear your update went as expected.

GT King Pro updated successfully to Arm-Stable-2022-0710. Gnome-linux-khadas-5.18.5-1.

On Gnome Wayland Session. The mouse movement is jerky or momentarily freezes whenever the mouse cursor/pointer crosses a Window Border.

This mouse movement aslo affect Firefox or Chromium streaming youtube video, whenever the mouse cursor/pointer move a cross a Window Border the video will momentarily freezes/jerk.

On Manjaro-Arm-KDE Plasma 5.25.2 Edition (Unstable Branch) with linux-khadas-5.18.5-1 kernel Wayland session does NOT have this issue.

It seems to only affect Gnome Wayland session and not on Gnome-Xorg session.

1 Like

Maybe it’s xwayland related. Does it happen on pure wayland applications too?

ibus-setup doesn’t start at startup.

Is Gnome-Terminal pure Wayland application?

On other distros on Gnome Wayland (example Fedora 36 Workstation Gnome) have the same issue with kernels 5.18.1 to 5.18.6. With kernel 5.18.9 NO more such momentarily freeze whenever the mouse cursor/pointer move across a Window Border. Basically it is related to early upstream kernel 5.18.y but seems to be resolved with kernel 5.18.9.

I install kernel linux-5.18.9-1 (from Stable Branch) on Manjaro-Arm-Gnome. The install went smoothly with NO errors.

Date: 2022-07-11 Time: 21:10
Install linux-5.18.9-1 to resolve the momentarily freeze of mouse cursor or jerky movement whenever the mouse cursor/pointer crosses a Window Border. On Gnome Wayland only.  Does NOT affect KDE Plasma Wayland or Gnome-Xorg Sessions.

 jflim@jflim-gtkpro    sudo pacman -S linux
[sudo] password for jflim: 
resolving dependencies...
looking for conflicting packages...
:: linux and linux-khadas are in conflict (kernel26). Remove linux-khadas? [y/N] y

Packages (2) linux-khadas-5.18.5-1 [removal]  linux-5.18.9-1

Total Download Size:   53.94 MiB
Total Installed Size:  80.66 MiB
Net Upgrade Size:       7.24 MiB

:: Proceed with installation? [Y/n] Y
:: Retrieving packages...
 linux-5.18.9-1-a...    53.9 MiB  1683 KiB/s 00:33 [######################] 100%
(1/1) checking keys in keyring                     [######################] 100%
(1/1) checking package integrity                   [######################] 100%
(1/1) loading package files                        [######################] 100%
(1/1) checking for file conflicts                  [######################] 100%
(2/2) checking available disk space                [######################] 100%
:: Processing package changes...
(1/1) removing linux-khadas                        [######################] 100%
(1/1) installing linux                             [######################] 100%
Optional dependencies for linux
    crda: to set the correct wireless channels of your country [installed]
:: Running post-transaction hooks...
(1/6) Arming ConditionNeedsUpdate...
(2/6) Updating module dependencies...
(3/6) Updating linux module dependencies...
(4/6) Updating linux initcpios...
==> Building image from preset: /etc/mkinitcpio.d/linux.preset: 'default'
  -> -k 5.18.9-1-MANJARO-ARM -c /etc/mkinitcpio.conf -g /boot/initramfs-linux.img
==> Starting build: 5.18.9-1-MANJARO-ARM
  -> Running build hook: [base]
  -> Running build hook: [udev]
  -> Running build hook: [plymouth]
  -> Running build hook: [autodetect]
  -> Running build hook: [modconf]
  -> Running build hook: [block]
  -> Running build hook: [filesystems]
  -> Running build hook: [keyboard]
  -> Running build hook: [fsck]
==> Generating module dependencies
==> Creating gzip-compressed initcpio image: /boot/initramfs-linux.img
==> Image generation successful
(5/6) Updating uInitrd...
Image Name:   uInitrd Image
Created:      Mon Jul 11 21:02:32 2022
Image Type:   AArch64 Linux RAMDisk Image (uncompressed)
Data Size:    8378347 Bytes = 8181.98 KiB = 7.99 MiB
Load Address: 00000000
Entry Point:  00000000
(6/6) Updating uImage...
Image Name:   uImage
Created:      Mon Jul 11 21:02:38 2022
Image Type:   AArch64 Linux Kernel Image (uncompressed)
Data Size:    24390144 Bytes = 23818.50 KiB = 23.26 MiB
Load Address: 01080000
Entry Point:  01080000
 jflim@jflim-gtkpro   

But with the newly installed linux-5.18.9-1, Manjaro-Arm-Gnome NO Longer Boot Up. Cannot find or mount rootfs PARTUUID=f46886d7-02.

Had same issue the last time I tried to install kernel linux from Unstable Branch. This time it if from same Stable Branch.

Does this mean I can NO longer switch kernel from linux-khadas to linux?

Yeah, so it’s not xwayland related.

The GT King Pro is using the linux-khadas kernel for a reason. Likely because there’s not proper mainline support for it yet. Maybe linux-khadas can be updated to 5.18.9+ too soon, @spikerguy will know.

So the issue seems to be an upstream kernel issue, which could likely be fixed with kernel 5.18.9 and above.

I assume it no longer boots, because the the main kernel (linux) is missing some device specific stuff.

Until it gets investigated and fixed, yes.

1 Like

For your information, last year I had been using linux 5.14.y, 5.15.y before. No issue then. If not mistaken @spikerguy tested it on Unstable Branch and he had no issue with linux kernel on GT King Pro.

Thank you for your support.

It is fully supported but due to some config changes its not booting on linux

We’re looking into it.

1 Like

Since the last updates, I got the error that there were unmet dependencies.

could not satisfy dependencies:

  • unable to satisfy dependency ‘edk2-ovmf’ required by qemu-system-x86
  • unable to satisfy dependency ‘seabios’ required by qemu-system-x86
  • unable to satisfy dependency ‘qemu-system-x86’ required by qemu-desktop
  • unable to satisfy dependency ‘edk2-armvirt’ required by qemu-system-aarch64
  • unable to satisfy dependency ‘qemu-system-aarch64’ required by qemu-emulators-full

As a last resort I removed qemu, libvirt and vmm.
As I went through my notes to install it again, I see I installed the package qemu, which seems to be gone now. That would explain the dependencies error.

Total CPU usage plasmoid remains unusable on RPI4 here.

Hi @spikerguy,

Your new linux-5.18.10-2 resolved the issue. I can now boot up with linux-5.18.10-2 and also it resolved the momentarily freeze whenever the mouse cursor/pointer moves across Window Border on Gnome Wayland.

Thank you for your great support. Look forward to the release of linux-khadas-5.18.10.


Running Xfce4 on Raspberry Pi 400, was using FKMS video driver before the 22.06 update, but got the well known very bad mouse lag and had to switch over to KMS.

After that HDMI display sleep is not working.

With DPMS enabled, any screensaver/power management sleep mode makes the display go blank, lose video signal and eventually go to sleep. Immediately when the display would go to sleep, the video driver wakes up again. Seems like there is some new input event that triggers a wakeup when the display goes to sleep.

There is no observable difference between forcing different sleep modes with
xset dpms force (standby|suspend|off)

With DPMS disabled, sleep modes just blanks display with backlight on, as expected, because no DPMS signalling is asking it to power down.

Going back to the FKMS driver, DPMS sleep works as expected, but that’s not really an option given the severe performance issues.

On PinePhone I had to downgrade chatty to version 0.6.6-1 as when I received an SMS the chatty crashed and didn’t start anymore. Found existing issues:

EDIT: and issue seems to be fixed in the package version 0.6.7-2 which is now available in the repository.