[ARM Stable Update] 2020-12-30 - Python 3.9 rebuilds, Kernels, Firefox, Mesa 20.2.6, KDE Apps, Gstreamer, KDE Frameworks, LibreOffice, Thunderbird, Pamac

Hello ARM community. A new stable update is here

US Merch Shop will launch in January! Stay tuned

Some Highlights

  • Most of the Kernels got updated to 5.10.x series.
  • Systemd is now at 247.2
  • More Mobile updates
  • We updated Pamac to 10.0.2
  • Regular upstream updates
  • Most of the Kernels got updated.
  • Mesa is now at 20.2.6
  • Qt6 got added to our repos.
  • Boost update might break some packages
  • KDE Apps are now at their December Release
  • KDE Frameworks got updated to 5.77.0
  • Libreoffice is now at 7.0.4
  • Thunderbird 78 is now added
  • More Cinnamon and Deepin updates
  • Gstreamer got updated
  • Haskell and other regular upstream updates
  • More Mobile and KDE-git updates

Upstream Notifications:

Older notifications

The ghostpcl and ghostxps requires manual intervention (if you have these installed):

The nss package requires manual intervention:

The packages hplip and firewalld requires manual intervention:

Package Changes

(Tue Dec 22 07:38:52 CET 2020)

  • arm-stable community aarch64: 2588 new and 2575 removed package(s)
  • arm-stable core aarch64: 65 new and 63 removed package(s)
  • arm-stable extra aarch64: 1106 new and 1024 removed package(s)
  • arm-stable mobile aarch64: 168 new and 168 removed package(s)

A list of all package changes can be found here.

Testers needed on arm-testing branch

We are in need of testers for our arm-testing and arm-unstable branches.
So if you are adventurous and want newer software quicker, we would love for you to help us test out the new packages in arm-testing branch.

All you have to do to switch to this branch is:

  • Run this command to switch branch: sudo pacman-mirrors -aS testing && sudo pacman -Syyu. This will generate a new mirrorlist for you, sync your databases with the new mirror and update your system using the arm-testing branch.

We would then love for you to give feedback in our update posts in #arm:testing-updates. That way we can better find and fix bugs, before they hit arm-stable branch. Thank you!

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Known Issues and Solutions

This is a wiki post, please edit it when you find a solution to an issue you encountered

Old Issues

My VPN no longer connects
OpenVPN 2.5.0 changed how VPN routes work.
Workaround is to downgrade to previous version (2.4.9):

sudo pacman -U /var/cache/pacman/pkg/openvpn-2.4.9*

DP Alt Mode no longer works on Pinebook Pro
This is a known issue, the hacky patch we had to enable this has broken in recent kernels.
@tsys and Ayufan are looking into it.
As a workaround you can install linux-pinebookpro again.
FIXED with linux-5.9.12-4 and linux-rc-5.10-rc7-2 and above.

brcm-patchram-plus and pi-blueooth are in conflict
See this post for workaround:
[ARM Testing Update] 2020-11-16 - Bitwarden, Mesa-Git, Pacman and kernels

Plasma Mobile Keyboard
The plasma mobile onscreen keyboard does not work with QT 5.15.0.
This is fixed by updating to kwin 5.19.3-1.1.

PinePhone uboot
This update to the PinePhone Uboot package (2020.04-2), changed how the DTS is loaded from the kernel, since the Kernel DTS for the Pinephone also changed. When doing this update on the PinePhone images from Alpha5 and back, please make this change to the /boot/extlinux/extlinux.conf before rebooting:

  • sun50i-a64-pinephone.dtb to sun50i-a64-pinephone-1.2.dtb

Manual interventions:
The nss and zn_poly packages prior to version 3.51.1-1 and version 0.9.2-2 respectively, were missing a soname link each. This has been fixed in 3.51.1-1 and 0.9.2-2 of these packages, so the upgrade will need to overwrite the untracked files created by ldconfig. If you get any of these errors

nss: /usr/lib/p11-kit-trust.so exists in filesystem
zn_poly: /usr/lib/libzn_poly-0.9.so  exists in filesystem

when updating, use

pacman -Syu --overwrite /usr/lib/p11-kit-trust.so --overwrite /usr/lib/libzn_poly-0.9.so

to perform the upgrade.

Device stopped booting after Uboot update
The uboot update included a change to the extlinux.conf file. This change will be incompatible with the old 1 partition layout of some devices.
So if you are updating installs made with images 20.02.1 or older, you need to apply this fix before rebooting!
To fix this please edit your /boot/extlinux/extlinux.conf file and add 2 periods in front of each first slash, like so:

KERNEL ../Image
FDT ../dtbs/ #etc.
APPEND initrd=../initramfs-linux.img #etc.

Save the file and reboot.

Cool, I’m there–just updated to testing. Is the poll under this announcement in regard to the stable update or folks who upgrade to testing to help?

It’s regarding the stable update.

1 Like

Successfully updated Manjaro-ARM-VIM3-XFCE-Linux-Vim-5.10.1-1 on Beelink GT King Pro to latest Stable-2020-12-30 with linux-vim-5.10.1-1 and new u-boot.ext (boot-vim3-2020-10-1). With this new u-boot.ext GT King Pro kernel panic on mainline kernel seems to have been resolved.

Thank you Manjaro Team and Spikerguy. Wish you all A Happy New Year.

Edit: After the latest update, Sound do not work anymore.
Edit2: Resolved. Restore Sound by editing “g12_sound.sh” to revert to OLD CONF (suggested by Spikerguy).


Odroid n2 and c2 Kde up to date, it run.

Sound issue on my laptop… solved by downgrading to the 5.9 kernel

So I have run the update (stable). The OS no longer had any access to the sim card/mobile network. The menu was removed from settings. This was resolved via the simple expedient; restarting the phone several times.

Updated my Pinebook Pro successfully, and also changed to new kernel 5.10. USB-C charging is working, but looks like display out is broken again.

Not sure yet if I will stay like this for some time (and wait for a fix on 5.10), or switch back to Linux-PinebookPro (5.7)…

Otherwise a very huge update. Thanks a lot to the team for keeping the ball rolling…:wink:

Have a great New Year!!

In my case USB-C charging isn’t working properly and display out works exactly like on 5.7 kernel. Also combining charging and display out is nearly impossible, due charging problems. USB-C charging alone sometimes works, sometimes don’t. Power operation mode is either 3.0A instead of usb_power_delivery or turns on and off repeatedly. With display out charging is always on and off repeatedly plus the lcd display is going from dark to bright with the charging. I’m using BSP U-boot, if it counts. I’m going back to 5.7 kernel for now.
But otherwise this update is great, keep the good work!

Happy New Year!

Yes, you are right. After leaving the PBPPro in idle for some time I noticed that battery is draining even though it’s in the USB-C dock…

So I reverted to kernel 5.7 as well. Looks like that’s still the most stable option for now.

1 Like

Hey there,
I just updated to 5.10 and when open the terminal it shows this:

Traceback (most recent call last):
  File "/home/ali/.local/bin/powerline-shell", line 5, in <module>
    from powerline_shell import main
ModuleNotFoundError: No module named 'powerline_shell'


powerline_shell is an AUR package. Please rebuild it after you update.

1 Like

Thank you, it worked

Freecad need to be rebuilt after this update. It is built against libboost 1.7.4 but libboost has been upgraded to 1.7.5 so freecad doesn’t work any more.
Also, arduino and cura dosen’t work on aarch64. Arduino runs into a null pointer error and there’s not a “next step” button on cura’s welcome page so basic configuration cannnot be done.

python has been upgraded so you have to reinstall the modules you have installed via pip

FreeCAD is a package we get from Arch Linux ARM, seems they rebuilt it to late to get into this update.

This sounds like upstream issues.

Hello, I just updated Manjaro Xfce on my Raspberry Pi 4B and found out the new update takes up a lot of memory and very laggy. I jumped back from KDE to Xfce because I thought it is much lightweight.

Here’s the output of free -h while watching YouTube videos.

LightDM failing to start on boot after latest update.


EDIT: Nevermind. I was plugged into the wrong HDMI port, and apparently the latest update decided to finally complain about that.

I applied this update on the pinebookpro.
Using kernel linux-pinebookpro 5.7.19-1, everything works fine (charge + external monitor via a usb-c dock).
With linux-5.10.2-1 the charge indicator (widget in the task bar) showed that it was charging, but it was not (I measured the current with a usb gadget). External monitor did not work either.
With linux-rc-5.10-rc7-4 the charging mode was swtiching fast (and the screen backlight too). I did not try the external monitor.

In the end, I reverted to linux-pinebookpro 5.7 :slight_smile:

1 Like

I build a new image for pine64 and pineH64 but on both network doesn’t work.

Edit: regarding the network, I had to “ip link set eth0 up” as it was down and the restart network manager. Now network is working. Don’t know why it’s this way on pin64 and pineh64.