[ARM Stable Update] 2020-12-30 - Python 3.9 rebuilds, Kernels, Firefox, Mesa 20.2.6, KDE Apps, Gstreamer, KDE Frameworks, LibreOffice, Thunderbird, Pamac

During update, my customized x11vcn.service was overwritten with the default.
Also, x11vcn.service was disabled.

So far, I did not encounter any serious issues on rpi4 stable.

The version of FreeCAD in ArchLinux ARM’s repository is 0.18.5-6, however, that is 0.18.5-3 in Manjaro ARM’s repository. We need to keep up with ArchLinux ARM in time.

We already have that package in our other branches …

freecad repository : community
Stable : 0.18.5-3
Testing : 0.18.5-6
Unstable : 0.18.5-6

Do you know how Manjaro repo work?

If you want “close to Arch”, you could run on Unstable branch. That will have the new versions on the same day as or the day after Arch.

Unfortunately after this update my Raspberry Pi 3B has no network, either Ethernet or WiFi.
I have been unable to enable the network with NetworkManager and I am at a loss to know what to try next - any suggestions please?

Depends on the state of your system. Do the interfaces show up in network manager? Do you see wifi networks? Trying to establish if this is a driver issue (that restoring the previous kernel packages from pacman cache would fox) or some sort of configuration issue with networkmanager et al.

Thanks. No interfaces or anything at all shows up.

My wifi, ethernet and bluetooth all work.

What does your: sudo systemctl --type=service say

If that’s the case, I’d roll back the kernel package as outlined here from the archlinux wiki:


Think this would work on a Lenovo Miix 630?

No. It’s a snapdragon SoC, and we don’t have support for those.

1 Like

Does anyone else have problems with kdeconnect after this update? I didn’t notice earlier because I wasn’t using PBP for a few days. The previous versions were working except SMS sending but this version of kdeconnect does not see devices on the network, both paired and not paired. Downgrading didn’t help either (maybe I should restart the system after reinstalling kdeconnect), also the downgrade command now complains about not being runned by the root, so my local alias with the linkt to the ARM repo doesn’t without sudo and sudo can’t find my alias. Workaround was to install kdeconnect-git from the community repo and restart, it crashes after loading all SMSes and just before you can type anything, but remote control works perfectly.

Hi. I had the same issue in starting both octave and R as was found in Testing with libblas.so.3. It is just due to the libblas.so.3 link being missing: I fixed it using

sudo ln -s libopenblas.so.3 libblas.so.3

I suspect that the libblas.so link is messed up as well. Thanks.


Ta. I’ve tried reporting it upstream, but they’re not the most talkative of people, so will just have to hope that someone sees it and fixes it.

To those curious about USB-C chargin while the laptop is turned off:

Apologies; my life went to hell for a bit. But it appears to charge via USB-C while powered down. Still, I would strongly advise you do not fully rely on this without personally testing it yourself on your own device, if you do not have the standard barrel charger.

I’m not sure where the problem lies with this one. I checked the PKGBUILD for openblas from Arch Linux ARM’s repos and ran makepkg. The $pkgdir/usr/lib/ directory contains the libblas.so.3 symlink:

Scatha% ls -alh 
total 2.7M
drwxr-xr-x 4 benjamin benjamin 4.0K Jan 12 16:56 .
drwxr-xr-x 5 benjamin benjamin 4.0K Jan 12 16:56 ..
drwxr-xr-x 3 benjamin benjamin 4.0K Jan 12 16:56 cmake
lrwxrwxrwx 1 benjamin benjamin   23 Jan 12 16:56 libblas.so -> libopenblasp-r0.3.13.so
lrwxrwxrwx 1 benjamin benjamin   23 Jan 12 16:56 libblas.so.3 -> libopenblasp-r0.3.13.so
-rwxr-xr-x 1 benjamin benjamin 2.7M Jan 12 16:56 libopenblas_armv8p-r0.3.13.so
lrwxrwxrwx 1 benjamin benjamin   29 Jan 12 16:56 libopenblas.so -> libopenblas_armv8p-r0.3.13.so
lrwxrwxrwx 1 benjamin benjamin   29 Jan 12 16:56 libopenblas.so.3 -> libopenblas_armv8p-r0.3.13.so
drwxr-xr-x 2 benjamin benjamin 4.0K Jan 12 16:56 pkgconfig

However, when I install the package via pacman -U the symlink isn’t present in /usr/lib/:

Scatha% ls -alh libblas*
lrwxrwxrwx 1 root root 23 Dec 21 16:38 libblas.so -> libopenblasp-r0.3.13.so

The package() function in the PKGBUILD contains these two lines:

  ln -s libopenblasp-r$pkgver.so libblas.so
  ln -s libopenblasp-r$pkgver.so libblas.so.3

so it seems peculiar that one symlink would be created, and the other not.

Those links made are to a module that does not exist.

Using what your PKGBUILD shows above the only real module is :

2.7M Jan 12 16:56 libopenblas_armv8p-r0.3.13.so

Try this:

ln -s ./libopenblas_armv8p-r$pkgver.so ./libblas.so
ln -s ./libopenblas_armv8p-r$pkgver.so ./libblas.so.3

Ah… I now see where I’m being dim.

I’ve had a go at reworking the upstream PKGBUILD for this:

Will have to see if anyone in Arch Linux ARM thinks it’s worthy.