Archlinux-appstream-data-20230827-2 causes problem to Pamac

I am on stable branch and today I received a big update (no announcement yet).
There is archlinux-appstream-data from 20230715-1 to 20230827-2, and it causes a problem to Pamac: the browse page is empty, as already reported by other users:

ATM the solution is to downgrade such package.


Or, as a temporary measure, add the package to IgnorePkg in /etc/pacman.conf — make sure it’s uncommented… :arrow_down:

IgnorePkg   = archlinux-appstream-data
1 Like

This reported issue shouldn’t be happened, on the Stable branch.
People on the other branches were aware of the issue, but archlinux-appstream-data has been pushed to stable however.


I agree. And maybe this is why there hasn’t been a Stable Updates thread yet, i.e. maybe they’re trying to pull that package from the update again. But of course, for those who’ve already gone ahead with it, there would then later be a downgraded or patched version of the package.

On a personal note, I don’t really care about this bug, given that I never use the pamac GUI anyway. I always update everything from the command line with pacman for the repository packages, and then with either the pamac CLI, yay or trizen for my AUR stuff — I don’t use any AppImages, Snaps or FlatPaks.

1 Like

On unstable branch, it landed on 28/08/2023, so yes, one day is not enough for unstable users to upgrade and test it.


Pushing unstable stuff to stable branch defeats the whole purpose of having branches. Someone has been a bad boy and deserves spanking.

I guess i have to introduce the “super stable” branch on my system: “wait 2-3 days after the announcement to see the bugs in the forum and then update”


Well at least know we what the issue is I can wait for a fix as I don’t do enough browsing in pamac to worry about it.


Slapped with a wet trout! :stuck_out_tongue:

Or was it a herring? Oh wait… No, those are for cutting down the mightiest tree in the forest. :grin:


According to the News section in octopi, today’s update would indeed be a Testing update, but like the rest of you, I’m on Stable, and therefore I should not be seeing that update. Thus, it would appear that somebody made a boo-boo and accidentally pushed the Testing update out onto the Stable repository.


Now where did I leave my wet trout? :smiling_imp:


Problem was reported to testing update announcement 3 hours before this topic, followed by off-topic comments related to stable branch

List of updated packages has been published on Gitlab - Manjaro 2023-08-29 Stable Update

Before I read this thread I run today’s update with
pamac upgrade a
all worked but pamac gui hangs for about 10min at

$ pamac-manager
** Message: 17:52:40.983: flatpak_plugin.vala:393: refreshing flathub appstream data

before window opens.

I don’t know, but I’ve just posted this… :arrow_down:

temporary fix is to re-create old directories :

sudo ln -s /usr/share/swcatalog /usr/share/app-info
sudo ln -s /usr/share/swcatalog/xml /usr/share/app-info/xmls

This approach doesn’t work for me, which is the gnome desktop environment.

libpamac 11.6.2 should fix that. Pls test and give feedback.


Seem to be fixed now, apart from Categories/Games is Empty?

Xfce stable, libpamac 11.6.2-1 works on first glance.

Can’t reproduce.

systemctl restart pamac-daemon.service


Still the same here, No package found in Games.

1 Like




I sure did, also tried refreshing the mirrors but most are down at the time.