Android on Linux?

I’m trying to install an Android app on a laptop running the latest version of Manjaro with the MATE desktop environment and I’ve been unsuccessful so far. So, I would appreciate any help that I could receive to solve this issue, thanks.

Moderator edit: Corrected formatting.

1 Like

You’d need an android emulator for that.
Quite obviously, I might add.

1 Like

Yes. I’ve tried installing Android emulators already - haven’t gotten any degree of success as of yet.

Tried Virtualbox?

I suppose this is about to turn into a support question about VirtualBox - since I haven’t got VirtualBox to even work. And the last time I attempted to get something set up on this, it ended up bricking my system and I had to re-install Manjaro.

I never even tried.
No experience with that.
No real use case for me.

The Android on my phone is sufficient for me. :slightly_smiling_face:

although it usually is Lineage OS - I use phones that can be flashed and are supported there.
Currently running Android 10 on Galaxy A3 (2016)

To be quite frank, the Android on my tablet/smartphone should be sufficient for me. And, no — “Going back to Windows 11 is not really an option for me.”

The amount of ads that Windows 11 gave me constantly is kind of a deal-breaker for me in the absolute first place!

I’m kind of trying to transfer myself away from Windows use (mostly) by the end of the decade. I suppose VirtualBox may be an option for me again — if I can figure out how to get VirtualBox to work, without say… Getting an error message saying “You can’t turn this on because you need to have edited /vbox/sbin as root.”

The Arch wiki is a very good resource for getting this explained - it is, after all, the primary resource for all info pertinent to Arch/Manjaro.

Well, thanks for helping. I may end up going to look up information on the Arch wiki after this.

The info is good and complete.
I have zero problems running either VirtualBox or Virt-Manager (KVM/qemu)

But there are dedicated Android emulators as well - I know nothing about them, experience wise.

I’m looking that information up. Also, KVM/qemu may be worth looking into getting to work.

Will install a VM to test.

//EDIT: as expected it works normally, I installed Android 9 and it works just fine following the few tips in the link above, like the video adapter you need to select VBoxVGA or VBoxSVGA or else you end up in console, not proper display of Android OS. Network works out of the box, I switched keyboard layout and UI language, installed Firefox web browser, configured a few settings. It works.

1 Like