All desktop and menu icons missing

All my desktop and menu icons are missing. The system font changed for some areas, but not for others (when I right-click my desktop the font in the menu is changed, in folders it is not). My icon theme was also reset.

https://paste.pics/e603480ec1f5fb1721e3eaf9c3519ba2

Everything is still clickable and works as intended (desktop and menu).

Some text is missing

https://paste.pics/d021b3872a286c6f38a99cd8adb9a6d7

What I have tried to fix it:

  • reboot
  • changing kernel
  • clearing cache (and specifically removing icon-cache.kcache and selecting new icon theme afterwards like mentioned here)
  • changing global theme
  • changing icon package
  • changing desktop background and layout (folder view is normal, changed it to desktop only makes the icons with text completely disappear. I can not select a location for the folder view, see 2nd screenshot)

I am a noob, please help

1 Like

create a new test user from system settings, log out, log in with it and see if it has also the same issues… if not, its something in your main user, and can be very likely be renaming some folders…

Icons appeared for the test user and disappeared 1 by 1 when I hovered over them. After relogging they are still gone.

thats not good…
rerun update again:
sudo pacman -Syu
if no errors, post output from:
inxi -Faz

Cannot do pacman -Syu without root rights. Its the main user but apparently I dont have one (maybe its better, so I can do less harm).

Here ist my inxi -Faz output

System:
  Kernel: 5.15.76-1-MANJARO arch: x86_64 bits: 64 compiler: gcc v: 12.2.0
    parameters: BOOT_IMAGE=/boot/vmlinuz-5.15-x86_64
    root=UUID=3b338e1a-d0bb-45c0-a4f6-b49640c7c762 rw quiet apparmor=1
    security=apparmor udev.log_priority=3 radeon.si_support=0
    amdgpu.si_support=1 radeon.cik_support=0 amdgpu.cik_support=1
  Desktop: KDE Plasma v: 5.26.2 tk: Qt v: 5.15.6 wm: kwin_x11 vt: 1 dm: SDDM
    Distro: Manjaro Linux base: Arch Linux

Machine:
  Type: Desktop Mobo: ASRock model: Z77 Pro3 serial: <superuser required>
    UEFI: American Megatrends v: P1.60 date: 09/12/2012

CPU:
  Info: model: Intel Core i5-3470 bits: 64 type: MCP arch: Ivy Bridge
    gen: core 3 level: v2 built: 2012-15 process: Intel 22nm family: 6
    model-id: 0x3A (58) stepping: 9 microcode: 0x21
  Topology: cpus: 1x cores: 4 smt: <unsupported> cache: L1: 256 KiB
    desc: d-4x32 KiB; i-4x32 KiB L2: 1024 KiB desc: 4x256 KiB L3: 6 MiB
    desc: 1x6 MiB
  Speed (MHz): avg: 1746 high: 2083 min/max: 1600/3600 scaling:
    driver: intel_cpufreq governor: schedutil cores: 1: 1600 2: 1701 3: 2083
    4: 1600 bogomips: 25610
  Flags: avx ht lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx
  Vulnerabilities:
  Type: itlb_multihit status: KVM: VMX disabled
  Type: l1tf mitigation: PTE Inversion; VMX: conditional cache flushes, SMT
    disabled
  Type: mds mitigation: Clear CPU buffers; SMT disabled
  Type: meltdown mitigation: PTI
  Type: mmio_stale_data status: Unknown: No mitigations
  Type: retbleed status: Not affected
  Type: spec_store_bypass mitigation: Speculative Store Bypass disabled via
    prctl and seccomp
  Type: spectre_v1 mitigation: usercopy/swapgs barriers and __user pointer
    sanitization
  Type: spectre_v2 mitigation: Retpolines, IBPB: conditional, IBRS_FW,
    STIBP: disabled, RSB filling, PBRSB-eIBRS: Not affected
  Type: srbds status: Vulnerable: No microcode
  Type: tsx_async_abort status: Not affected

Graphics:
  Device-1: Intel Xeon E3-1200 v2/3rd Gen Core processor Graphics
    vendor: ASRock driver: i915 v: kernel arch: Gen-7 process: Intel 22nm
    built: 2012-13 ports: active: HDMI-A-2 empty: DP-1, DP-2, HDMI-A-1, VGA-1
    bus-ID: 00:02.0 chip-ID: 8086:0152 class-ID: 0380
  Device-2: NVIDIA GM204 [GeForce GTX 970] driver: nouveau v: kernel
    non-free: 520.xx+ status: current (as of 2022-10) arch: Maxwell code: GMxxx
    process: TSMC 28nm built: 2014-19 pcie: gen: 1 speed: 2.5 GT/s lanes: 16
    link-max: gen: 3 speed: 8 GT/s ports: active: HDMI-A-3 empty: DP-3, DP-4,
    DP-5, DVI-I-1 bus-ID: 01:00.0 chip-ID: 10de:13c2 class-ID: 0300
    temp: 38.0 C
  Display: x11 server: X.Org v: 21.1.4 compositor: kwin_x11 driver: X:
    loaded: modesetting alternate: fbdev,vesa dri: nouveau,crocus
    gpu: i915,nouveau display-ID: :0 screens: 1
  Screen-1: 0 s-res: 3840x1080 s-dpi: 96 s-size: 1013x285mm (39.88x11.22")
    s-diag: 1052mm (41.43")
  Monitor-1: HDMI-A-2 mapped: HDMI-1-2 pos: right model: Acer S242HL
    serial: <filter> built: 2012 res: 1920x1080 dpi: 92 gamma: 1.2
    size: 531x299mm (20.91x11.77") diag: 609mm (24") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  Monitor-2: HDMI-A-3 mapped: HDMI-3 pos: primary,left model: AOC 27G2G4
    serial: <filter> built: 2019 res: 1920x1080 hz: 60 dpi: 82 gamma: 1.2
    size: 598x336mm (23.54x13.23") diag: 686mm (27") ratio: 16:9 modes:
    max: 1920x1080 min: 720x400
  API: OpenGL v: 4.3 Mesa 22.2.1 renderer: NV124 direct render: Yes

Audio:
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: ASRock
    driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20
    class-ID: 0403
  Device-2: NVIDIA GM204 High Definition Audio driver: snd_hda_intel
    v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 16 link-max: gen: 3
    speed: 8 GT/s bus-ID: 01:00.1 chip-ID: 10de:0fbb class-ID: 0403
  Sound API: ALSA v: k5.15.76-1-MANJARO running: yes
  Sound Server-1: JACK v: 1.9.21 running: no
  Sound Server-2: PulseAudio v: 16.1 running: yes
  Sound Server-3: PipeWire v: 0.3.59 running: yes

Network:
  Device-1: Realtek RTL8111/8168/8411 PCI Express Gigabit Ethernet
    vendor: ASRock driver: r8169 v: kernel pcie: gen: 1 speed: 2.5 GT/s lanes: 1
    port: d000 bus-ID: 05:00.0 chip-ID: 10ec:8168 class-ID: 0200
  IF: enp5s0 state: up speed: 1000 Mbps duplex: full mac: <filter>
  Device-2: Intel Wi-Fi 6 AX200 driver: iwlwifi v: kernel pcie: gen: 2
    speed: 5 GT/s lanes: 1 bus-ID: 06:00.0 chip-ID: 8086:2723 class-ID: 0280
  IF: wlp6s0 state: up mac: <filter>

Bluetooth:
  Device-1: Intel AX200 Bluetooth type: USB driver: btusb v: 0.8
    bus-ID: 1-1.1:3 chip-ID: 8087:0029 class-ID: e001
  Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends

Drives:
  Local Storage: total: 2.33 TiB used: 644.78 GiB (27.0%)
  SMART Message: Unable to run smartctl. Root privileges required.
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST2000DM001-1CH164
    size: 1.82 TiB block-size: physical: 4096 B logical: 512 B speed: 6.0 Gb/s
    type: HDD rpm: 7200 serial: <filter> rev: CC44 scheme: MBR
  ID-2: /dev/sdb maj-min: 8:16 vendor: Crucial model: CT500MX500SSD1
    size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: 6.0 Gb/s
    type: SSD serial: <filter> rev: 023 scheme: GPT
  ID-3: /dev/sdc maj-min: 8:32 vendor: Crucial model: M4-CT064M4SSD2
    size: 59.63 GiB block-size: physical: 512 B logical: 512 B speed: 3.0 Gb/s
    type: SSD serial: <filter> rev: 070H scheme: GPT

Partition:
  ID-1: / raw-size: 465.46 GiB size: 457.09 GiB (98.20%)
    used: 99.42 GiB (21.8%) fs: ext4 dev: /dev/sdb2 maj-min: 8:18
  ID-2: /boot/efi raw-size: 300 MiB size: 299.4 MiB (99.80%)
    used: 280 KiB (0.1%) fs: vfat dev: /dev/sdb1 maj-min: 8:17

Swap:
  Alert: No swap data was found.

Sensors:
  System Temperatures: cpu: 36.0 C mobo: N/A gpu: nouveau temp: 38.0 C
  Fan Speeds (RPM): N/A gpu: nouveau fan: 1220

Info:
  Processes: 223 Uptime: 57m wakeups: 0 Memory: 7.65 GiB
  used: 2.18 GiB (28.4%) Init: systemd v: 251 default: graphical
  tool: systemctl Compilers: gcc: 12.2.0 clang: 14.0.6 Packages: pm: pacman
  pkgs: 1774 libs: 493 tools: pamac pm: flatpak pkgs: 0 Shell: Zsh v: 5.9
  default: Bash v: 5.1.16 running-in: konsole inxi: 3.3.23

Didnt noticed, so run it with sudo:
sudo pacman -Syu

And format your inxi output, click this icon in editor: </> and copy the output there…

And why do you have the radeon/amdgpu kernel parameters? You dont have amd, you have intel + nvidia…

And why dont you have installed nvidia drivers? Is there a reason for it? This issue you have could be because of it…

Thank you for all the replies :slight_smile:

Oh yeah I just need to run it with sudo, of course.

My output from sudo pacman -Syu is

:: Paketdatenbanken werden synchronisiert …
 core ist aktuell
 extra ist aktuell
 community                                                          7,5 MiB  11,3 MiB/s 00:01 [#######################################################] 100%
 multilib ist aktuell
 wine-lol.db konnte nicht heruntergeladen werden
Fehler: Konnte Datei 'wine-lol.db' nicht von m-reimer.de ĂĽbertragen : The requested URL returned error: 404
Fehler: Keine Datenbank konnte synchronisiert werden (Konnte manche Dateien nicht ĂĽbertragen)
~ >>>                                                            

first error doesnt matter i think, was old gaming stuff i tried. 2nd error roughly translated

Error: Database could not be synchronized (some data could not be transfered)

The drivers are probably because i switched to an nvidia gpu recently from amd. I will try to install nvidia drivers. How do I replace the kernel parameters?

So remove the changes that you made to pacman, then rerun the update again…
Dont install the nvidia drivers untill the pacman is fixed, and untill we add another parameter related to nvidia, because its possible that without the parameter you may not be able to boot…
So first fix pacman…then we will continue

1 Like

How do i remove the changes to pacman. Sudo pacman -Sc ? I did that and then used sudo pacman -Syu again. Same error: No Database could be sychronised

The changes are probably in pacman conf, so post output from:
cat /etc/pacman.conf

/etc/pacman.conf
#
# See the pacman.conf(5) manpage for option and repository directives

#
# GENERAL OPTIONS
#
[options]
# The following paths are commented out with their default values listed.
# If you wish to use different paths, uncomment and update the paths.
#RootDir     = /
#DBPath      = /var/lib/pacman/
CacheDir = /var/cache/pacman/pkg/
#LogFile     = /var/log/pacman.log
#GPGDir      = /etc/pacman.d/gnupg/
#HookDir     = /etc/pacman.d/hooks/
HoldPkg      = pacman glibc manjaro-system
# If upgrades are available for these packages they will be asked for first
SyncFirst    = manjaro-system archlinux-keyring manjaro-keyring
#XferCommand = /usr/bin/curl -C - -f %u > %o
#XferCommand = /usr/bin/wget --passive-ftp -c -O %o %u
#CleanMethod = KeepInstalled
#UseDelta    = 0.7
Architecture = auto

#IgnorePkg   =
#IgnorePkg   =
#IgnoreGroup =

#NoUpgrade   =
#NoExtract   =

# Misc options
#UseSyslog
#Color
#TotalDownload
# We cannot check disk space from within a chroot environment
CheckSpace
#VerbosePkgLists

# By default, pacman accepts packages signed by keys that its local keyring
# trusts (see pacman-key and its man page), as well as unsigned packages.
SigLevel    = Required DatabaseOptional
LocalFileSigLevel = Optional
#RemoteFileSigLevel = Required

# NOTE: You must run `pacman-key --init` before first using pacman; the local
# keyring can then be populated with the keys of all official Manjaro Linux
# packagers with `pacman-key --populate archlinux manjaro`.

#
# REPOSITORIES
#   - can be defined here or included from another file
#   - pacman will search repositories in the order defined here
#   - local/custom mirrors can be added here or in separate files
#   - repositories listed first will take precedence when packages
#     have identical names, regardless of version number
#   - URLs will have $repo replaced by the name of the current repo
#   - URLs will have $arch replaced by the name of the architecture
#
# Repository entries are of the format:
#       [repo-name]
#       Server = ServerName
#       Include = IncludePath
#
# The header [repo-name] is crucial - it must be present and
# uncommented to enable the repo.
#

# The testing repositories are disabled by default. To enable, uncomment the
# repo name header and Include lines. You can add preferred servers immediately
# after the header, and they will be used before the default mirrors.

[core]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[extra]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

[community]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist

# If you want to run 32 bit applications on your x86_64 system,
# enable the multilib repositories as required here.

[multilib]
SigLevel = PackageRequired
Include = /etc/pacman.d/mirrorlist    

[wine-lol]
Server = https://m-reimer.de/wine-lol/$arch

# An example of a custom package repository.  See the pacman manpage for
# tips on creating your own repositories.
#[custom]
#SigLevel = Optional TrustAll
#Server = file:///home/custompkgs

~ >>>                                          

Open it:
kate /etc/pacman.conf
and remove this:

[wine-lol]
Server = https://m-reimer.de/wine-lol/$arch

save it and rerun update again

Than you. At least no errors now. Just 2 warnings, that local version is newer than community version.
Reboot did not bring the icons back.

:: Paketdatenbanken werden synchronisiert …
 core ist aktuell
 extra ist aktuell
 community ist aktuell
 multilib ist aktuell
:: Vollständige Systemaktualisierung wird gestartet …
Warnung: deepin-desktop-base: Lokale Version (3:2019.07.10-1) ist neuer als community (2:2022.07.26-2)
Warnung: deepin-wallpapers: Lokale Version (2:1.7.7-1) ist neuer als community (1:1.7.7-2)
 Es gibt nichts zu tun

Why do you have deepin installed?

I dont know :smiley: Sorry I really have no clue about linux.

Im starting to think its not related to nvidia…
Post output from:
pacman -Qs deepin

1 Like
~ >>> pacman -Qs deepin                                                                                                                                    
local/deepin-desktop-base 3:2019.07.10-1 (deepin)
    Base component for Deepin
local/deepin-qt-dbus-factory 5.5.22-5
    A repository stores auto-generated Qt5 dbus code (libdframeworkdbus)
local/deepin-qt5integration 5.5.24-1 (deepin)
    Qt platform theme integration plugins for DDE
local/deepin-qt5platform-plugins 5.0.67-1 (deepin)
    Qt platform plugins for DDE
local/deepin-wallpapers 2:1.7.7-1 (deepin-manjaro)
    Wallpapers for manjaro-deepin
local/deepin-wayland 1.0.0-1 (deepin)
    DDE wayland support libraries
local/dtkgui 1:5.6.0.2-1
    Deepin Toolkit, gui module for DDE look and feel
local/dtkwidget 5.6.0.2-2
    Deepin graphical user interface library
~ >>>   

Open add/remove software app search there for deeoin, click on installed, and remove the 8 deepin packages… If there are errors post them here, if there are none, reboot…

I had to remove dtkgui in the process and that did it. All Icons are back!! Thank you so much!
How do I avoid this in the future? I am asking because I did not know when I installed deepin

aaaaand they are gone on reboot…