After update 2021-10-08 audio devices click/pop when playback started

After this update, any new device that accesses the sound system, such as an audio player, firefox, audacity, etc. causes a very audible loud click/pop as it starts. This wasnt present prior to the update.

Edit: and its usually 2 or 3 and they are loud like putting in a sound cable when the speakers are on.

3 Likes

The same here with me, but only on the left channel (left satellite box). When I booted Linux Mint to test whether it could be the sound driver in the kernel, I also heard a (much quieter) plop on the left channel. I have already checked all cable connections of my sound system, since I assumed that something was defective. The only noticeable thing was that I only noticed this since the last update and reboot.

Edit: Device: ALC 887

Good to know I am not alone.

My Device: Advanced Micro Devices, Inc. [AMD] Starship/Matisse HD Audio Controller
Kernal Driver snd_hda_intel

I think its a power saving change. Following the advice here: Stop audio pops on Intel HD Audio | Major Hayden

I can set the powersaving bit to 0 and the pop went away. I had to edit the file, as echo wasnt allowed to modify it. I havent set it permanently with modprobe yet.

1 Like

It’s not gone, but at least it’s much quieter now. Thanks for the tip! The direction seems to be right, although it does not seem to be a final solution.

Although I have added it to

/etc/modprobe.d/audio_disable_powersave.conf

with

options snd_hda_intel power_save=0

it is set to 0 in

/sys/modules/snd_hda_intel/parameters/power_save

is set to 1 again after every reboot. What am I doing wrong?

If I use sudo in

/sys/modules/snd_hda_intel/parameters/power_save

# echo 0 > /sys/module/snd_hda_intel/parameters/power_save
$ cat /sys/module/snd_hda_intel/parameters/power_save
0

I get an error message when I try to save the file:

Error saving file. The argument is invalid.

1 Like

To disable power saving on Manjaro might require 2 modprobe options

options snd_hda_intel power_save=0 power_save_controller=N

Pops when starting and stopping playback - Advanced Linux Sound Architecture/Troubleshooting - ArchWiki

But the modprobe/boot options to disable power saving might be overruled by tlp power management

To change tlp configuration for audio devices, open tlp configuration file in a text editor
(other text editors are available, but nano is usually installed on any version of Manjaro)

sudo nano +329 /etc/tlp.conf

change these settings

#SOUND_POWER_SAVE_ON_AC=1
#SOUND_POWER_SAVE_ON_BAT=1

to this

SOUND_POWER_SAVE_ON_AC=0
SOUND_POWER_SAVE_ON_BAT=0

and change this setting:

#SOUND_POWER_SAVE_CONTROLLER=Y

to this

SOUND_POWER_SAVE_CONTROLLER=N

For nano, use Ctrl + O to save the file and Ctrl + X to exit

Reboot system to ensure changes to power management are loaded

2 Likes

@nikgnomic :

Is then the entry in

/etc/modprobe.d/audio_disable_powersave.conf

still necessary?

The modprobe options are probably not needed if powersave is disabled in tlp

But I would suggest renaming the .conf file rather than deleting it

mv  /etc/modprobe.d/audio_disable_powersave.conf /etc/modprobe.d/audio_disable_powersave.old

and delete the file when system is confirmed to work OK

mv  /etc/modprobe.d/audio_disable_powersave.old
1 Like

very much thanks @nikgnomic . I was in despair …

1 Like

OK, that did NOT work.
With the changes in

+329 /etc/tlp.conf

and reboot, the file

/sys/modules/snd_hda_intel/parameters/power_save

disappears and the scramble is back.

I noticed that this noise is gone ONLY WHEN

the value in

/etc/modprobe.d/audio_disable_power_save.conf is set to 0, but this will not survive a reboot.

Agreed that did not work. Editing TLP was the first thing I did, and it did not change anything.

I decided to remove it from the system altogether. I have a desktop, I dont need laptop power management. I also tried a different Kernel but that didnt help either.

So the only thing that is working is the first solution of setting etc/modprobe.d/audio_disable_power_save.conf is set to 0

I will look into making it permanent later on when I have time and post it here.

1 Like

Following thread since after last system update i’ve the same problem :slight_smile:

1 Like

This is consistent with my experience. Thanks for the effort, a permanent solution is eagerly awaited. :pray:

I looked at the post that @nikgnomic made above. They posted the Arch ALSA wiki link that I followed.

  1. I removed TLP from the computer using the package manager. Unless someone can tell me why I would want it on a desktop, I am fine with this decision.

  2. I created a file with

sudo nano /etc/modprobe.d/modprobe.conf

and added this:

options snd_hda_intel power_save=0 power_save_controller=N

This appears to now be persistent and does the trick.

There is an additional step noted in the wiki that MAY need to be done on certain machines, but this worked for me.

I cannot think of any reason why tlp would be necessary for a desktop system, so if removing it gets your system to work as you want that is a valid solution

@anon71035019
If the modprobe option is not working for you, try replacing it with a similar option added to GRUB_CMDLINE_LINUX_DEFAULT boot options in /etc/default/grub like this:

GRUB_CMDLINE_LINUX_DEFAULT="quiet udev.log_priority=3 snd_hda_intel.power_save=0"

The single space in the modprobe option must be replaced with a dot (full stop/period) to be read correctly in GRUB

and update GRUB

sudo update-grub

@fabby I was going to mark have marked post#15 as the solution because it did follow on from my post. OP went and RTFW and brought something new to the discussion
(and he likes old V Dubs like myself )

1 Like

What is a stop, how must this line look correctly?

options snd_hda_intel power_save=0 power_save_controller=N

Sorry, do not really understand much of it :thinking:

PS.: I want to try the modprobe method again first.

1 Like

Just a thought: would you avoid this problem by simply connecting an external DAC to USB to bypass the ALC887? I’ve been meaning to replace the onboard sound with something better for years anyway.

Once again, if it should have gone down: I have no idea of coding, how must the line now be written correctly:

options snd_hda_intel power_save=0 power_save_controller=N

?

What is with this stop-sign, with which the space is to be replaced?

IF the modprobe option is replaced with a boot option in GRUB
the Space must be replaced with a Full Stop

snd-hda-intel power-save=0 added to GRUB would be read as 2 separate options
snd_hda_intel and power-save=0

snd-hda-intel.power-save=0 is read as one complete option

2 Likes

thx @nikgnomic