After Stable Update 2021-09-24 LightDM no longer automatically start

I rebooted again for execute lightdm --test-mode --debug to get a debug log:

[+0.00s] DEBUG: Logging to /home/dave/.cache/lightdm/log/lightdm.log
[+0.00s] DEBUG: Starting Light Display Manager 1.30.0, UID=1000 PID=813
[+0.00s] DEBUG: Loading configuration dirs from /usr/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /usr/local/share/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration dirs from /etc/xdg/lightdm/lightdm.conf.d
[+0.00s] DEBUG: Loading configuration from /etc/lightdm/lightdm.conf
[+0.00s] DEBUG: Running in user mode
[+0.00s] DEBUG: Registered seat module local
[+0.00s] DEBUG: Registered seat module xremote
[+0.00s] DEBUG: Using D-Bus name org.freedesktop.DisplayManager
[+0.05s] DEBUG: _g_io_module_get_default: Found default implementation gvfs (GDaemonVfs) for ‘gio-vfs’
[+0.05s] DEBUG: Monitoring logind for seats
[+0.05s] DEBUG: New seat added from logind: seat0
[+0.05s] DEBUG: Seat seat0: Loading properties from config section Seat:*
[+0.05s] DEBUG: Seat seat0 has property CanMultiSession=no
[+0.05s] DEBUG: Seat seat0: Starting
[+0.05s] DEBUG: Seat seat0: Creating greeter session
[+0.17s] DEBUG: Loading users from org.freedesktop.Accounts
[+0.17s] DEBUG: User /org/freedesktop/Accounts/User1000 added
[+0.18s] DEBUG: Seat seat0: Creating display server of type x
[+0.18s] DEBUG: Could not run plymouth --ping: Failed to execute child process “plymouth” (No such file or directory)
[+0.18s] DEBUG: Seat seat0: Starting local X display
[+0.18s] DEBUG: XServer 0: Logging to /home/dave/.cache/lightdm/log/x-0.log
[+0.18s] WARNING: XServer 0: Failed to make authority directory /run/lightdm/root: Permission denied
[+0.18s] DEBUG: XServer 0: Writing X server authority to /run/lightdm/root/:0
[+0.18s] WARNING: XServer 0: Failed to write authority: Failed to open X authority /run/lightdm/root/:0: No such file or directory
[+0.18s] DEBUG: XServer 0: Launching X Server
[+0.18s] DEBUG: Launching process 847: /usr/bin/X :0 -seat seat0 -auth /run/lightdm/root/:0 -nolisten tcp
[+0.18s] DEBUG: XServer 0: Waiting for ready signal from X server :0
[+0.18s] DEBUG: Acquired bus name org.freedesktop.DisplayManager
[+0.18s] DEBUG: Registering seat with bus path /org/freedesktop/DisplayManager/Seat0
[+0.18s] WARNING: Could not enumerate user data directory /var/lib/lightdm-data: Error opening directory '/var/lib/lightdm-data': Permission denied
[+0.18s] DEBUG: Process 847 exited with return value 1
[+0.18s] DEBUG: XServer 0: X server stopped
[+0.18s] DEBUG: XServer 0: Removing X server authority /run/lightdm/root/:0
[+0.18s] DEBUG: Seat seat0: Display server stopped
[+0.18s] DEBUG: Seat seat0: Stopping session
[+0.18s] DEBUG: Seat seat0: Session stopped
[+0.18s] DEBUG: Seat seat0: Stopping display server, no sessions require it
[+0.18s] DEBUG: Seat seat0: Stopping; greeter display server failed to start
[+0.18s] DEBUG: Seat seat0: Stopping
[+0.18s] DEBUG: Seat seat0: Stopped
[+0.18s] DEBUG: Required seat has stopped
[+0.18s] DEBUG: Stopping display manager
[+0.19s] DEBUG: Display manager stopped
[+0.19s] DEBUG: Stopping daemon
[+0.19s] DEBUG: Exiting with return value 1

Can you provide your configs?


Around 6 months ago I faced instabilities with lightdm-gtk-greeter (doubled login-gui, unthemed, top left on my screen sometimes) .
Since replacing lightdm-gtk-greeter and it’s settings with slick-greeter and lightdm-settings my system runs fine. Worth a try.
And no, I don’t use pikom.


greeter-session = lightdm-webkit2-greeter

lightdm-gtk-greeter.conf (is not used: I use lightdm-webkit2-greeter; I tried to switch back to lightdm-gtk-greeter but the result is the same)



debug_mode          = false
detect_theme_errors = true
screensaver_timeout = 300
secure_mode         = true
time_format         = LT
time_language       = auto
webkit_theme = sequoia

[+0.18s] WARNING: Could not enumerate user data directory /var/lib/lightdm-data: Error opening directory '/var/lib/lightdm-data': Permission denied

So there is a permission issue… But such directory is owned by lightdm:

I don’t use lightdm-gtk-greeter, but lightdm-webkit2-greeter, which has always worked fine; the strange thing is that since two days ago it worked without issues; the problem start to appear since the stable update from yesterday (which didn’t provided updates for lightdm); I also restored a system backup with timeshift, but the described issue is still there.

change to:

Done: doesn’t help.

It is really weird… at this point I have no idea. I come back to you if I have another idea. Maybe someone know what your actual problem is…

I have no system which is running lightdm or xfce4 right now.


In the meantime I thank you for your efforts, for devoting your time :slight_smile:

1 Like

This might be relevant:

I don’t have hybrid graphic (Intel/Nvidia): I have only Intel; I also tried to boot with different kernels, without success.

I’m going to accept the fact of login using TTY instead of graphic greeter.

I also tried to uninstall again lightdm and lightdm-greeter and delete his directories (I discovered that are reported in /usr/lib/tmpfiles.d/lightdm.conf)


Then reboot for the umpteenth time, reinstall it again and so on: lightdm doesn’t want to autostart anymore, and I repeat: I also restored the system backup from the day before the stable update.
I also disabled the service lightdm.service: is useless, since it doesn’t autostart anymore: is a weight on the startup.

So I login from TTY, by executing startxfce4, and I had to replicate the environment variables from ~/.profile to ~/.bashrc (eg, like export QT_QPA_PLATFORMTHEME="qt5ct");
This because seems that by starting the graphical environment from startxfce4 doesn’t source ~/.profile: I verified this by doing echo $QT_QPA_PLATFORMTHEME: resulted in an emtpy output, is ok instead by having the env variables in ~/.bashrc.

still in ~/.bashrc, I made an alias to quickly execute startxfce4:
alias sd="startxfce4" (sd stands for Start Desktop).

lxdm, the alternative for lightdm, works fine, but is not customizable like lightdm, and furthermore, the system’s mouse theme is not applyed by lxdm.

Hm, shouldn’t be a thing depending on your hardware. Maybe try a newer LTS Kernel 5.4 or 5.10

$ sudo mhwd-kernel -i linux54
$ sudo mhwd-kernel -i linux510

I have no issues with this on my old Lenovo ThinkPad 60.

1 Like

I already tried newer kernels, without success.

Other solutions are:

1 Like

I already had, since months, i915 in mkinitcpio, as well I also tried logind-check-graphical=true in /etc/lightdm/lightdm.conf.

As you seem to be the only one having this issue, moved that conversation into the original topic until we have a solution / workaround after which we can update the wiki…


I am also experiencing the same issue. My CPU is Ryzen 3 3200G, mobo Asus TUF Gaming x570-Plus, running kernel 5.14.10-1, and Cinnamon 5.0.5 DE. I opened the file mkinitcpio as root and there is no MODULES section, see content:

# mkinitcpio preset file for the 'linux514' package


PRESETS=('default' 'fallback')


fallback_options="-S autodetect"

Editing the /etc/lightdm/lightdm.conf by replacing false by true did not work.
I can only access the desktop by launching “startx” in tty.
Thanks for any help.

You’re supposed to add it, but that looks like the wrong file. What’s it’s full pathname?


Full path name: /etc/mkinitcpio.d/linux514.preset
Hope this helps.

1 Like