After install BIOS is not accessible anymore


Installed Manjaro on a laptop today from an USB drive.
Everything went fine, nothing special about the install itself, chose full install with disk encryption.
Made no changes in partition and no dual boot.

After the install I realized that I didn’t want full encryption, just an encrypted /home partition.
So, I rebooted my computer and pressed F2 as allways for entering BIOS, but now it just goes one beep and then automatically boots into Manjaro.
Tried F12 and entered a boot menu only listing Manjaro.
Same USB I used just 10 minutes ago is not listed as an entry in boot menu anymore.

I’ve now tried different ISO’s, USB-drives, Windows 7 original CD, it can’t find anything else in boot menu than Manjaro.
I can’t enter BIOS either to do a reset, I guess Manjaro somehow overwrote BIOS or installed an EFI on a BIOS-only motherboard.
The only way to restore BIOS is to use a Windows utility because booting from USB doesn’t work anymore.

I’ve never seen anything like this, I’ve installed a lot of Linux distributions in my past.

Is there anything to do? I can boot up Manjaro, but that’s pretty much it.

Thanks in advance!

probably just bad timing
the bios is accessible for a short time - then it is the boot loader that you’ll reach
spam the key …

Spam the key doesn’t work unfortunately. Even paus/break and F2 doesn’t do the kick.
I can hear it beep but it just boots into Manjaro.

F12 can bring up boot menu, but only shows Manjaro.
One weird thing is that it looks like the installation is UEFI with GPT but the motherboard only supports BIOS legacy.

it always is
no matter what OS or bootloader is installed

Maybe not after a reboot - because the timing might not be easy.
But from complete shutdown/power off and then power on again via the physical switch.
It’s… I’ll even say impossible that the bios is rendered inaccessible due to installing anything - because it is what has to come up first, to initialize the machine and then pass control to whatever boot loader.

Can’t help.
Maybe someone else can?


so, Bios is accessible …
maybe connect your USB stick
it should then show up as an option to boot from …
just a guess

Thanks for your input.

I’ve tried cold boot and removing battery and the SSD.
Neither USB drives or Windows original DVD will show in the boot menu.

I just think it’s odd how I can access BIOS menu, change boot order, install Manjaro and after a reboot none of it work.

That is very unusual and strange.
I have no idea and can’t help.

Maybe someone else can?

All the best!

Only thing I can think of is trying to get into BIOS with

sudo systemctl reboot --firmware-setup

I tried the command, but no luck: Cannot indicate to EFI to boot into setup mode: Firmware does not support boot into firmware

If I do ls /sys/firmware/efi it looks like it’s installed with EFI, but this motherboard should not support it. How is that even possible :confused:

I’ve now done a lot of research and unfortunately the issue is far more serious !

First things first:
The motherboard do actually support UEFI, there’s just no option in BIOS menu to change between legacy/UEFI/csm, no secure boot and no fast boot.

Now the more seriousness of the issue:
On some affected systems Linux Uefi installation do overwrite parameters on NVRAM, deleting ALL entries in F12 boot menu like - USB boot, PXE boot and CD/DVD boot, leaving you with only one efi-entry in this case Manjaro EFI.
It also locks out the user from being able to access BIOS menu through F2.

This bug was reported to Ubuntu as early as 2012:

There is no solution, which means that if my Manjaro install fails somehow the laptop is bricked!!
It seems though, that there is a workaround according to some users on the ubuntu bug page that I could short two pins on the motherboard to get booting from USB work and then eventually install Windows and restore BIOS. But this is potentially DANGEROUS and could end up in a disaster breaking the motherboard.

I don’t know what to do, but for now I cant touch the Manjaro install at all risking of bricking my laptop.
I’m wondering if there’s a possibility to create a manual EFI shortcut to a USB drive from within Manjaro?

Sorry if my english grammar isn’t correct.
Thanks in advance

in comment no. 8
he said:

Buth onestly, I don’t want to write everything all over again, so for the details please have a look at (the comment by moerdock from 2012/11/30 04:00).

Which is unfortunate since this link now goes nowhere.
The site doesn’t seem to hold any information anymore.

There seems to be a way of booting freeDOS to re-flash the firmware.
I have done this myself in the past.
… but to do that, you need to be able to boot something else beside the installed system
which currently seems not possible - without physically opening the thing and “shorting some pins”

Wrong guess - try lousy EFI implementation - the installer never overwrite your firmware - it only adds a boot entry to the list and sets the entry as primary. Just try running efibootmgr and efibootmgr -h

The installer Manjaro uses - Calamares - does not - and cannot - install using EFI on a non-efi system - just read all the topics where members has been confused on this matter.

Your issue is not unheard of - from time to time - although rarely - we hear of this - and it is most likely the firmware implementation which are at fault here.

Boot your Manjaro and run the efi tool - what is the output (copy the output as text and paste it - then select the pasted text and click the </> in the post toolbar) of

$ efibootmgr

Could you post as many details as possible on your system and the firmware reported to inxi

$ sudo inxi -Mxxx

I did read the whole bug page and a couple of more bug reports and I can only find the workaround with shorting the pins. I see that as a last resort because it is a posibility of breaking the motherboard and there is no coming back from that.

Your are absolutely correct, I did correct myself in my last post. The motherboard does support EFI even though there’s no option in the BIOS menu for choosing between legacy and UEFI.

I tried earlier with efibootmgr, it only shows:
No BootOrder is set; firmware will attempt recovery

Here it goes:


Type: Laptop System: Fujitsu Product: LIFEBOOK AH532 v: N/A
Mobo FUJITSU model: FJNBB1C UEFI: FUJITSU // Phoenix v: Version 1.09 date: 05/22/2012

Best Regards,

I cannot predict how this will work but the idea is to use grub’s boot from ISO functionality.

This should - theoretically make it possible to boot a windows iso of some kind.

The preferable would be a Windows rescue ISO like Hirens Boot CD which uses a Windows Rescue environment - WinRE.

In theory - from that environment and your hardware can be flashed from within windows you should be able to both download and flash the firmware.

Booting a Manjaro ISO is easy-peasy - just read this

Booting a Windows ISO from GRUB is more tricky and frankly I don’t the how to do it but I figure if ventoy project can do it - it should be possible.

I have also been playing with the thought of using the installed Manjaro to manually install Manjaro onto an USB - then use grub efi installer without the removable argument which in theory should add the usb stick to the systems firmware.

If that works then you would have an entry in efi which in theory could also boot a stick with a windows installer or winpe. If this works you could use Manjaro to prepare an USB with ventoy - then one-to-one copy Hirens boot CD to the USB.

But all that is speculation and I have idea if it will work at all.

From a fedora forum - I found this

Which matches my thought of using efibootmgr to create an entry pointing to the USB - if your system only has one disk then pointing to

# efibootmgr --create --disk /dev/sdb --part 1 --loader /EFI/folder/efistub --label 'USB RESCUE'

From an old topic found in the archive

On a note - I vaguely recall someone who fixed in similar issue - the problem was the EFI loader - a wild guess could be a version issue between the loader and firmware blocking the firmware from loading correctly.

:warning: Proceed with caution - this is completely unverified - the result may have been sheer luck - but if you still have Windows installed on the system this may work. Please check the contents of /boot/efi/EFI subfolders and files - you need to be root to list the contents - but be careful with this one as it may brick your system. :warning: The trick was to remove the grub efistub so the system was forced to use the windows stub - which brought the firmware back to life. :warning:


Thank you very much for the information!
I’ll be digging into that one with booting Hirens from grub. I’m setting up a test enviroment on another computer so if something breaks there I could just do a reinstall.

I was looking at that Fedora post last night but there’s one thing I am worried about:
When I run efibootmgr now it says: No BootOrder is set; firmware will attempt recovery
If I add an entry is there a posibility that i might actually delete the working Manjaro efi?
It doesn’t seem like it recognizes the boot entry now because it’s not present in efibootmgr.

I will also check out that thread with similar problem.

Unfortunately no Windows EFI or other EFI is present in F12 boot menu, just Manjaro EFI.

Thanks again for your help, I’ll try the Hirens/Grub way and report back!

Best Regards

not sure if this is of any meaning after all those technical posts;
but last week i stumbled upon an option in KDE/“desktop session” where you can check a box which says: “enter UEFI setup on next restart”.

Just another crazy thought - have tried dismantling the internal disk and boot from USB?

I found a workaround for getting BIOS menu back. It’s time consuming, but didn’t need to short any pins.

As always, backup your data first.


  • Put Hirens Boot Cd or Windows 10 on a bootable USB
  • Start Grub menu before Manjaro boots, enter Grub terminal
  • Locate your USB drive with ls command, should be like hd0, hd1 etc
  • Use ls to find where the bootable efi-file is - like bootx64.efi
  • Load in modules with these commands:

insmod part_gpt
insmod fat
insmod chain

Boot Hirens/Windows with these commands:

chainloader (hdX)/directory/directory/bootx64.efi

If it all goes well your Hirens/Windows 10 should be booting up in a couple of minutes.
Time depends on how fast your media is.

For me, I had to install Windows, couldn’t restore BIOS in Hirens. Windows BIOS utility just crashed.
After I restored BIOS in Windows 10, I could access BIOS from F2 and all boot entries came back in the F12 boot menu.

I installed Fedora using UEFI just for comparison and same thing happened, lost both F2 BIOS acess and all F12 boot entries.
The bug reported to Ubuntu back in 2012 is therfore still not squashed and you should think once or twice before installing a Linux UEFI installion on a Fujitsu AH532.

Thank you all for your help.

1 Like

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.