New Laptop but after Install no BIOS /UEFI /USB Boot possible anymore

Hi, im a new member here and unfortunately a few hours after use, i have a big problem. I hope you all can help me out here.
I bought a new Acer Swift Laptop with no OS installed. I installed manjaro with default settings (complete disk) but with disk encryption.
I previously disabled secure boot to be able to install / boot the usb stick where i flashed manjaro.

But now, when i try to enter BIOS by pressing F2 button, a black screen appears and the whole system stuck. All i can do is to power off, no keystroke recognized.

I was searching around and found people who facing the same problem like me. For example this thread:

But i can’t do what he was doing, i can only enter grub rescue mode and i dont know how to locate the bootx64.efi by using “ls” command. and the other commands like “chainloader” are unknown in grub rescue. And it doesnt matter what i do, i always get the “unknown filesystem” result in grub.

So it seems that that “great” GRUB loader destroyed my only few hour old 500€ Laptop because i dont know how to fix it. Is there no possibillity to wipe the GRUB partition that the BIOS / EFI can load again?
I can use manjaro for now but when somethin goes wrong im not able to install anything new because of the locked BIOS / Boot menu.

How is it possible that such an massive bug that can lead to hardware fail is still not fixed?! @tuxlinux said that this issue persits since 2012.

When there is a solution to enter BIOS or boot from USB again, i would be very thankful because if its not, i can only hope for warranty.

Sorry for bad grammatics, im german, english isnt my native language :slight_smile:

BootCurrent: 0003
Timeout: 0 seconds
BootOrder: 0003,0001,2001,2002,2003
Boot0000* Windows Boot Manager
Boot0001* HDD: KINGSTON RBUSNS8154P3128GJ1
Boot0003* Manjaro
Boot2001* EFI USB Device
Boot2003* EFI Network

Have you tried this?

It only needs an editor which is already there in grub rescue

I don’t know if this will work … in fact I would like to know if it does :slight_smile:

When you boot your system - hold down Shift key until you enter the grub menu.

In the grub menu you can both edit an entry E or you can use C to enter the console.

Press C and input fwsetup and press Enter

If this doesn’t work you can use the console with the solution from the topic you mention.

When you have gotten your firmware entries back - go into the firmware and disable EFI - then reboot with a Manjaro installer.

Then you can wipe the EFI partition and create another unformatted partition and flag it as bios-boot.

Then reinstall grub to the new unformatted partition.

1 Like

I cant do anything in grub rescue beside “ls” the only output i get is always unknown filesystem. I think its because my hdd is luks encrypted. When i boot without manjaro usb stick it asks for password on hd0,gpt2 and when i put the stick in the laptop want to decrypt hd1. that makes no sense ?!

Thats all i can see and i cant do much;

EDIT: Great, cant post links, cant post images. wow…

Anyway, since the ssd is encrypted i always get to the "attempting to decrypt master key…
ls command results in: (proc) (hd0) (hd0,gpt2) (hd0,gpt1)
grub rescue> _

Shift does nothing during boot, i always see this picture above. It seems that this is the famous EFI / GRUB bug that kills BIOS / EFI access…

If i try to enable the “enter firmware setup at next start” i always get the black screen with the white dash.

Have you tried to hold down Shift key when booting the system?

Then in the grub menu - press C to access console - which has more options than the rescue console.

You cannot target anything inside the encrypted container - unless you unlock it.

I am confused - the listing - this is from running your installed Manjaro?

If it is - then grub is working - and then I don’t understand why you keep saying the thing with grub rescue and why is there a Windows Boot Manager when you say it came without operating system?

I found a similar issue also with Acer Installing Manjaro and PopOs in Dual Boot with windows in Acer laptop breaks BIOS

It also looks like you have an EFI usb stick entry.

I tried to hold down shift when booting but all what happened was that the grub wants my password to decrypt my device. press esc results in grub rescue mode. i never seen a grub menu like you expect. thats very strange, because when i need to recover Manjaro one day because of a bad kernel or something i have a problem i think^^

I dont know how to react right with an encrypted system. Do i have to press C immediately after the decryption or is it not possible to stop the boot process after the password was entered?

Yeah, i dont know why there was a windows boot entry. seems that grub saved something that never was^^

I “solved” the problem by booting to manjaro, enter the kde partition program and wipe the EFI partition. to be sure i formatted it fat32 and did a reboot. So the laptop wasnt able to find the boot entries expected and tells me no OS installed. That was my chance to enter BIOS again.
I installed Windows temporary to do an BIOS update. After that i disabled quick boot and secure boot in BIOS and did an fresh manjaro install. I dont give up that easy! :smiley:

SO i have a completely fresh manjaro install right now, full drive luks encryption.
But i have the same thing as before. I cant enter BIOS when GRUB bootloader is installed. I placed a “backdoor” by allow the bootmenu when pressing F12, so in emergency i am able to boot from usb.

Its an Acer Swift Notebook from 2020, so pretty new. there must be an big issue between BIOS / UEFI and GRUB loader.


I think you are made of the right stuff - for using LInux :partying_face:

What you did here was exactly what I expected to be the result if you wiped the efi partition.

It has something to do with the efistub placed in $esp/EFI and one of many possible solutions was to remove the manjaro efistub - and possibly the windows stub as well

➜  ~ sudo tree /boot/efi/EFI      
├── boot
│   └── bootx64.efi
└── Manjaro
    └── grubx64.efi

Thank you postng the steps you used - which actually worked :tada: .

I will gather what info we have and work out a HowTo - to at least let others getting started on the troubleshooting process.

For your issue with unlocking the root there is a few commands - I have never tried them using GRUB console but one would think they will work.

cryptsetup open /dev/sdy1 /dev/mapper/cryptroot
mount /dev/mapper/cryptroot /mnt
1 Like

What a pesky bug. One can only speculate why this is so.

What is the exact model of the Acer Swift - I am very tempted to locate a device to experiment on.

From vairous reading and looking at how systemd-boot copies the efi stub - I have an idea.

If it solves nothing the we know - but as I don’t have the system - I have to ask for you to be the test :slight_smile:

Boot your Manjaro system - login and switch to root user

$ su -

Then proceed to create this folder - and it is important you write it as is - with upper case where denoted

# mkdir -p /boot/efi/EFI/BOOT

Then copy the boot loader from Manjaro to the folder

# cp /boot/efi/EFI/Manjaro/grubx64.efi /boot/efi/EFI/BOOT/BOOTX64.EFI

I suspect the firmware is hardcoded to look for a loader with name and location as


The exact Model is “Acer Swift 1 (SF114-32-P4YN) 14” Full-HD IPS, Intel Pentium N5030, 8GB DDR4, 128GB SSD. Modelname : Swift 1 SF114-32 Productnumber: NX.GXUEV.00H

It costs 449€ in germany with 19% tax already included, so its a cheap one but has keyboard backlight, full aluminium unibody and full hd display ips. :slight_smile:

I maybe try that experiment on some day, but at the moment im really happy with it and i dont want to crash it once more :smiley: My linux skills are poor that means if something goes wromg and my system did not boot anymore im lost^^ But i will keep that in mind when i have an experiment day someday! :stuck_out_tongue:

1 Like

As far as I know, some UEFI allow booting Manjaro even with Secure Boot enabled (yes, that speaks much of a quality of such firmwares, but that’s another story).
So, first try to enable it back and boot Manjaro. In case of no luck, before disabling Secure Boot again do a simple thing: set an Administrator or Supervisor (not sure how it’s called in Acer UEFI) password in BIOS. I’m talking about a popup that asks for your password when one’s trying to get into the BIOS, a thing that prevents an authorized access to the entire UEFI settings. This is what was necessary on my machine in order to disable SB, and that’s a quite common requirement. After that, you’ll probably will be able to get to UEFI settings as you expected.

Yes you can use this Laptop with Linux and secure boot enabled. you have to disable it first, then install what you want and when the laptop boots from internal disk you can go back to bios and set secure boot on ( i cant, this is the reason of this thread :wink: ). you have to select the xxx.efi file located on the internal disk and you up to go. that means on the other hand that you cant boot anythin else whats not signated. when secure boot is enabled you cant even install windows from an usb stick, because bios say that its not signed. I dont know what acer thought on it, i know people who send the notbook back because they werent able to install anything on it because of “secure” boot :smiley:

Yes I understand your situation. However, you haven’t clarified if you tried again with setting Supervisor password first.

The problem is on manjaros side. I installed ubuntu and pop os for testing and i have zero problems to enter bios. i dont know whats wrong with the boot config here but its not a “linux thing”

I found this thread after quite a bit of searching. My problem was that I had an SSD with an encrypted Manjaro but didn’t know how to access the bios to boot from USB or another disk. The solution is simple:

Hold shift after you enter your password and get the “Slot open” message. This gives access to a few options which includes a UEFI boot mode. I’m used to holding delete, F12 etc. after boot but an encrypted disk is new to me. Hopefully this helps someone else.