After cleaning up pacman, Manjaro doesn't start anymore

Luckily those times are over and that bug should be fixed now, see Bug `manjaro-chroot -a` (#312) · Issues · Tools / development-tools / manjaro-tools · GitLab and [util-mount] fix chroot -a (204ae900) · Commits · Tools / development-tools / manjaro-tools · GitLab

1 Like

@freggel.doe, that’s very nice to hear, nevertheless it will take a while until all the rescue USB sticks carry this, at the moment it seems just to reach unstable. :turtle:

@ElPhysico, it would be probably easier for a gnome user to help you, as some of the packages you have removed seem not ot be in the repos I can see (e.g. electron4). When reinstalling, packages which have been installed as dependency previously then they should be reinstalled as depency again or at least this must be fixed, afterwards.

Some good tips how to fix this are given in this link:
https://wiki.archlinux.org/index.php/Pacman/Restore_local_database

:man_shrugging:

2 Likes

I really appreciate your time, help, and effort Wollie. I would have liked to test if reinstalling alone would have fixed the problem but it seems a fresh installation is the easiest solution right now.

2 Likes

Perhaps this is somehow useful? Copy&Paste from Manjaro’s Wiki:

Dealing with Orphaned Packages

To check to see if there any orphaned packages(packages which are no longer needed) installed you can use:

pamac list -o

To remove all orphans use the command:

pamac remove -o

Cleaning the Cache

When pamac installs packages, it keeps a copy of all the old packages you have downloaded. This cache can be very useful if you have to install older packages in an emergency. However, left unchecked, this cache will grow very large over time.

Otherwise, to clear the cache completely, enter the following command (and use with care):

pamac clean

A safer way to remove old package cache files is to remove all packages except for the latest three package versions using:

pamac clean --keep 3

2 Likes

I think this is what is known as an “off by one error” and it is very funny that it is in a low-level system recovery tool!
:joy:

To be fair … the tool (and bug) is from an old dev that left the project.
Also … most of us dont need to use tools like that … when I did (my own fault) a while ago … I fixed it.
Which prompted a better fix. And now its fixed. yay.

1 Like

As a future advice Bleachbit will help clean more garbage, like logs, thumbnails, user’s cache files etc. Sudo bleachbit cleans even further system logs, unused languages, the tmpfs, etc.

And when used incorrectly will bust your system.
But sure … go ahead and use sudo with it blindly :crazy_face:

2 Likes

Hmm, it never busted mine :stuck_out_tongue: I just don’t tick the Deep Scan stuff and it’s fine.

But yeah for a beginner I’d guess staying away from sudo for a while is better

Probably good.
Beyond that … theres other little commands or utilities to accomplish it.
Old wisdom says just avoid bleachbit … but I have heard more than once its less destructive or maybe even safe now, as long as you avoid a couple options.

2 Likes

For now I just increased the disk space for my Manjaro installation and I will stick with cleaning the cache only since I’ve learned that orphaned packages apparently don’t occupy too much space and you can just leave them be.

But thanks for all your input and recommendations. It seems for some things I need to use sudo such as installing new packages, but I will be more thoughtful in the future about using commands I don’t know or understand.

2 Likes

What is really weird though, I have a fresh new installation of Manjaro now and yesterday it was working and I didn’t change anything with it, only did 2 recommended updates and now today, it seems I have the same problem again, after selecting Manjaro in the grub screen, it gets stuck with the Dell-logo screen. So I assume there must be a problem with one of those 2 updates? Right now I need to participate in meetings so I cannot investigate but as soon as I have time, I will see if I can undo those two updates and get it to boot again.

I also found this:

So in the end, it might just be a random incident, maybe there was a Windows update that is now causing trouble. I might try this “changing the kernel” but not sure how exactly to do it, trying to figute it out.

Update: This answer in the post I linked above has helped me. Now many restarts, also booting into Windows and back into Manjaro, have worked fine.

Also, I checked before what haveged is and even though I don’t know how entropy and random number generators affect the booting process, it has helped and I hope the system keeps working for a long time now. Gotta get into that backup strategy next.

2 Likes

I have run into this issue after changing the kernel to 5.8. I recently did a fresh manjaro install on 5.8 as well and this is the default behavior for me out of the box.

Alt+F2 and Alt+F1 always works and gets me to my login screen. I don’t know what 5.8 is doing different from 5.4.

I did try the haveged method before,

sudo pacman -Syyu haveged
sudo systemctl enable haveged --now

but the issue persisted for me.

I am going to try haveged again today, maybe itll work on my fresh install.

I still wouldn’t trust a non-distro-and-DE-specific tool such as this. Threre are some differences between filesystems & directories on different distros plus config. file & maybe directory differences between desktop environments even on the same distro.

Too many people have gotten into trouble using such utilities. :wink:

Good luck! If you find out more, please let me know!