Manjaro hangs on Dell logo during boot

I’ve been running Manjaro for more than a year now, all of the sudden when I boot into it I get stuck on Dell logo and all I can do is restart. Sometimes I can successfully boot after restart, but lately it takes me 5 or more tries to boot successfully. I’ve seen some solutions for this on the web, but they are mostly some steps to try, it seems that it has to do with video driver, but I wanted to be sure of the steps since this is my work machine.

Edit: I am also running Windows 10 on this machine and I can boot into it successfully every time.

The randomness of boots succeeding and not succeeding sounds more like a problem with low entropy to me. If you have the system up and running now, then I would advise you to install haveged. It’s a random number generator that will increase the entropy your CPU generates at boot time. :arrow_down:

sudo pacman -Syyu haveged
sudo systemctl enable haveged --now

Thanks.

Interesting thing is that this happens only when I boot into Manjaro. I am also running Windows on it and I can boot into it fine every time.

Well, I can’t comment on that because I don’t do Windows. But I suspect that Windows doesn’t rely on the same mechanism for generating entropy. Maybe it doesn’t generate any entropy at boot time, or maybe it has its own random number generator. :man_shrugging:

Either way, have you tried it now, and does it work?

No. Installed havegd, rebooted and can’t boot now just as before.

Well, it was worth a try. :frowning_man:

This is crazy, tried now on 5 times and it booted it. May be someone can give definite answer, this is very annoying.

Well, maybe it was the entropy after all? :smiley:

1 Like

LOL, I don’t want to it restart now, have to do some work :slight_smile:

Well, if you have the time later, then you can try again, and if it works, then we’ll know. :slight_smile:

Will do, but if it was supposed to work, wouldn’t it have worked on first try? It’s not like cranking and engine I hope

Logic suggests that it should indeed have worked the first time. I have no explanation for why it didn’t. :man_shrugging:

Well at least it’s consistent. I had to restart again and it booted on 4th time. Not sure if it means anything.

When the machine does boot up:

  • check journal for errors from previous failed boots
  • disable grub silent boot
    • edit /etc/default/grub
    • remove quiet from GRUB_CMDLINE_LINUX_DEFAULT
    • update-grub to re-generate grub.cfg

This should allow you to check messages on next (failing?) boot,

1 Like

Hello,

Question, have you installed anything lately that after this problem started. Also have you check your logs in /var/log to see if there is something that may be causing the delay in booting?

When it comes to windows, until you install the proprietary drivers, it uses a generic video driver. Also windows uses virt drivers until you put the proprietary ones on the system which is why windows works, it really never touches bare metal until all manufacturer drivers are installed.

I have the same issue, except:

  1. I had manjaro installed for just a few weeks before it started happening (a few days ago)
  2. I’m using gnome
  3. I am only using manjaro. I don’t have dual boot
  4. I have to restart the laptop 10 or more times before I get to the login screen
  5. I can consistently open grub and see the manjaro entry. But once I select it the dell logo flashes 3 times and then gets stuck

I will try to remove quiet from grub and after work I’ll see if that gives me any useful information.

This is Xorg.0.log in /var/log, the only readable one. The other one is Calamares.log, not sure if it’s relevant, sorry I can’t post links for some reason - pastebin com/raw/9cY18Ztm

I found a temporary solution:

after removing quiet from grub I saw that there was no error reported: all steps were passing.
The last step before the booting stopped were either
Started TLP system startup/shutdown
or
Started CUPS scheduler

Thanks to this reddit post I found out that once it’s stuck there if I press ctrl-F2 and then ctrl-F1 I can get to the manjaro login screen.

I then tried to upgrade the kernel from version 5.7 to 5.8 but that didn’t solve the issue. I wasn’t able to downgrade to 5.4 (I can’t find out how to switch kernel: in grub I don’t see the different versions listed) so I can’t say about it.

1 Like

Does this help? :arrow_down:

Or this? :arrow_down:

1 Like

Ok finally installing kernel 5.4 (latest LTS) and removing 5.7 and 5.8 solved the issue.

I used
mhwd-kernel -li
and then
sudo mhwd-kernel -i linux54 rmc
after I made sure I only had 5.8 installed and running.

2 Likes