After an update I can no longer boot into my computer

Hello. I have a Manjaro system running on kernel 5.4. It is an EFI system.

Today after a few updates, my system is currently booting to a black screen and nothing more. I have booted from a Live USB and ran

manjaro-chroot -a

After the command completed I tried running mkinitcpio -P to fix it, but I get this:

Building image from preset: /etc/mkinitcpio.d/linux54.preset: ...
ERROR: '/lib/modules/5.4.89-1-MANJARO' is not a valid kernel module directory

The directory /etc/mkinitcpio.d has a bunch of .pacsave files and one linux54.preset file. Contents of this file are:

# mkinitcpio preset file for the 'linux54' package


PRESETS=('default' 'fallback')


fallback_options="-S autodetect"

The contents of /lib/modules are:


mhwd-kernel -li says:

Currently running: 5.9.16-1-MANJARO (linux59)
The following kernels are installed in your system:
    * linux54

mhwd-kernel -i linux54 gives me an error no targets specified

I am stuck and I don’t know what else to try. Please advise.

Hi @lixoman100, and welcome!

It seems something is messed up with you kernel. It it recommended to always keep 2 kernels installed:

  • One to use and play with daily; and
  • one as backup in the case of the other one failing/giving problems. As is happening here.

My recommendation is to boot into the live ISO environment. Then reinstall the kernels, as you tried there, but a bit differently than you tried:

  1. Once you have successfully booted into the live ISO environment, open a terminal and enter the chroot environment, as previously done using manjaro-chroot -a.
  2. As you know, if success you are now root on your installation, and should be very careful. Now, I recommend installing a different kernel, 5.10 for example, as this is set to be the next LTS version:
mhwd -i linux510
  1. If successful, reboot.

Once you have rebooted and everything’s working again, you can install another kernel as backup and/or troubleshoot how to reinstall 5.4.

Hope this helps!

Thanks for the answer.

mhwd -i linux510 gives me the error invalid use of option: -i/--install

mhwd-kernel -i linux510 gives me the error error: no targets specified after “synchronizing package databases”.

Any other suggestions?

That was my mistake, my apologies. You were right in adding -kernel to the command.

But let’s try updating the database first. From within the chroot environment, do:

pacman -Syyyu

Along with any software from the repositories, this should update the package database, which is what we’re after. Then try

sudo mhwd-kernel -li

again, to see what kernels are installed and also try:

sudo mhwd-kernel -l

to get a list of available kernels.

(You’ll probably have notice and wondered about the sudo prefix, seeing as we’re already root, but my opinion is “rather safe than sorry” and it hasn’t let me down yet.)

You can then try installing kernel 5.10 again, as previously advised:

sudo mhwd-kernel -i linux510

and go from there.

Also see How to remove a "ghost-kernel"?

Hope this helps! If not, I’m fresh out of ideas and won’t be long here anyway, before I’ve got to be off.

pacman -Syyyu
 there is nothing to do
mhwd-kernel -li
Currently running: 5.9.16-1-MANJARO (linux59)
The following kernels are installed in your system:
    * linux54
sudo mhwd-kernel -i linux510
error: no targets specified

OK, with that, I’m officially out of ideas, but check this out:

Also this:

Sounds remarkably like your situation!

I was unable to do anything with the issue so I ended up reinstalling. I really didn’t want to because I had some software that took a long time to setup, but luckily I had /home on a separate partition and was able to recover 95% of what I had.

Thanks for the assistance anyway :+1:

I know the feeling all too well, and I’m glad you’re up and running again. :grinning:

This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.