After a recent update, KDE is constantly redrawing? and glitching

So recently I updated(somewhere over 200 packages). Tuesday I restart plasma since the plasmashell process was consuming over 1GB of memory. Ever since this restart KDE is glitchy at best and unusable at worst.

I have a recording(which I apperently can’t link to here) to try to show what’s happening. If I had to describe it things show up out of scale, then correct, text appears as some icons disappear, icons disappear, the whole process repeats. This is with the task bar, kde menu, settings application, etc. It doesn’t appear to affect any normal application such as chrome, ksysguard, konsole, dolphin, etc.

Also along with this, some apps(such as manjaro hello), nolonger theme correctly, and Konsole somehow got set to the system’s default of Noto Sans.

I assume because of the repeating patterns something is repeatedly crashing and attempting to reload, but I’m unable to determine what from. Additionally, I created a fresh user and it has the same issue. So the issue is not with my user’s config.

Is this the kind of issue you encounter ?
https:…imgur.com/X5cXJm7
(replace … per // ofc)

Exactly

https:…bit.ly/3kuLX2G

I have the same issue or at least similar. After seeing movie I have worse ^_^…

Displaying content is stable but screen blinks and moves to right (that bottom right clock is moved to left side of screen).

and typing on keyboard is intensifying effect of blinking…maybe some issue with driver? or kernel?

Here is a little fix, waiting for manjaro team to release last mesa version.

wget https://archive.archlinux.org/packages/m/mesa/mesa-20.1.8-1-x86_64.pkg.tar.zst
sudo pacman -U mesa-20.1.8-1-x86_64.pkg.tar.zst

Hope that will help you too.
Have fun :slight_smile:

That followed by:
kquitapp5 plasmashell && kstart5 plasmashell

No more issues. Thanks. Now I can actually get work done.

1 Like

Thx. Seems to help. After reboot screen is stable.

edit: After second reboot the issue is back. So maybe it is not the same issue as OP

Uhm…
@Alexis @Ruptotus @mvanorder
Dont do that. That package is an old one, and behind the current in the repos version.

All branches are ahead of that version … at 20.2.1-1
(Stable Branch was on 20.1.8-1 until recently … so your system was not current)

All of you please make sure to fully update your systems … as it appears you were not before, and may further now be in a partial-upgrade state.

sudo pacman-mirrors -f && sudo pacman -Syyu

I am fully upgraded. Before update there was warning about conflicts but i ignored it (shame on me)…

This is what it looks like:
https:…drive.google.com/file/d/16ZcwGr-CBdPi_Vyyj7GeqlpqXju0D5J9/view?usp=sharing

You arent with that version of mesa above.
Just humor me and run the command so we can be sure. :wink:

no worries i actually did run
sudo pacman-mirrors -f && sudo pacman -Syyu
and am upgraded :slight_smile: and rebooted

OK … lets start with the basics then …


(please return inxi -Fazy)

Hi cscs,

As I mentionned, other comments just told that the last stable manjaro update was problematic when Manjaro was virtualized under VMware Workstation.
I just tried to apply the update as you mentionned (just to test if I was doing something wrong) but mesa 20.2.1 is still buggy in the manjaro repositories.
(I let you check the GIFs @Ruptotus and I sent).
Issue is solved by this commit: winsys/svga: fix display corruption after surface_init (f41848a9) · Commits · Mesa / mesa · GitLab
But I’m unable to use KDE when using mesa 20.2.1 (and that’s why I reverted the version :))
In case that help you, here is inxi -Fazy command run when mesa is latest version. System: Kernel: 5.9.3-1-MANJARO x86_64 bits: 64 compiler: gcc v: 10.2.0 p - Pastebin.com

2 Likes

I see. I thought you were using an earlier version and were trying to ‘force upgrade’ to 20.1
If it is a 20.2 regression then that makes more sense.

Ok. maybe I make another thread as my issue is different…

I hadn’t mentioned, but I am running a VM on VMware Fusion 15(I can’t stand Mac OS, but it’s the only way to get a good i7 form work).

No at all, I prefer to have the packages always up-to-date and that’s why keeping mesa at version 20.1.8 isn’t something I like.
It’s why I suggested @mvanorder to revert the update for mesa as there is a known issue about it behavior in 20.2.1.

Dunno if you can do something about mesa last version as they mentionned that they pushed fix to 20.2.1 on their repositories.

OK we have some eyes on it now. Not sure what our course of action is just yet, but the team knows.

If that can help, installing mesa20.2.1-1 from Index of /packages/m/mesa/ is working well.