Zsh prompt broken after this week update

I updated yesterday and after that my zsh prompt looks like this:

_p9k_init_params:72: character not in range                                                                                                                                                                        

My .zshrc is just the default:

# Use powerline
# Source manjaro-zsh-configuration
if [[ -e /usr/share/zsh/manjaro-zsh-config ]]; then
  source /usr/share/zsh/manjaro-zsh-config
# Use manjaro zsh prompt
if [[ -e /usr/share/zsh/manjaro-zsh-prompt ]]; then
  source /usr/share/zsh/manjaro-zsh-prompt

Use this command in the terminal
sudo echo en_US.UTF-8 UTF-8 >> /etc/locale.gen && sudo locale-gen

edit by moderator (modified pipe to append to locale.gen instead of overwriting)

1 Like

Thanks! This solved the issue.

1 Like

2 posts were split to a new topic: Zsh prompt problem/error after update

Hi mvaled78,

No need to edit the title to include [Solved]: the Solution is enough for our forum software to mark your solution as solved.

(Not only Manjaro itself it to-notch, but our forum software is too!


This topic was automatically closed 15 days after the last reply. New replies are no longer allowed.