[Stable Update] 2021-02-09 - Kernels, Gnome 40-Alpha, KDE Apps 20.12.2, Systemd, Mesa, LibreOffice

Hello community,

Another stable branch update with some usual updates for you.


Find out what is new in LibreOffice 7.1! #stayhome, #staysafe, #stayhealthy

  • Most of the Kernels go updated
  • A lot of effort went into Gnome 40
  • Some Deepin packages got updated
  • Firefox and Thunderbird got renewed: FF 85.0.1, TB 78.7.0
  • Systemd is now at 247.3
  • Nvidia driver got updated to 460.39
  • ZFS is now updated to 2.0.2
  • A new point-release of KDE-Apps 20.12 landed in our repos
  • AMDVLK is now at 2021.Q1.2
  • LibreOffice got renewed to 7.0.4 and 7.1.0
  • Mesa is now at 20.3.4
  • Most of LibRetro got renewed
  • Another bug-fix release of Gstreamer
  • Virtualbox is now at 6.1.18
  • Other regular upstream updates including python and haskell

Get our latest daily developer images now from Github: Plasma, Gnome, XFCE


Our current supported kernels

  • linux44 4.4.255
  • linux49 4.9.255
  • linux414 4.14.219
  • linux419 4.19.173
  • linux54 5.4.95
  • linux59 5.9.16 [EOL]
  • linux510 5.10.13
  • linux511 5.11-rc6
  • linux54-rt 5.4.93_rt51
  • linux59-rt 5.9.1_rt19

Packages Changes (Sat Feb 6 10:58:24 CET 2021)

  • stable community x86_64: 2056 new and 1933 removed package(s)
  • stable core x86_64: 77 new and 78 removed package(s)
  • stable extra x86_64: 1098 new and 1169 removed package(s)
  • stable multilib x86_64: 52 new and 52 removed package(s)

A detailed list of all package changes can be found here.

  • No issue, everything went smoothly
  • Yes there was an issue. I was able to resolve it myself.(Please post your solution)
  • Yes i am currently experiencing an issue due to the update. (Please post about it)

0 voters

Check if your mirror has already synced:

25 Likes

Known issues and solutions

For TL3s and up: This is a wiki post; please edit as necessary.
Please, consider subscribing to the Stable Updates Announcements RSS feed

New issues:

  • Apache error:  httpd: Syntax error on line XXX of /etc/httpd/conf/httpd.conf: Cannot load modules/libphp7.so into server

    Please click the ► at the beginning of this line to view this solution

    Full error message:

    MMM DD HH:MM:SS ServerName httpd[45914]: httpd: Syntax error on line XXX of /etc/httpd/conf/httpd.conf: Cannot load modules/libphp7.so into server: /etc/httpd/modules/libphp7.so: cannot open shared object file: No such file or directory
    MMM DD HH:MM:SS ServerName systemd[1]: httpd.service: Control process exited, code=exited, status=1/FAILURE
    MMM DD HH:MM:SS ServerName systemd[1]: httpd.service: Failed with result ‘exit-code’.‘exit-code’.
    
    • Execute:

      sudo nano --backup  /etc/httpd/httpd.conf
      
    • change the following lines:

      LoadModule php7_module modules/libphp7.so
      Include conf/extra/php7_module.conf
      

      to:

      LoadModule php_module modules/libphp.so
      Include conf/extra/php_module.conf
      

      Respectively! (They are not necessarily next to one another!)

    • Save (Ctrl+X Enter Y)

    • Restart Apache (or reboot if you don’t know how or to to get that Window$ feeling again)

  • Pulseeffects stopped working

    Please click the ► at the beginning of this line to view this solution

    Execute:

    pamac install manjaro-pipewire
    pamac install gst-plugin-pipewire
    
  • GlibC 2.33-3 update might mess-up your locales

    Please click the ► at the beginning of this line to view this solution
    • go to Manjaro Settings,
    • add your language back in the regional settings,
    • Log off / log in

    and everything should be back to normal (even the Terminal).

    If it isn’t, execute sudo locale-gen and log off and log back in.

  • gnome-shell-extension-desktop-icons  cannot be updated

    "Please click the ► at the beginning of this line to view this solution
    error: failed to commit transaction (conflicting files)
    gnome-shell-extension-desktop-icons: /usr/share/gnome-shell/extensions/desktop-icons@csoriano/schemas/gschemas.compiled exists in filesystem
    Errors occurred, no packages were upgraded.
    

    please run the following command:

    sudo pacman -S gnome-shell-extension-desktop-icons --overwrite /usr/share/gnome-shell/extensions/\*
    

    and the issue will be resolved.

  • I’m still running on nvidia-450 and I want to recompile the 450 driver (Kernel 5.4 LTS):

    Please click the ► at the beginning of this line to view this solution
    1. Add the line IgnorePkg = lib32-nvidia-utils lib32-opencl-nvidia mhwd-nvidia opencl-nvidia in file /etc/pacman.conf

    2. Upgrade your packages (using the pamac GUI) or:

      pamac upgrade
      
    3. Reboot on kernel 5.4 (see Note 1 below on how to do this)

    4. Boot will be stuck because no driver has been found, just open a console with Ctrl+Alt+F2

    5. First read Note 2 below, then get the sources for your driver (in my case, 450xx):

      git clone https://gitlab.manjaro.org/packages/extra/nvidia-450xx-utils.git
      git clone https://gitlab.manjaro.org/packages/multilib/lib32-nvidia-450xx-utils.git
      git clone https://gitlab.manjaro.org/packages/extra/linux54-extramodules/nvidia-450xx.git
      
    6. Compile the driver (if you get an error, see Note 3):

      cd nvidia-450xx-utils && makepkg -si
      cd ../lib32-nvidia-450xx-utils && makepkg -si
      cd ../nvidia-450xx && makepkg -sif
      
    7. Reboot on kernel 5.4 (see Note 1 below on how to do this)

    Now, everything is working again! To check if you’re indeed running kernel Linux 5.4, you can run uname --kernel-release in a console, and to check if you’re running the driver you just compiled, you can run inxi --graphics --display OR nvidia-smi

    Note 1: to choose which kernel to boot on, you need to edit those two lines in /etc/default/grub to match those (5 as in 5 seconds to make your choice on the menu, you can put whatever):

      GRUB_TIMEOUT=5
      GRUB_TIMEOUT_STYLE=menu
    

    Then, run sudo update-grub. When booting, you’ll now see a menu with all installed kernels so you can choose which one to use for this session.

    Then finally execute the reboot command:

      sudo reboot 
    

    Note 2: During step 5 and 6: If you already have compiled the nvidia driver during last update, you can skip cloning nvidia-450xx-utils and lib32-nvidia-450xx-utils (you already have the sources, you just need to compile them again), but I suggest you remove your older nvidia-450xx folder (rm -rf nvidia-450xx) and clone it again before compiling this one, otherwise you will get an error like “folder already exists” when trying to compile.

    Note 3: When trying to compile the driver, you might get an error with two nvidia packages creating conflicts (I think lib32-nvidia-utils was one of them, I don’t remember the other one). To fix that, just uninstall those packages with pamac remove <package>.

  • I’m still running on nvidia-450 and I want to upgrade to 460 (Kernel 5.10):

    Please click the ► at the beginning of this line to view this solution
    • Print this page so you have it as a reference while in TTY2

    • Log off

    • Switch to TTY2 by pressing Ctrl+Alt+F2

    • Log in there

    • Execute:

      pamac remove nvidia-450xx-utils
      #you will get some warnings about optional components needing this: 
      #  no worries, you'll install 460 in the next line
      sudo mhwd --install pci video-nvidia
      sudo reboot
      

Recent Arch Linux news:

PHP 8.0 and PHP 7 legacy packages are available

PHP 8.0 and PHP 7 legacy packages are available

2021-01-28 - Pierre Schmitz

The php package has been updated to version 8.0. Please refer to the upstream migration guide. As some applications are not compatible with PHP 8 yet we provide a php7 package which can be installed alongside version 8. Packages that depend on PHP reflect this update and will require php7 if needed. You might need to update your configuration accordingly. PHP 7 binaries and configuration have the “7” suffix:

  • /usr/bin/php → /usr/bin/php7
  • /etc/php → /etc/php7
  • /usr/bin/php-fpm → /usr/bin/php-fpm7
  • /usr/lib/systemd/system/php-fpm.service → /usr/lib/systemd/system/php-fpm7.service
  • /run/php-fpm → /run/php-fpm7

We also provide third party modules compiled for PHP 7:

Note that support for php7 will be limited and likely be dropped in about a year depending on how soon the majority of applications will be compatible with version 8.

https://archlinux.org/news/php-80-and-php-7-legacy-packages-are-available/

Chromium losing Sync support in early March

Chromium losing Sync support in early March

2021-02-03 - Evangelos Foutras

Google has announced that they are going to block everything but Chrome from accessing certain Google features (like Chrome sync) starting on March 15. This decision by Google is going to affect Arch’s chromium package a bit earlier, on March 2, when Chromium 89 gets released.

We know for sure that data syncing will stop working (passwords, bookmarks, etc.). Other features such as geolocation or enhanced spell check might continue to function for a bit longer. Extensions integrating with Google Drive might misbehave and LibreOffice will lose access to documents stored there.

Other distros such as openSUSE and Fedora have already removed the soon-to-be-limited API keys from their Chromium 88 packages. Fedora’s advisory provides a great deal of perspective on this and I also found this Hackaday post to be quite informative.

https://archlinux.org/news/chromium-losing-sync-support-in-early-march/


Older Issues

Please click the ► at the beginning of this line to view the older issues

Nvidia card owners

  • We simplified nVidia driver installation. This means we dropped legacy drivers.
    • We recommend to switch over to Nouveau drivers if your card is mentioned here and the feature you need is not in red TO DO here for your particular card.

    • If you however still need proprietary drivers, you may want to execute the following to ensure all parts of the nVidia drivers get installed properly:

      sudo mhwd -a pci nonfree 0300
      
      If proprietary drivers don't fix everything, please click the ► at the beginning of this line to view more info
      1. try installing kernel 5.4 LTS (Long Term Support)
      2. If that doesn’t fix it, take a full system backup, go to a console using Ctrl+Alt+F2 and:
      • Backup /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • remove all nVidia related drivers and applications:

        pacman --remove nvidia*
        
      • Note which applications are being removed and keep them handy in a list

      • Install the driver first:

        mhwd --install video-hybrid-XXX-nvidia-prime
        

        (Where XXX is amd or intel if you have hybrid graphics or the whole thing is video-nvidia if you’re on an nVidia-only system)

      • reboot and see if you at least get a screen.

      • Install all the other applications from your handy list that you still need one by one.

      • Restore /etc/X11/mhwd.d/nvidia.conf if you ever edited that manually

      • If that wouldn’t solve the issue open a new issue here referring to this update and posting at a minimum the full output of:

        inxi --admin --verbosity=7 --filter --no-host --width
        

      If you however still have issues with your Nvidia card, you may open a new thread in our forum: https://forum.manjaro.org/c/support/Graphic-Cards/33 or look at our tutorial on compiling old Nvidia drivers.

For AMD GPU users having a black screen with kernel 5.10

Please click the ► at the beginning of this line to view more info

Due to a bug in the AMD drivers, please try the following first:

For GRUB:

  1. Open a terminal or a TTY
  2. Open /etc/default/grub in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: GRUB_CMDLINE_LINUX_DEFAULT="
  4. Add amdgpu.dc=0
  5. Save
  6. Execute sudo update-grub and reboot

For systemd-boot:

  1. Open a terminal or a TTY
  2. Open /boot/loader/entries/manjarolinux5.10.conf in your favourite CLI editor (nano vi, emacs`)
  3. Add amdgpu.dc=0 to the end of the line options
  4. Save & reboot

For rEFInd:

  1. Open a terminal or a TTY
  2. Open /boot/refind_linux.conf in your favourite CLI editor (nano vi, emacs`)
  3. Find the line: "Boot using default options" "root=
  4. Add amdgpu.dc=0
  5. Save & reboot

Possible 2 Min delay on shutdown with Gnome

Please click the ► at the beginning of this line to view more info
  • If you got the problem with shutdown delay (about 2min) on Gnome, here is a workaround:
    • Edit /usr/lib/systemd/user/gnome-session-restart-dbus.service in your favourite editor as root and add Slice=-.slice as a line all by itself like this:

      [Service]
      Type=notify
      Slice=-.slice
      ExecStart=/usr/lib/gnome-session-ctl --restart-dbus
      
    • Click this link For more information

Touchpad on a ThinkPad stops working

  • Restart again, please.

You get [PKGNAME] warning: directory permissions differ on [Directory name]

followed by:

Filesystem: NNN package MMM

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod MMM DirectoryName
    

Where obviously MMM is the second number you see (the correct one)

  • The explanation:
    Your package expects the security permissions to be MMM but your system is set to NNN. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.

Systemd error message: .slice: Failed to migrate controller cgroups

If you have a similar error message like this:

systemd[1004]: -.slice: Failed to migrate controller cgroups from /user.slice/user-1000.slice/user@1000.service, ignoring: Permission denied

… you may need to add this Grub parameter to your /etc/default/grub file in line GRUB_CMDLINE_LINUX_DEFAULT: systemd.unified_cgroup_hierarchy=true. To update your grub menu, call: sudo update-grub. For more information on that issue, see also Arch Forum.


CUPS update need manual intervention

After you update your system, update your systemd services like this:

sudo systemctl disable --now org.cups.cupsd.socket
sudo systemctl disable --now org.cups.cupsd.service
sudo systemctl disable --now org.cups.cupsd.path
sudo systemctl enable --now cups.service
sudo systemctl enable --now cups.socket
sudo systemctl enable --now cups.path

[Edit according to @banjo’s advice.]

xf86-video-intel already exists in filesystem errors

Please click the ► at the beginning of this line to view this solution

If you get something like this:

error: failed to commit transaction (conflicting files)
xf86-video-intel: /usr/bin/intel-virtual-output exists in filesystem
xf86-video-intel: /usr/lib/libI810XvMC.so exists in filesystem
...
xf86-video-intel: /usr/share/man/man4/intel.4.gz exists in filesystem
xf86-video-intel: /usr/share/polkit-1/actions/org.x.xf86-video-intel.backlight-helper.policy exists in filesystem
Errors occurred, no packages were upgraded.

Just delete the files that are in conflictand perform the upgrade again.

nvidia-450xx-utils and nvidia-440xx-utils are in conflict

Please click the ► at the beginning of this line to view this solution
  • If you get the following error message:

    resolving dependencies...
    looking for conflicting packages...
    :: nvidia-450xx-utils and nvidia-440xx-utils are in conflict (nvidia-libgl). Remove nvidia-440xx-utils? [y/N] y
    error: failed to prepare transaction (could not satisfy dependencies)
    :: unable to satisfy dependency 'nvidia-440xx-utils=440.100' required by linux54-nvidia-440xx
    :: removing nvidia-440xx-utils breaks dependency 'nvidia-440xx-utils=440.100' required by linux58-nvidia-440xx
    

Warning: do not reboot until this procedure tells you to starting from the next step!

  • Please note the exact nVidia driver you have running by executing:

    mhwd --listinstalled
    
  • Please note the kernel(s) you’ve got installed and remove anything 440-related, including CUDA by executing:

    pamac remove nvidia-440xx-utils linuxZZ-nvidia-440xx cuda nvtop
    

    where ZZ is/are the kernel version(s) you’re running.

  • Repeat for all the kernel versions you have

    How do I know which kernel versions I have?
    • execute ls /boot/linux*
    • any nulber after linux before the - (minus sign) are the kernel(s) you have installed
  • If you would have any other old nVidia drivers that you don’t need any more because your card is supported by the 450 series get rid of them as well.

  • now install the same family of 450 driver you had for the 440 driver, by executing:

    mhwd --install pci Your450Family
    

    where Your450Family is obviously one of video-hybrid-amd-nvidia-440xx-prime OR video-nvidia-440xx that you noted above

  • And finally:

    sudo reboot
    

If this would not have solved your issue, please open a new issue here and state that you followed this procedure already.


Warning: directory permissions differ on /var/lib/dhcpcd/

followed by:

filesystem: 700 package: 755

Please click the ► at the beginning of this line to view this solution
  • The solution:

    sudo chmod 755 /var/lib/dhcpcd/
    
  • The explanation:
    The DHCP Daemon expects the security permissions to be 755 but your system is set to 700. This is just a warning (today) but to ensure you remain up-to-date with the latest and greatest security rules it’s advised to execute the above command.


virtualbox NS_ERROR_FAILURE (0x80004005)

Please click the ► at the beginning of this line to view this solution
  • The solution:
  1. You need to add your user back into the virtualbox user group

    sudo usermod --append --groups vboxusers $USER
    

    (Change $USER to the correct user name if not for yourself)

  2. Upgrade the VirtualBox extension pack to the latest version by executing:

    pamac build virtualbox-ext-oracle
    

PAM and PAMBASE got updated, which might prevent you from login

Please click the ► at the beginning of this line to view more detailed information

Due to updates from pambase and pam you might take care about any .pacnew files in /etc/pam.d as for example pam_tally, pam_tally2 and pam_cracklib got deprecated. Read in the ArchWiki about managing those files.

Typical issue:

For recovery, it is enough to boot with kernel option “systemd.unit=rescue.target”, then proceed into /etc/pam.d and merge “system-auth” and “system-auth.pacnew”


Bad font rendering after freetype2 upgrade

Please click the ► at the beginning of this line to view more detailed information

There were some changes in the freetype2 version 2.10.3 which enable subpixel rendering.
This might look ugly without enabling lcdfilter at the same time.

You can create a symlink in /etc/fonts/conf.d/ to enable “lcddefault” as filter.

sudo ln -s /etc/fonts/conf.avail/11-lcdfilter-default.conf /etc/fonts/conf.d/

System takes a long time to boot

If you’ve got errors like Failed to start Network Manager Wait Online. you can try removing systemd from passwd and group in /etc/nsswitch.conf as described here
Update: If you can see the line
dbus-daemon[1453]: [system] Connection has not authenticated soon enough, closing it (auth_timeout=30000ms, elapsed: 45146ms)
in in your dbus log ( journalctl -b -u dbus ), the new/better workaround is to switch cups from service to socket as described here:
systemctl disable cups.service
systemctl enable cups.socket

I think I’ve some font problems

With the update of fontconfig some major rules how fonts get applied changed. Make sure that your system has ttf-dejavu installed. A more in depth explanation can be found here.

Gnome-shell-extension-pop-shell is currently incompatible with wayland

… and causes the system to freeze when the first window is tiled and can render it unbootable. Solution is a hard reset and disabling either pop shell or wayland. If the system becomes unbootable, use a live USB to edit /etc/gdm/custom.conf to disable wayland and reboot.

10 Likes

Updated without problems, KDE with kernel 5.4.

Thanks Manjaro Team.

1 Like

Update failed on Manjaro Gnome as the gnome-shell-extension-desktop-icons package could not be upgraded:

error: failed to commit transaction (conflicting files)
gnome-shell-extension-desktop-icons: /usr/share/gnome-shell/extensions/desktop-icons@csoriano/schemas/gschemas.compiled exists in filesystem
Errors occurred, no packages were upgraded.

Ran the following to resolve it:

sudo pacman -S gnome-shell-extension-desktop-icons --overwrite /usr/share/gnome-shell/extensions/\*

Update completed normally afterwards.

2 Likes

The update went fine on three computers:
1 * KDE (kernel 5.4 and 4.19) and 2 * XFCE (kernel 5.4 and 4.19, kernel 4.19 and 4.14).

On a single computer, kernel 4.19 is running and I need to reinstall grub with kernel 4.14 afterwards.

The KDE computer with Nvidia graphics card needs to be rebooted with “reboot” on console.

Thanks!

Updated without problems and working fine on KDE 5.20.5 with Kernel 5.10+. Thanks.

The update itself was fine, but since yesterday I am having trouble with the verification of (it seems) the main Archlinux/Manjaro PGP keys (Levente Polyak, Christian Hesse, Philip Mueller).

As a consequence, the database core, extra, community, multilib cannot be verified and updates via either pamac or pacman fail.

I managed to temporarily fix the issue by setting “SigLevel = Never” in /etc/pacman.conf.

With that change, I went twice through the troubleshooting procedure at Pacman troubleshooting - Manjaro
(the procedure fails with the default pacman configuration).

Apparently the process succeeds (I get no suspicious errors), but setting SigLevel back to the default level still brings all the previous issues.

I don’t have much bug reporting experience, so sorry for the possible lack of important information.

BTW: “the update was fine” of course was fine only with SigLevel set to Never

Updated one of my machines, Gnome and it was OK. So far got this error with gnome-terminal

me@manjaro Linux 5.10.13-2-MANJARO x86_64 20.2.1 Nibia
~ >>> gnome-terminal                                                  
# Error constructing proxy for org.gnome.Terminal:/org/gnome/Terminal/Factory0: Error calling StartServiceByName for org.gnome.Terminal: Timeout was reached

Will test later on others

2 Likes

Updated without problems -except PulseEffects, as expected. I removed it and now I am installing pulseeffects–legacy package.

1 Like

There appears to be a conflict with mpv and vlc with the update of the libplacebo package.

$ yay
:: Synchronizing package databases...
 core                        167.2 KiB  9.61 MiB/s 00:00 [------------------------------] 100%
 extra                      1983.8 KiB  15.4 MiB/s 00:00 [------------------------------] 100%
 community                     6.4 MiB  13.9 MiB/s 00:00 [------------------------------] 100%
 multilib                    181.3 KiB  0.00   B/s 00:00 [------------------------------] 100%
:: Starting full system upgrade...
resolving dependencies...
looking for conflicting packages...
error: failed to prepare transaction (could not satisfy dependencies)
:: installing libplacebo (3.104.0-1) breaks dependency 'libplacebo.so=72-64' required by mpv
error installing repo packages

$ sudo pacman -Rns libplacebo
checking dependencies...
error: failed to prepare transaction (could not satisfy dependencies)
:: removing libplacebo breaks dependency 'libplacebo' required by mpv
:: removing libplacebo breaks dependency 'libplacebo.so=72-64' required by mpv
:: removing libplacebo breaks dependency 'libplacebo' required by vlc

I could try uninstalling both mpv and vlc but then after updating I might not be able to install them back, considering there’s a dependency break.
How to proceed?

1 Like

Had an issue with my locale settings; the setting were gone.
Noticed it because my powerline10k prompt was not displaying unicode characters.

Fixed by:

  1. Manjaro Settings Manager
  2. Click [Add]
  3. Add desired locales
  4. Go to Detailed Settings
  5. Select desired Display Language and Format
  6. Click [Apply], Click [Quit]

Open a new terminal to see powerline10k prompt with unicode characters.

2 Likes

You do not block/ignore the upgrade of mpv, right? The latest version of mpv package should be compatible with the latest version of libplacebo package. On my side, I both have libplacebo 3.104.0-1 and mpv 1:0.33.0-4 which has on libplacebo.so=104.64 as one of its dependencies.

2 Likes

Just updated on Manjaro Gnome. I had a issue where the gnome terminal didn’t open. It did work before the update. I fixed it using this StackExchange answer.

3 Likes

Not a big deal really, but I got these new icons for Files and Terminal. icons Not sure if that is intentional or not but they look kinda out of place. Other than that the update went fine on Manjaro GNOME

3 Likes

System is now partly French and English (French before the update). Gnome languages list is empty. Terminal won’t open anymore.

Edit: just had to go to Manjaro Settings, add the French back in the regional settings, log back in and everything went back to normal (even the Terminal).

Thanks guys.

4 Likes

I’ve had locale issues in testing with a console solution.

  • Remove the least used one of them
  • update
  • re-install the one you removed.

If there would be an issue, create a new topic and ping me with the link. Worst I’m expecting is an additional symlink to be put in place.

:crossed_fingers:

Had a problem with opening all gnome applications and from checking journalctl -xe, it turned out that there was a problem with my locale configuration.
Solution:
1- uncomment en_US.UTF-9 from /etc/locale.gen
2- generate locale by this command locale-gen
3- add LANG=en_US.UTF-8 and LC_COLLATE=C to /etc/locale.conf
and that’s it. Everything worked.

1 Like

A post was split to a new topic: Powerdevil: “Charge thresholds not supported” with ddcutil 1.0.0

Papirus got updated and many icons got a new design.

Now as for if it is an improvement or not… that’s a different question. :upside_down_face:

3 Likes