Zooming in causes display to render incorrectly

I am visually impaired an I rely on zoom hovever when i reach zoom levels over 4x or 5x with a scale of 1.5 I experience weird behaviors.

  1. A diagonal split occours in the display sometimes showing double the same text or a black diagonal space .
  2. Text becomes condensed More taller then wider. (out of regular propotions).
  3. Cursor renders incorrectly. Assume a link the cursor appears to be placed right above the link as intented but, when i try to click the link no response follows. So, when i zoom out i find that cursor is placed few points to the right from where the link is.

It would be easier if i could show what i experience but, unfortunately I could not embed media here

Steps to Reproduce:

  1. Settings > Display Effects > Zoom. Turn on zoom
  2. Under zoom configuration set scale to 1.5. Howver the same issue occurs with the default sale of 1.2.
  3. move cursor arround. The diagonal split mostly seems to occur when cursor reaches center of the display

These issues seem to occur only after reaching certain zoom levels.

I used fedora a while ago and experienced the same issues.


As any Desktop Effect in KDE Plasma, zoom relies on Compositor settings. Make sure you have them like this:


The Compositor will have a bit different behavior depending on the GPU and drivers used. Pleas share from terminal inxi -Fazy

I just tried to replicate you issue on my end, and it did not happen.

I tried changing compositor settings like you suggested. I guess its bit better but havent resolved the issue.
System info:

  Kernel: 5.13.12-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-5.13-x86_64 
  root=UUID=de786bba-f13a-43d3-b81e-6973633c9c84 rw quiet apparmor=1 
  security=apparmor udev.log_priority=3 
  Desktop: KDE Plasma 5.22.4 tk: Qt 5.15.2 info: latte-dock wm: kwin_x11 vt: 1 
  dm: SDDM Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop Mobo: N/A model: N/A serial: <filter> 
  BIOS: American Megatrends v: 080015 date: 03/14/2012 
  Info: Dual Core model: Pentium E5500 bits: 64 type: MCP arch: Penryn 
  family: 6 model-id: 17 (23) stepping: A (10) microcode: A0B cache: L2: 2 MiB 
  flags: lm nx pae sse sse2 sse3 ssse3 vmx bogomips: 11179 
  Speed: 2794 MHz min/max: 1203/2803 MHz Core speeds (MHz): 1: 2794 2: 2794 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX disabled 
  Type: l1tf mitigation: PTE Inversion; VMX: EPT disabled 
  Type: mds 
  status: Vulnerable: Clear CPU buffers attempted, no microcode; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass status: Vulnerable 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 
  mitigation: Full generic retpoline, STIBP: disabled, RSB filling 
  Type: srbds status: Not affected 
  Type: tsx_async_abort status: Not affected 
  Device-1: Intel 4 Series Integrated Graphics driver: i915 v: kernel 
  bus-ID: 00:02.0 chip-ID: 8086:2e32 class-ID: 0300 
  Device-2: Microdia Defender G-Lens 2577 HD720p Camera type: USB 
  driver: snd-usb-audio,uvcvideo bus-ID: 1-4:4 chip-ID: 0c45:6341 
  class-ID: 0102 
  Display: x11 server: X.Org 1.20.13 compositor: kwin_x11 driver: 
  loaded: modesetting alternate: fbdev,vesa display-ID: :0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: VGA-1 res: 1920x1080 hz: 60 dpi: 94 size: 521x293mm (20.5x11.5") 
  diag: 598mm (23.5") 
  OpenGL: renderer: Mesa DRI Intel G41 (ELK) v: 2.1 Mesa 21.2.1 
  direct render: Yes 
  Device-1: Intel NM10/ICH7 Family High Definition Audio driver: snd_hda_intel 
  v: kernel bus-ID: 00:1b.0 chip-ID: 8086:27d8 class-ID: 0403 
  Device-2: Microdia Defender G-Lens 2577 HD720p Camera type: USB 
  driver: snd-usb-audio,uvcvideo bus-ID: 1-4:4 chip-ID: 0c45:6341 
  class-ID: 0102 
  Sound Server-1: ALSA v: k5.13.12-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.33 running: yes 
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 v: kernel 
  port: e800 bus-ID: 02:00.0 chip-ID: 10ec:8136 class-ID: 0200 
  IF: ens33 state: up speed: 100 Mbps duplex: full mac: <filter> 
  Local Storage: total: 465.76 GiB used: 21.57 GiB (4.6%) 
  SMART Message: Unable to run smartctl. Root privileges required. 
  ID-1: /dev/sda maj-min: 8:0 vendor: Seagate model: ST3500413AS 
  size: 465.76 GiB block-size: physical: 512 B logical: 512 B speed: <unknown> 
  type: HDD rpm: 7200 serial: <filter> rev: JC4B scheme: MBR 
  ID-1: / raw-size: 53.16 GiB size: 52.03 GiB (97.86%) used: 21.57 GiB (41.5%) 
  fs: ext4 dev: /dev/sda4 maj-min: 8:4 
  Kernel: swappiness: 60 (default) cache-pressure: 100 (default) 
  ID-1: swap-1 type: file size: 4 GiB used: 1.59 GiB (39.8%) priority: -2 
  file: /swapfile 
  System Temperatures: cpu: 62.0 C mobo: N/A 
  Fan Speeds (RPM): N/A 
  Processes: 223 Uptime: 3h 57m wakeups: 0 Memory: 3.71 GiB 
  used: 3.07 GiB (82.7%) Init: systemd v: 248 tool: systemctl Compilers: 
  gcc: 11.1.0 Packages: 1302 pacman: 1281 lib: 361 flatpak: 11 snap: 10 
  Shell: Zsh v: 5.8 running-in: yakuake inxi: 3.3.06 

:+1: Welcome to Manjaro! :+1:

  1. My dad’s visually impaired too and I’ve set his zoom settings to the following:

    and he does not experience the same effects you describe.
    Ctrl+Alt+Z zooms in under his cursor and Ctrl+Alt+Shift+Z zooms out
  2. Do you have a compelling reason to be on the 5.13 Stable Development kernel?
    If that’s just the default and you never changed anything, please read this:
    [HowTo] become a Manjaro power user when you're a wizard at Windows but a N00b at Manjaro / Linux
    and then install at a minimum Kernel 5.10 LTS and boot that.
    (If you need more help installing that, please shout out)
  3. As you seem to be new to the Manjaro ecosystem, please read the rest of that tutorial too for the bits you don’t know already (and a good laugh too) :grin:


Hey, Thanks for the Welcome. I am really enjoying Manjaro except for this little issue. I dont really understand why I am the only one having this issue. 6x zoom is my sweet spot where i could read comfortably but, i experience this issue exactly when i reach that point.

I tried installing 5.10 Kernel as you suggested and still experience the same. I wish i could show what i experience but, for some reason this forum is restricting me from sending media.

Like you said i am new to manjaro. Befor this I was using Fedora with Gnome for a while and had some similar issues in zoom there as well. however, I reported it and the bug was reproducable. Here I dont understand why. Might this be happening because of my old hardware?

Also a few years back i dont exactly remember when may be 2 to 4 years back. I was new to linux and installed Ubuntu with Gnome and had the same issue with diagonal split. However back then the issue was far worse and i couldn’t go above 2x zoom. So, I had to switch back to windows.
And now im here back in linux. Manjaro is really awesome with my hardware even in fedora i experienced lags and hangs sometimes but Manjaro works smoothly.

Also, Thanks for sharing your setup. For me i prefer Pointer to scale and mouse tracking to push i find it better that way.

Please read this:

Try kernel 5.4.

Maybe that’s what’s causing the issue? Could you try turning that off temporarily???

That’s as far as it goes answering your questions, but a few additional things I did for my dad:

  • Bought him a new 52" TV (as his condition is deteriorating)
  • Used his old 32" FHD TV to replace his 24" monitor
  • set it to HD resolution (1280x720)
  • still gave him the zoom option with the whole Ctrl+Alt+Z thing…

(maybe those tips will help you too)


This is my Desktop
After pressing zoom in shortcut 4 times i.e. 6x actual size
Top pannel with the same above mentioned zoom level
Zoomed in 1.5x more i.e. pressed zoom in shortcut once additionally. Note: I was actually placing my cursor in the center where the date and time is. But, seeing system tray instead and when zooming out i find my cursor positioned right where i wanted in the center on date and time.
Inside a Web page
Inside the same webpage after moving cursor slightly to the left. if i move cursor more i get a black screen.

That’s weird!

Does this also happen when you create a new user and log in there and only activate zoom and configure nothing else? (E.G. falcon-z2)


Yes, It even happened right from the start when i was installing Manjaro inside the live usb. I tried setting everything to default and all other combinations nothing resolves the issue the same thing occurs.
And before switching to manjaro i used Fedora’s KDE spin for a few days and had the same issue both in the live environment and after installing.

I also tried 5.4 Kernel like you suggested and experienced the same.

What’s the output of:

mhwd --listinstalled


I think i located the issue. In Compositor i switched Rendering backend from OpenGl to XRender and zoom works fine now. However, with xrender other relevent features like invert, blur under desktop effects are gone.
So, i guess the problem was with OpenGL.

nstalled PCI configs:
                  NAME               VERSION          FREEDRIVER           TYPE
           video-linux            2018.05.04                true            PCI

Warning: No installed USB configs!

And my graphics chipset is
Intel G41 Express Chipset

  • If you get lost, please remember Ctrl+Alt+F1 is your friend!

  • Print this page so you have it as a reference while in TTY2

  • Log off from the GUI

  • Switch to TTY2 by pressing Ctrl+Alt+F2

  • Log in there

  • Execute:

     sudo mhwd --remove pci video-linux
     sudo mhwd --install pci video-modesetting
  • reboot

If you get a black screen remove video-modesetting and put video-linux back, but I would be surprised as video-modesetting is from 2020 and video-linux from 2018…


I switched drivers. But, the same issue occurs when i switch back to OpenGL both 2.0 and 3.1.

In that case, I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back to your question after your issue has been solved and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

This topic was automatically closed 2 days after the last reply. New replies are no longer allowed.