Yt-dlp out of date in stable

According to /etc/pacman.d/mirrorlist I believe I’m on the stable branch. yt-dlp currently does not work and is version 2023.01.06. With yt-dlp -U it tells me there is a new version (which presumably fixes the issue) 2023.02.17, and I see this built in the arch repository (which I can’t link, cool forum), but pacman is quite adamant I’m on the latest version.

At packages dot manjaro dot org (which I also can’t link) I see the correct version in the “unstable” branch.

Is there a reason this has yet to be moved to stable? Is there a way for me to ask pacman to check unstable for that package only?

1 Like

Hi @Asday, and welcome!


Packages only end up in stable when they’ve been vetted and then promoted from unstable to testing and, finally, stable. So, in other words, just be patient. This is the curated part of Curated rolling release.

AFAIK not only that package, or at least I don’t know how if possible, but you can always switch branches, upgrade and then switch back.

But be warned: Since packages in the unstable branch have not yet been vetted, there exists the chance that you might experience breakage. You have been warned.

1 Like

Previously whenever youtube rolls out an update which breaks yt-dlp, they’re on it pretty quick, then it’s in the arch repositories even quicker, and I’ve never come across a gap in time between it hitting the arch repositories and needing to use it myself on manjaro.

The diff for this patch is one (or two, I forget) lines containing a simple regex change. Is there a way to find out what might be the holdup this time? Is there some mailing list to follow that a maintainer would post to when there are issues preventing migration?

you can switch branch to unstable, pacman -S yt-dlp and then switch back to stable. This way you won’t update your system to unstable, only the one package. Only caveat is that if the package needs other packages to also be updated to work, you need to also update those, and then those they need etc… this is why partial updates are risky. But since yt-dlp is not working for you now, it cannot get worse.

1 Like

To both these questions:


That’s just pure, pure, pure luck AFAIK. I’ve had it. But I lived with it. I’m sure you can too.

An impossibility, that.

You can edit your stable-branch version. source (…works fine)

In the file /usr/lib/python3.10/site-packages/yt_dlp/extractor/ change the following line (line 4049) (or comment it out by adding an octothorpe # in front of it):

'uploader_id': self._search_regex(r'/(?:channel|user)/([^/?&#]+)', owner_profile_url, 'uploader id') if owner_profile_url else None,

to this

'uploader_id': self._search_regex(r'/(?:channel/|user/|@)([^/?&#]+)', owner_profile_url, 'uploader id', default=None),

Now I feel old. Because, in my day it was called a hash symbol

1 Like

New users are not permitted to post active links. to prevent spam
But an inactive link can posted in preformatted text:

Whats next? Octothorpetag? :slight_smile:

1 Like

Something like that, it would seem…

There is roughly 2-4 weeks between unstable and stable - it has been this way for years


Unstable branch carries that name because otherwise the stable branch wouldn’t be necessary.

But as Manjaro ‘unstable’ matches - except kernels, nvidia and Manjaro apps - arch stable - there’s usually no problems with staying on unstable branch.

When I aquainted Manjaro back in 2016 I didn’t now of the branch concept - but when I realized the branch concept - I switched to unstable - been there ever since and I have never experienced serious issues that I didn’t cause myself.

When I saw the word octothorpe my first thought was Bell labs - and their name for the # on the phone - but that is because I have a brain which remembers the most odd and useless things.


Not a direct answer to your question — the other interlocutors have already answered that — but if you really need to get something off of YouTube really fast and you can’t wait, then you can always install clipgrab from the AUR. :arrow_down:

pamac build clipgrab

… or… :arrow_down:

yay -S clipgrab

It works like a charm, it has a GUI, and if you’re on Plasma, it’ll dock in the system tray. :slight_smile:

I resemble that comment. :stuck_out_tongue:



Seems like “octothorpe” is a much older name from around 1970. So I guess you should feel young instead :wink::smile:


Hey yes! In that case I’m not that old. Language has just come a full circle, apparently.

Octothorpe → Hash → octothorpe…

It it said that history repeats itself. Well, this is a clear example of it, I’d say…


The AUR also contains yt-dlp-git, for those who like to stick with yt-dlp.

Or you could pip install --upgrade yt-dlp, which (depending on your PATH, but worked for me without changing it) shadows the system-wide installation.

Why make live more difficult than it is already?
Check out FreeTube !!

Thanks. After performing the above “yt-dlp-2023-01-06” now works with mpv.

I made an account on this forum just to say this fixed also worked for me