Youtube-dl / yt-dlp not working


Just made the move from xubu to manj-xfce. Although there are a couple of quirky issues I can ignore for the most part, it’s more difficult to ignore that youtube-dl / yt-dlp fails when trying to download vids:

[user@home1 Videos]$ yt-dlp Iowvdr7R-jg
[youtube] Extracting URL: Iowvdr7R-jg
[youtube] Iowvdr7R-jg: Downloading webpage
[youtube] Iowvdr7R-jg: Downloading android player API JSON
ERROR: [youtube] Iowvdr7R-jg: Unable to extract uploader id; please report this issue on , filling out the appropriate issue template. Confirm you are on the latest version using  yt-dlp -U

And running yt-dlp -U of course shows that the package from the repos is not the lastest release, but I wonder if that is my issue as usually the versions on xubu stable are even older, but was working fine before I made the move:

[user@home1 Videos]$ yt-dlp -U
Latest version: 2023.03.04, Current version: 2023.01.06
ERROR: You installed yt-dlp with a package manager or; Use that to update

What’s the easy fix here, can anyone help? Thks.

The forum has a search function:


Except the post you link from searching doesn’t address my issue. The question in that post exclusively deals with upgrading an app to bleeding edge version and the response went on to discuss how to do that with the standard warning of doung so.

If you took the time to comprehend my question, while I acknowledged the version of youtbue-dl / yt-dlp from the pacmac repos isn’t the latest, nor does it seem like that is the issue, since I am almost certain the same app in xubuntu stable is the same or an even older version and was working fine just before I moved to manj-xfce recently.

Here’s another revelation: not only are the forums searchable, but belueve it or not, hold on for it, there are search engine that allow one to search outside of the forum on the World Wide Web. Wow!

And guess what? I actually did such a search and tried multiple fixes for any similarly issues addressed on pages and other forums where the same or similar questions were asked.

Too bad none of the proposed solutions worked. Therefire I resorted finally to risk asking on these forums first to see what tge consensus might be for a quick fix.

I’m sure glad you took the time for your reoly to explain the forum has a search funtion. Wow! What a beacon of knowledge you display. Amazing, or not so much.

Have you seen and tried @banjo’s (probable) answer?

You can edit your stable-branch version. source (…works fine)

In the file /usr/lib/python3.10/site-packages/yt_dlp/extractor/ change the following line (line 4049) (or comment it out by adding an octothorpe # in front of it):

'uploader_id': self._search_regex(r'/(?:channel|user)/([^/?&#]+)', owner_profile_url, 'uploader id') if owner_profile_url else None,

to this

'uploader_id': self._search_regex(r'/(?:channel/|user/|@)([^/?&#]+)', owner_profile_url, 'uploader id', default=None),


Because from what I see quickly, it is the same error. But I’m no expert, so might be wrong.

1 Like

Ups, just manj’d in a xubu - still have some pieces under my xfce. :foot: :crazy_face:



März 06, 2023




OP has the choice to change branches, use the git version

aur/yt-dlp-git 2023.03.03.r6.g283a0b5bc-1 (+33 3.27) 
    A youtube-dl fork with additional features and fixes (git)

…or edit the stable version.

1 Like



Please don’t invent abbreviations and expect everyone to know what you’re talking about.

Your flippant, sarcastic attitude is not welcome here. Please show respect for people that volunteer their free time to help others.

Please see:

What did you try? What was the result?

Either way, if the version in the repos is not working, just use the upstream binary and add it to your $PATH; i.e., ~/.local/bin/.

1 Like