Yellow Tint Filter on second Monitor

Hi, I’ve been searching numerous resources online including the bb archlinux forum about my problem.

The second monitor I have is a Lenovo L97 Wide wired over VGA on an HP 8470p running on an AMD graphics processor. The screen seems to have this yellowish tint on it.

Things I have tried:

1. Calibration through the Monitor’s inbuilt Color Adjustments.

Result: Nothing help on it, except the contrast around 40-50 which really dims my screen but the yellow tint seems to go away.

2. Using redshift manual assignment of the color temperature.

redshift -m randr:crtc=1 -O 16000

Result: Seems it helps but still dims my screen like a lot. I have set the Temp around 16000K, I know but my Eye is comfortable as long as the tint is gone but yeah, the screen really dims.

3. Turning Off Night Mode

Result: NO, just doesn’t help.

4. Tried Gamma correction on the laptop itself

Result: Worth the try bu now bot of the main screen and the Laptop screen is now messed up.

Here’s an actual image, thank god my white balance isn’t flushing it out.

I know, it might not be that much on picture but hell, in real life it is much worst than that.

Talking about hardware info:

System:    Kernel: 5.10.42-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 Desktop: KDE Plasma 5.21.5 Distro: Manjaro Linux 
           base: Arch Linux 
Machine:   Type: Laptop System: Hewlett-Packard product: HP EliteBook 8470p v: A1029D1102 serial: <filter> 
           Mobo: Hewlett-Packard model: 179B v: KBC Version 42.38 serial: <filter> UEFI: Hewlett-Packard v: 68ICF Ver. F.74 
           date: 04/11/2019 
CPU:       Info: Dual Core model: Intel Core i5-3320M bits: 64 type: MT MCP arch: Ivy Bridge rev: 9 cache: L2: 3 MiB 
           flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 vmx bogomips: 20756 
           Speed: 1224 MHz min/max: 1200/3300 MHz Core speeds (MHz): 1: 1224 2: 1211 3: 1216 4: 1548 
Graphics:  Device-1: Advanced Micro Devices [AMD/ATI] Thames [Radeon HD 7550M/7570M/7650M] vendor: Hewlett-Packard 
           driver: radeon v: kernel bus-ID: 01:00.0 
           Device-2: Primax HP HD Webcam [Fixed] type: USB driver: uvcvideo bus-ID: 1-1.3:5 
           Display: x11 server: X.Org 1.20.11 driver: loaded: ati,radeon unloaded: modesetting resolution: 1: 1600x900~60Hz 
           2: 900x1440~60Hz 
           OpenGL: renderer: AMD TURKS (DRM 2.50.0 / 5.10.42-1-MANJARO LLVM 11.1.0) v: 3.3 Mesa 21.0.3 direct render: Yes 
Audio:     Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Hewlett-Packard driver: snd_hda_intel v: kernel 
           bus-ID: 00:1b.0 
           Device-2: AMD Turks HDMI Audio [Radeon HD 6500/6600 / 6700M Series] vendor: Hewlett-Packard driver: snd_hda_intel 
           v: kernel bus-ID: 01:00.1 
           Sound Server-1: ALSA v: k5.10.42-1-MANJARO running: yes 
           Sound Server-2: JACK v: 0.125.0 running: no 
           Sound Server-3: PulseAudio v: 14.2 running: yes 
           Sound Server-4: PipeWire v: 0.3.28 running: no 
Network:   Device-1: Intel 82579LM Gigabit Network vendor: Hewlett-Packard driver: e1000e v: kernel port: 5020 bus-ID: 00:19.0 
           IF: eth0 state: down mac: <filter> 
           Device-2: Intel Centrino Advanced-N 6205 [Taylor Peak] driver: iwlwifi v: kernel port: 4000 bus-ID: 25:00.0 
           IF: wlan0 state: up mac: <filter> 
Bluetooth: Device-1: Broadcom HP Portable SoftSailing type: USB driver: btusb v: 0.8 bus-ID: 2-1.6:3 
           Report: rfkill ID: hci0 rfk-id: 1 state: up address: see --recommends 
Drives:    Local Storage: total: 298.09 GiB used: 64.43 GiB (21.6%) 
           ID-1: /dev/sda vendor: Western Digital model: WD3200LPVX-22V0TT0 size: 298.09 GiB 
Partition: ID-1: / size: 283.94 GiB used: 64.36 GiB (22.7%) fs: ext4 dev: /dev/sda2 
           ID-2: /boot/efi size: 299.4 MiB used: 312 KiB (0.1%) fs: vfat dev: /dev/sda1 
Swap:      ID-1: swap-1 type: partition size: 8.31 GiB used: 76 MiB (0.9%) dev: /dev/sda3 
Sensors:   System Temperatures: cpu: 57.0 C mobo: 54.0 C gpu: radeon temp: 55.0 C 
           Fan Speeds (RPM): N/A 
Info:      Processes: 234 Uptime: 45m Memory: 3.77 GiB used: 2.34 GiB (62.1%) Init: systemd Compilers: gcc: 11.1.0 
           clang: 11.1.0 Packages: 1611 Shell: Zsh v: 5.8 inxi: 3.3.04 

I just hope someone can figure out whats happening on this monitor. :frowning:

Thanks in advance

i wondered if it was vga when i saw the title. the way loose vga plugs lose connection often seems to be the blue pin first, so you only get the red and the green signals, which make yellow. physicially tighten it, or possibly replace the cable.


They’re pretty tight and had changed cables as well. I dont know if this is such a very bad monitor but at work, i usually have the same issue with the work pc. they even ran on DVI or display port but rarely hdmi. Lenovo as well, they’re just weird. I wondered quite a bit same as your suggestion but if the cable has been replaced, hardware related issue could be on the vga connector port itself but other than that changing cables has been done and no effect. Thanks by the way for the time.

  • Are you using a converter?
  • Have you tried another monitor yet? (E.G. Your TV)


I did try other monitor, works fine.
Nope not using a converter, vga is native to the laptop.

If the Lenovo L97 Wide is still under warranty: have it swapped as “defective”…


I’ve marked this answer as the solution to your question as it is by far the best answer you’ll get.

However, if you disagree with my choice, please feel free to take any other answer as the solution to your question or even remove the solution altogether: You are in control! (If you disagree with my choice, just send me a personal message and explain why I shouldn’t have done this or :heart: or :+1: if you agree)

P.S. In the future, please don’t forget to come back and click the 3 dots below the answer to mark a solution like this below the answer that helped you most:
so that the next person that has the exact same problem you just had will benefit from your post as well as your question will now be in the “solved” status.

Unfortunately the monitor is way too far from its warranty period, however i have a strange occurence where it works fine on windows because of the calibration system of windows, ive tried it on windows 7 and i was able to fix it except here in Manjaro. I’ll still have it open for now.

that doesn’t mean anything: Windows drivers get “fixed” to circumvent hardware problems.

Unfortunately, I’m all out of other bright ideas…


A post was split to a new topic: Gnome DE colour problems