XFCE installer does not recognise disk device

Upon launching the installer, I receive an error “There are no partitions to install on”, and the “Details…” menu tells me that the requirement for at least one disk drive is not satisfied. I have two hard drives physically installed.

The output for inxi -Fazy is as follows:

  Kernel: 5.13.13-1-MANJARO x86_64 bits: 64 compiler: gcc v: 11.1.0 
  parameters: BOOT_IMAGE=/boot/vmlinuz-x86_64 lang=en_US keytable=us tz=UTC 
  misobasedir=manjaro misolabel=MANJARO_XFCE_2112 quiet systemd.show_status=1 
  apparmor=1 security=apparmor driver=free nouveau.modeset=1 i915.modeset=1 
  Desktop: Xfce 4.16.0 tk: Gtk 3.24.29 info: xfce4-panel wm: xfwm 4.16.1 vt: 7 
  dm: LightDM 1.30.0 Distro: Manjaro Linux base: Arch Linux 
  Type: Desktop System: Gigabyte product: N/A v: N/A serial: <filter> Chassis: 
  type: 3 serial: <filter> 
  Mobo: Gigabyte model: Z77X-UD3H serial: <filter> UEFI: American Megatrends 
  v: F17 date: 08/22/2012 
  Info: Quad Core model: Intel Core i5-3570K bits: 64 type: MCP 
  arch: Ivy Bridge family: 6 model-id: 3A (58) stepping: 9 microcode: 21 
  cache: L2: 6 MiB 
  flags: avx lm nx pae sse sse2 sse3 sse4_1 sse4_2 ssse3 bogomips: 27238 
  Speed: 1602 MHz min/max: 1600/3800 MHz Core speeds (MHz): 1: 1602 2: 1665 
  3: 1671 4: 2135 
  Vulnerabilities: Type: itlb_multihit status: KVM: VMX unsupported 
  Type: l1tf mitigation: PTE Inversion 
  Type: mds mitigation: Clear CPU buffers; SMT disabled 
  Type: meltdown mitigation: PTI 
  Type: spec_store_bypass 
  mitigation: Speculative Store Bypass disabled via prctl and seccomp 
  Type: spectre_v1 
  mitigation: usercopy/swapgs barriers and __user pointer sanitization 
  Type: spectre_v2 mitigation: Full generic retpoline, IBPB: conditional, 
  IBRS_FW, STIBP: disabled, RSB filling 
  Type: srbds status: Vulnerable: No microcode 
  Type: tsx_async_abort status: Not affected 
  Message: No device data found. 
  Display: x11 server: X.Org 1.20.13 compositor: xfwm4 v: 4.16.1 driver: 
  loaded: ati,radeon unloaded: modesetting alternate: fbdev,vesa 
  display-ID: :0.0 screens: 1 
  Screen-1: 0 s-res: 1920x1080 s-dpi: 96 s-size: 508x285mm (20.0x11.2") 
  s-diag: 582mm (22.9") 
  Monitor-1: HDMI-0 res: 1920x1080 hz: 60 dpi: 102 
  size: 477x268mm (18.8x10.6") diag: 547mm (21.5") 
  OpenGL: renderer: AMD VERDE (DRM 2.50.0 5.13.13-1-MANJARO LLVM 12.0.1) 
  v: 4.5 Mesa 21.2.1 direct render: Yes 
  Device-1: Intel 7 Series/C216 Family High Definition Audio vendor: Gigabyte 
  driver: snd_hda_intel v: kernel bus-ID: 00:1b.0 chip-ID: 8086:1e20 
  class-ID: 0403 
  Device-2: AMD Oland/Hainan/Cape Verde/Pitcairn HDMI Audio [Radeon HD 7000 
  vendor: Pegatron driver: snd_hda_intel v: kernel bus-ID: 02:00.1 
  chip-ID: 1002:aab0 class-ID: 0403 
  Device-3: Creative Labs Sound Core3D [Sound Blaster Recon3D / Z-Series] 
  driver: snd_hda_intel v: kernel bus-ID: 04:00.0 chip-ID: 1102:0012 
  class-ID: 0403 
  Sound Server-1: ALSA v: k5.13.13-1-MANJARO running: yes 
  Sound Server-2: JACK v: 1.9.19 running: no 
  Sound Server-3: PulseAudio v: 15.0 running: yes 
  Sound Server-4: PipeWire v: 0.3.34 running: no 
  Device-1: Qualcomm Atheros AR8151 v2.0 Gigabit Ethernet vendor: Gigabyte 
  driver: atl1c v: kernel port: d000 bus-ID: 08:00.0 chip-ID: 1969:1083 
  class-ID: 0200 
  IF: enp8s0 state: up speed: 1000 Mbps duplex: full mac: <filter> 
  Local Storage: total: 57.68 GiB used: 0 KiB (0.0%) 
  ID-1: /dev/sda maj-min: 8:0 type: USB vendor: PNY model: USB 2.0 FD 
  size: 57.68 GiB block-size: physical: 512 B logical: 512 B type: N/A 
  serial: <filter> rev: PMAP scheme: MBR 
  SMART Message: Unknown USB bridge. Flash drive/Unsupported enclosure? 
  Message: No partition data found. 
  Alert: No swap data was found. 
  System Temperatures: cpu: 29.8 C mobo: 27.8 C gpu: radeon temp: 61.0 C 
  Fan Speeds (RPM): N/A 
  Processes: 219 Uptime: 11m wakeups: 0 Memory: 15.59 GiB 
  used: 1.97 GiB (12.6%) Init: systemd v: 248 tool: systemctl Compilers: 
  gcc: N/A Packages: pacman: 1122 lib: 305 flatpak: 0 Shell: Bash v: 5.1.8 
  running-in: xfce4-terminal inxi: 3.3.06 

GParted does not detect my drives either, only the boot stick.

Although it’s discouraged on this forum, I tried both RAID and EFI SATA modes in BIOS as well and of course neither one worked any better.

This looks like there could be a hardware incompatibility.

Hello @ranivacar :wink:

Page 49 and following: https://download1.gigabyte.com/Files/Manual/mb_manual_ga-z77x-ud3h_e.pdf

  1. Disable Intel RST
  2. Set AHCI mode

Update your UEFI…

The problem has been fixed, and the installer now works. I wish I could explain what I did but I’m not positive, it may have been in setting the UEFI to legacy/BIOS only instead of the opposite. I discovered that the problem had been solved looking for an update for the UEFI.

Nevermind. Turns out the drive it had newly recognized was the second USB stick I was going to load the UEFI update onto.

How would I update without a Windows OS or a second computer? Everything is .exe.

Windows is in fact unusable because of this lack of hard drive problem, the only place it could install previously was on the stick and it was completely unusable. The hard drive this may be a hardware problem (as @Wollie suggested), in which case I may look for another offsite forum for that.

Extract the exe and put it on a flash drive. Then update it on the UEFI. (Page 66)

Now there is a new problem and I cannot move the file to the USB drive, or find a solution on the internet. USB sticks are unable to be browsed and have blank properties

How would I look into this? I am starting to think the problem is physical.

Whoops, this was meant to be a reply to the flash drive instructions. @megavolt