Xampp not installing in Manjaro linux

I was trying to install Xampp app in my Manjaro XFCE
i executed the installer file and got this error


and I also tried to install it by Pacman and got some different error

here is my system specs

[ayushk@ayush-inspiron3541 ~]$ inxi -F
  Host: ayush-inspiron3541 Kernel: 5.10.60-1-MANJARO x86_64 bits: 64 
  Desktop: Xfce 4.16.0 Distro: Manjaro Linux 
  Type: Portable System: Dell product: Inspiron 3541 v: N/A 
  serial: <superuser required> 
  Mobo: Dell model: Inspiron 3541 v: A07 serial: <superuser required> 
  BIOS: Dell v: A07 date: 11/27/2015 
  Info: Quad Core model: AMD A6-6310 APU with AMD Radeon R4 Graphics 
  bits: 64 type: MCP cache: L2: 2 MiB 
  Speed: 1248 MHz min/max: 1000/1800 MHz Core speeds (MHz): 1: 1248 2: 1003 
  3: 1112 4: 1054 
  Device-1: AMD Mullins [Radeon R4/R5 Graphics] driver: radeon v: kernel 
  Device-2: Microdia Integrated_Webcam_HD type: USB driver: uvcvideo 
  Display: x11 server: X.Org 1.20.13 driver: loaded: ati,radeon 
  unloaded: modesetting resolution: 1366x768~60Hz 
  OpenGL: renderer: AMD KABINI (DRM 2.50.0 5.10.60-1-MANJARO LLVM 12.0.1) 
  v: 4.5 Mesa 21.2.1 
  Device-1: AMD Kabini HDMI/DP Audio driver: snd_hda_intel 
  Device-2: AMD FCH Azalia driver: snd_hda_intel 
  Sound Server-1: ALSA v: k5.10.60-1-MANJARO running: yes 
  Sound Server-2: PulseAudio v: 15.0 running: yes 
  Device-1: Realtek RTL810xE PCI Express Fast Ethernet driver: r8169 
  IF: enp2s0 state: down mac: 20:47:47:53:db:2d 
  Device-2: Qualcomm Atheros QCA9565 / AR9565 Wireless Network Adapter 
  driver: ath9k 
  IF: wlp3s0 state: up mac: b0:c0:90:62:24:ff 
  Device-1: Qualcomm Atheros AR9462 Bluetooth type: USB driver: btusb 
  Report: rfkill ID: hci0 state: up address: see --recommends 
  Local Storage: total: 465.76 GiB used: 52.54 GiB (11.3%) 
  ID-1: /dev/sda vendor: Seagate model: ST500LT012-1DG142 size: 465.76 GiB 
  ID-1: / size: 450.28 GiB used: 52.5 GiB (11.7%) fs: ext4 dev: /dev/sda1 
  ID-1: swap-1 type: partition size: 7.21 GiB used: 43.8 MiB (0.6%) 
  dev: /dev/sda2 
  System Temperatures: cpu: 73.0 C mobo: 55.0 C gpu: radeon temp: 68.0 C 
  Fan Speeds (RPM): cpu: 5238 
  Processes: 212 Uptime: 3h 35m Memory: 3.28 GiB used: 2.04 GiB (62.1%) 
  Shell: Bash inxi: 3.3.06 
[ayushk@ayush-inspiron3541 ~]$ 

Please help

Hi @ayush222006,

I might be wrong about this, but I think it’s because there isn’t a $BROWSER environment variable set. Please open a terminal, and run the following:


and provide the output here, wrapping it in 3 backticks (```) before and after the pasted text.

If confused, please see How to provide good information, specifically the section about pasting terminal output

I’m off now, but I suspect someone will be able to help further.

Hope you manage.

[ayushk@ayush-inspiron3541 ~]$  echo $BROWSER 

[ayushk@ayush-inspiron3541 ~]$ 

got nothing

You should echo $BROWSER not BROWSER, so run same command again, but this time with dollar sign.

[ayushk@ayush-inspiron3541 ~]$  echo $BROWSER 

[ayushk@ayush-inspiron3541 ~]$ 

got nothing

That’s what I suspected.

Which browser do you use? I’m suspecting it’s Chrome. In that case, please provide the output of:

which google-chrome-stable

I use Firefox browser every day

but I have brave browser installed too

here the output you asked for

[ayushk@ayush-inspiron3541 ~]$ which google-chrome-stable
which: no google-chrome-stable in (/home/ayushk/.local/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/var/lib/flatpak/exports/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/var/lib/snapd/snap/bin)
[ayushk@ayush-inspiron3541 ~]$ 

Tip: When pasting terminal output on Discourse forums using HTML, please use:


That way it’s monospaced and isn’t cut off on smaller screens.

I’ve done it for you this time. :wink:

Thanks for your correction and guidance, I would make sure of it next time
but where is the solution of my poblem
please help

solution was written at beginning , is at you to set in env BROWSER var, in ~/.bashrc or ~/.zshrc file , for you value is firefox

Thanks bro for your reply
can you please make it easy
as I am not able to understand it
you can provide step-by-step guidance if you can, I would very much appreciate it

To be able to do so, I need more information. Please open a terminal, and provide the output, like before, of the following command:

which firefox

Or, if you use Firefox developer edition, like me, the command is:

which firefox-developer-edition
[ayushk@ayush-inspiron3541 ~]$ which firefox
[ayushk@ayush-inspiron3541 ~]$ 

bro I don’t have developer edition installed in my laptop I use regular version
but I used this commond which you have given to me in regarding developer edition
and I got this

[ayushk@ayush-inspiron3541 ~]$ which firefox-developer-edition
which: no firefox-developer-edition in (/home/ayushk/.local/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/var/lib/flatpak/exports/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl:/var/lib/snapd/snap/bin)
[ayushk@ayush-inspiron3541 ~]$ 

That’s why I specifies that if you use it, but the first is correct, it would seem.

Now, we’ve got to add this to the .bashrc file. To do so, in an open terminal, run:

nano ~/.bashrc

(Or use your preferred text editor, if it’s not nano.)

Scroll to the bottom of the file, and add/insert the following line to export tthe $BROWSER environment variable:

export BROWSER=/usr/bin/firefox

Save the file and exit the editor.

When done, run the following in the terminal to enable the changes you just made:

source ~/.bashrc

If there are any errors, double check that ever6ything is right and try again. If no errors, try the setup again.

Report back if there are any errors and, if there are, what they are.

Bro thanks for the reply
I have followed all the guides you have instructed me to do
but It does not work
I am still getting the same error
which I was getting previously

I have added your command at the end of the file as follows

and used the command you have given me to use in terminal =

THIS CODE :arrow_up: :arrow_up: :arrow_up: :arrow_up:

This is the error I am getting now


the app installed and is working fine


But I am still getting this failed to execute default browser error